summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/babelfish/babelfish-0.5.5-r1.ebuild12
-rw-r--r--dev-python/babelfish/babelfish-9999.ebuild13
2 files changed, 6 insertions, 19 deletions
diff --git a/dev-python/babelfish/babelfish-0.5.5-r1.ebuild b/dev-python/babelfish/babelfish-0.5.5-r1.ebuild
index 878569ad886f..d279ec9809e2 100644
--- a/dev-python/babelfish/babelfish-0.5.5-r1.ebuild
+++ b/dev-python/babelfish/babelfish-0.5.5-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{6,7,8,9} )
inherit distutils-r1
@@ -14,11 +14,5 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE=""
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}"
-
-python_test() {
- esetup.py test
-}
+distutils_enable_tests setup.py
diff --git a/dev-python/babelfish/babelfish-9999.ebuild b/dev-python/babelfish/babelfish-9999.ebuild
index dcc8f1dacc4e..382197499a3f 100644
--- a/dev-python/babelfish/babelfish-9999.ebuild
+++ b/dev-python/babelfish/babelfish-9999.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-PYTHON_COMPAT=( python3_6 )
+PYTHON_COMPAT=( python3_{7,8,9} )
inherit distutils-r1 git-r3
@@ -13,12 +13,5 @@ EGIT_REPO_URI="https://github.com/Diaoul/${PN}.git"
LICENSE="BSD"
SLOT="0"
-KEYWORDS=""
-IUSE=""
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}"
-
-python_test() {
- esetup.py test
-}
+distutils_enable_tests setup.py