summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/libassuan/libassuan-2.5.4.ebuild2
-rw-r--r--net-analyzer/nagios-check_glsa2/files/nagios-check_glsa2-20120930-CACHEDIR.patch11
-rw-r--r--net-analyzer/nagios-check_glsa2/nagios-check_glsa2-20120930-r1.ebuild35
-rw-r--r--net-analyzer/nagios-plugins-snmp/nagios-plugins-snmp-0.6.0-r2.ebuild29
-rw-r--r--net-analyzer/nsca/nsca-2.7.2-r103.ebuild41
-rw-r--r--net-print/pnm2ppa/pnm2ppa-1.13-r1.ebuild23
6 files changed, 71 insertions, 70 deletions
diff --git a/dev-libs/libassuan/libassuan-2.5.4.ebuild b/dev-libs/libassuan/libassuan-2.5.4.ebuild
index eac69f3048fe..bfdc9bf52091 100644
--- a/dev-libs/libassuan/libassuan-2.5.4.ebuild
+++ b/dev-libs/libassuan/libassuan-2.5.4.ebuild
@@ -13,7 +13,7 @@ LICENSE="GPL-3 LGPL-2.1"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-RDEPEND=">=dev-libs/libgpg-error-1.8"
+RDEPEND=">=dev-libs/libgpg-error-1.17"
DEPEND="${RDEPEND}"
src_prepare() {
diff --git a/net-analyzer/nagios-check_glsa2/files/nagios-check_glsa2-20120930-CACHEDIR.patch b/net-analyzer/nagios-check_glsa2/files/nagios-check_glsa2-20120930-CACHEDIR.patch
new file mode 100644
index 000000000000..3e02afe6e004
--- /dev/null
+++ b/net-analyzer/nagios-check_glsa2/files/nagios-check_glsa2-20120930-CACHEDIR.patch
@@ -0,0 +1,11 @@
+--- a/check_glsa2_cached.sh
++++ b/check_glsa2_cached.sh
+@@ -8,7 +8,7 @@
+ # Caches the result of check_glsa2.sh
+ # First line is the return code, rest of the file is the message
+ NAME=$(basename $0 .sh)
+-CACHEDIR=/var/lib/gentoo/
++CACHEDIR=/var/cache/check_glsa2
+ CACHEFILE=${CACHEDIR}/check_glsa2.cache
+ SCRIPT=/usr/lib/nagios/plugins/check_glsa2.sh
+ ret=0
diff --git a/net-analyzer/nagios-check_glsa2/nagios-check_glsa2-20120930-r1.ebuild b/net-analyzer/nagios-check_glsa2/nagios-check_glsa2-20120930-r1.ebuild
index 5b6ab2dd057a..aba3bf1143f7 100644
--- a/net-analyzer/nagios-check_glsa2/nagios-check_glsa2-20120930-r1.ebuild
+++ b/net-analyzer/nagios-check_glsa2/nagios-check_glsa2-20120930-r1.ebuild
@@ -1,38 +1,31 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
-
-inherit multilib user
-
-DESCRIPTION="Nagios check script for GLSAs (Gentoo Linux Security Advisories)"
-HOMEPAGE="https://github.com/craig/check_glsa2"
+EAPI=7
MY_PN="${PN/nagios-/}"
MY_P="${MY_PN}-${PV}"
-S="${WORKDIR}/${MY_P}"
+DESCRIPTION="Nagios check script for GLSAs (Gentoo Linux Security Advisories)"
+HOMEPAGE="https://github.com/craig/check_glsa2"
SRC_URI="https://dev.gentoo.org/~flameeyes/${MY_PN}/${MY_P}.tar.xz"
+
LICENSE="GPL-2 BSD-2"
SLOT="0"
-
KEYWORDS="amd64"
-RDEPEND="app-portage/gentoolkit"
-DEPEND=""
-
-pkg_setup() {
- enewgroup nagios
- enewuser nagios -1 /bin/bash /dev/null nagios
-}
+DEPEND="
+ acct-group/nagios
+ acct-user/nagios"
+RDEPEND="
+ ${DEPEND}
+ app-portage/gentoolkit"
-src_prepare() {
- sed -i -e '/CACHEDIR=/s:=.*:=/var/cache/check_glsa2:' ${MY_PN}_cached.sh || die
-}
+S="${WORKDIR}/${MY_P}"
+PATCHES=( "${FILESDIR}"/${PN}-20120930-CACHEDIR.patch )
src_install() {
- local nagiosplugindir=/usr/$(get_libdir)/nagios/plugins
- exeinto ${nagiosplugindir}
+ exeinto /usr/$(get_libdir)/nagios/plugins
doexe *.sh
dodoc README
diff --git a/net-analyzer/nagios-plugins-snmp/nagios-plugins-snmp-0.6.0-r2.ebuild b/net-analyzer/nagios-plugins-snmp/nagios-plugins-snmp-0.6.0-r2.ebuild
index c89ed52c8249..6eb4daae21ea 100644
--- a/net-analyzer/nagios-plugins-snmp/nagios-plugins-snmp-0.6.0-r2.ebuild
+++ b/net-analyzer/nagios-plugins-snmp/nagios-plugins-snmp-0.6.0-r2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
-inherit autotools user
+inherit autotools
DESCRIPTION="Additional Nagios plugins for monitoring SNMP capable devices"
HOMEPAGE="http://nagios.manubulon.com"
@@ -12,31 +12,28 @@ SRC_URI="http://nagios.manubulon.com/${P}.tgz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~ppc ppc64 ~sparc x86"
-IUSE=""
-DEPEND="net-analyzer/net-snmp"
+DEPEND="
+ acct-group/nagios
+ acct-user/nagios
+ net-analyzer/net-snmp"
RDEPEND="${DEPEND}"
-S=${WORKDIR}/nagios-plugins-snmp
-
-pkg_setup() {
- enewgroup nagios
- enewuser nagios -1 /bin/bash /var/nagios/home nagios
-}
+S="${WORKDIR}/nagios-plugins-snmp"
src_prepare() {
- sed -i -e '/^CFLAGS=""/d' configure.in
+ default
+ sed -i -e '/^CFLAGS=""/d' configure.in || die
+ mv configure.{in,ac} || die
eautoreconf
}
src_configure() {
econf \
- --sysconfdir=/etc/nagios \
- --libexec=/usr/$(get_libdir)/nagios/plugins
+ --sysconfdir="${EPREFIX}"/etc/nagios \
+ --libexec="${EPREFIX}"/usr/$(get_libdir)/nagios/plugins
}
-DOCS=( README NEWS AUTHORS )
-
src_install() {
default
diff --git a/net-analyzer/nsca/nsca-2.7.2-r103.ebuild b/net-analyzer/nsca/nsca-2.7.2-r103.ebuild
index 9fe0ae002f79..c7120d06b665 100644
--- a/net-analyzer/nsca/nsca-2.7.2-r103.ebuild
+++ b/net-analyzer/nsca/nsca-2.7.2-r103.ebuild
@@ -1,9 +1,7 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
-
-inherit multilib user eutils
+EAPI=7
DESCRIPTION="Nagios Service Check Acceptor"
HOMEPAGE="https://www.nagios.org/"
@@ -15,28 +13,29 @@ KEYWORDS="~alpha amd64 ~arm ppc ppc64 sparc x86"
IUSE="tcpd +crypt minimal"
DEPEND="crypt? ( >=dev-libs/libmcrypt-2.5.1-r4 )
- !minimal? ( tcpd? ( sys-apps/tcp-wrappers ) )"
-
+ !minimal? (
+ tcpd? ( sys-apps/tcp-wrappers )
+ acct-group/icinga
+ acct-group/nagios
+ acct-user/icinga
+ acct-user/nagios
+ )"
RDEPEND="${DEPEND}
- !minimal? ( || ( net-analyzer/icinga net-analyzer/nagios ) )
+ !minimal? (
+ || (
+ net-analyzer/icinga
+ net-analyzer/nagios
+ )
+ )
sys-apps/openrc"
-pkg_setup() {
- if ! use minimal; then
- enewgroup nagios
- enewgroup icinga
- enewuser nagios -1 /bin/bash /var/nagios/home nagios
- enewuser icinga -1 -1 /var/lib/icinga "icinga,nagios"
- fi
-}
-
src_configure() {
use tcpd || export ac_cv_lib_wrap_main=no
use crypt || export ac_cv_path_LIBMCRYPT_CONFIG=/bin/false
econf \
- --localstatedir=/var/nagios \
- --sysconfdir=/etc/nagios \
+ --localstatedir="${EPREFIX}"/var/nagios \
+ --sysconfdir="${EPREFIX}"/etc/nagios \
--with-nsca-user=nagios \
--with-nsca-grp=nagios
}
@@ -49,7 +48,7 @@ src_compile() {
-e '/nsca_\(user\|group\)/s:nagios:icinga:' \
-e '/nsca_chroot/s:=.*:=/var/lib/icinga/rw:' \
-e '/\(command\|alternate_dump\)_file/s:/var/nagios:/var/lib/icinga:' \
- "${S}"/sample-config/nsca.cfg > "${T}"/nsca.icinga.cfg
+ "${S}"/sample-config/nsca.cfg > "${T}"/nsca.icinga.cfg || die
}
src_install() {
@@ -58,7 +57,7 @@ src_install() {
dobin src/send_nsca
insinto /etc/nagios
- doins "${S}"/sample-config/send_nsca.cfg
+ doins sample-config/send_nsca.cfg
if ! use minimal; then
exeinto /usr/libexec
@@ -68,7 +67,7 @@ src_install() {
newconfd "${FILESDIR}"/nsca.conf nsca
insinto /etc/nagios
- doins "${S}"/sample-config/nsca.cfg
+ doins sample-config/nsca.cfg
insinto /etc/icinga
newins "${T}"/nsca.icinga.cfg nsca.cfg
@@ -79,7 +78,7 @@ pkg_postinst() {
if ! use minimal; then
elog "If you are using the nsca daemon, remember to edit"
elog "the config file /etc/nagios/nsca.cfg"
- elog ""
+ elog
elog "If you intend to use nsca with Icinga, change the"
elog "configuration file path in /etc/conf.d/nsca so that"
elog "it will default to the correct paths and users."
diff --git a/net-print/pnm2ppa/pnm2ppa-1.13-r1.ebuild b/net-print/pnm2ppa/pnm2ppa-1.13-r1.ebuild
index 55c86714e946..bab71f44628c 100644
--- a/net-print/pnm2ppa/pnm2ppa-1.13-r1.ebuild
+++ b/net-print/pnm2ppa/pnm2ppa-1.13-r1.ebuild
@@ -1,17 +1,15 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
-
-inherit base
+EAPI=7
DESCRIPTION="Print driver for Hp Deskjet 710, 712, 720, 722, 820, 1000 series"
HOMEPAGE="http://pnm2ppa.sourceforge.net"
SRC_URI="mirror://sourceforge/pnm2ppa/${P}.tar.gz"
-KEYWORDS="~amd64 ~x86"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
IUSE="syslog"
# en on first place so others can override it
@@ -25,8 +23,7 @@ RDEPEND="
net-print/cups
>=net-print/cups-filters-1.0.43-r1[foomatic]
sys-libs/glibc
- syslog? ( virtual/logger )
-"
+ syslog? ( virtual/logger )"
DEPEND="${RDEPEND}"
src_configure() {
@@ -65,13 +62,17 @@ src_install() {
exeinto /etc/pdq/drivers/ghostscript
doexe pdq/gs-pnm2ppa
+
exeinto /etc/pdq/interfaces
doexe pdq/dummy
# install docs
- cd docs/en
+ cd docs/en || die
dodoc CALIBRATION*txt COLOR*txt PPA*txt RELEASE* CREDITS README sgml/*.sgml
- cd "${S}"
- dohtml -r .
+ cd "${S}" || die
+ docinto html/docs/en
+ dodoc docs/en/*.html
+ docinto html/ppa_protocol
+ dodoc ppa_protocol/*.html
}