summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/apispec/Manifest1
-rw-r--r--dev-python/apispec/apispec-6.8.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/apispec/Manifest b/dev-python/apispec/Manifest
index 3c5fde1cfaf0..86febf789a1a 100644
--- a/dev-python/apispec/Manifest
+++ b/dev-python/apispec/Manifest
@@ -1 +1,2 @@
DIST apispec-6.7.1.tar.gz 76714 BLAKE2B ced24f5d455d02a64bbcd098d892bf5f37275eb6cc3ea445b97f89b8e21d0446ae069e1086cdd9c833135931fa3ddf0694eddf10fbbbd81986a59c79f4faf42c SHA512 97a0800f95301b249c57b05560ef45912462c3754f1923530bdfbbbd5e6968f2b1a8174470a5fdb06368d8541a6ef2c76e4964e98cfb47eea0715e1e7abaac7f
+DIST apispec-6.8.0.tar.gz 76919 BLAKE2B c97f9a87175755c517a22ebbe66c1fb058b89f370a89f09af1007664519d95cf5938e1b699062f9b7f643bc3263a2055487996f759e0e64e2e2038d36e552525 SHA512 ad8b155dcc373f2423153a4b17d3b446a188e8835ea971496818a93bea098b641a3663dc75b6cd8b92a92de607ddc64fb9b13ad10356e6eeb05e4ff9918e9ecf
diff --git a/dev-python/apispec/apispec-6.8.0.ebuild b/dev-python/apispec/apispec-6.8.0.ebuild
new file mode 100644
index 000000000000..b4c64b64045b
--- /dev/null
+++ b/dev-python/apispec/apispec-6.8.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A pluggable API specification generator"
+HOMEPAGE="
+ https://github.com/marshmallow-code/apispec/
+ https://pypi.org/project/apispec/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.10[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/bottle[${PYTHON_USEDEP}]
+ >=dev-python/marshmallow-3.18.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/sphinx-issues \
+ dev-python/sphinx-rtd-theme
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # requires unpackaged prance
+ tests/test_ext_marshmallow_openapi.py::test_openapi_tools_validate_v2
+ tests/test_ext_marshmallow_openapi.py::test_openapi_tools_validate_v3
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}