summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--eclass/systemd.eclass4
-rw-r--r--x11-misc/bbkeys/bbkeys-0.9.2.ebuild2
-rw-r--r--x11-wm/blackbox/blackbox-0.76-r1.ebuild3
3 files changed, 5 insertions, 4 deletions
diff --git a/eclass/systemd.eclass b/eclass/systemd.eclass
index 81065a0af79a..ab0d65619843 100644
--- a/eclass/systemd.eclass
+++ b/eclass/systemd.eclass
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 2011-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# @ECLASS: systemd.eclass
@@ -58,7 +58,7 @@ _systemd_get_dir() {
echo "${d}"
}
-# @FUNCTION: _systemd_get_unitdir
+# @FUNCTION: _systemd_get_systemunitdir
# @INTERNAL
# @DESCRIPTION:
# Get unprefixed unitdir.
diff --git a/x11-misc/bbkeys/bbkeys-0.9.2.ebuild b/x11-misc/bbkeys/bbkeys-0.9.2.ebuild
index 703e7c8eff6e..cd8940c01e51 100644
--- a/x11-misc/bbkeys/bbkeys-0.9.2.ebuild
+++ b/x11-misc/bbkeys/bbkeys-0.9.2.ebuild
@@ -35,7 +35,7 @@ src_prepare() {
src_install() {
default
- rm -rf "${ED%/}"/usr/share/doc || die
+ rm -rf "${ED}"/usr/share/doc || die
echo PRELINK_PATH_MASK=\""${EPREFIX}"/usr/bin/bbkeys\" > "${T}"/99bbkeys || die
doenvd "${T}"/99bbkeys
diff --git a/x11-wm/blackbox/blackbox-0.76-r1.ebuild b/x11-wm/blackbox/blackbox-0.76-r1.ebuild
index 81e924b915bf..50375072373b 100644
--- a/x11-wm/blackbox/blackbox-0.76-r1.ebuild
+++ b/x11-wm/blackbox/blackbox-0.76-r1.ebuild
@@ -12,7 +12,7 @@ SRC_URI="https://github.com/bbidulock/blackboxwm/archive/${PV}.tar.gz -> ${P}.ta
LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="nls truetype debug"
+IUSE="debug nls static-libs truetype"
RDEPEND="x11-libs/libXft
x11-libs/libXt
@@ -51,4 +51,5 @@ src_install() {
dodoc AUTHORS ChangeLog* COMPLIANCE README* TODO
find "${D}" -name '*.la' -delete || die
+ use static-libs || rm /usr/$(get_libdir)/libbt.a || die
}