summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/actionpack/Manifest1
-rw-r--r--dev-ruby/actionpack/actionpack-7.0.8.7.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/dev-ruby/actionpack/Manifest b/dev-ruby/actionpack/Manifest
index 24fb4236ccf2..ac173bf4288f 100644
--- a/dev-ruby/actionpack/Manifest
+++ b/dev-ruby/actionpack/Manifest
@@ -4,6 +4,7 @@ DIST rails-6.1.7.9.tgz 11034686 BLAKE2B 12edf62a94e0b504f1db721081ce35a6b7e8f67b
DIST rails-7.0.8.4.tgz 11082427 BLAKE2B 2ca521ad92b7a33fa2160b4cfbc1aac826641d2aac7a8751b6acaed1b7fc42bb860b4ade3f973eb51dc17d20fa4c97b02e8d6b970ae63b042cd58ab2f6cfc797 SHA512 e6628e901fcdcd4b9101cdae0cd556569fc7b577466a15f99d1e221c1c0059287dce87c1362df8b23ded992e96c551b35c0c789e683f080079e678555b7a79e6
DIST rails-7.0.8.5.tgz 11073275 BLAKE2B f2d45a577a53d7741b1efab59991f8242cf76e96267f174d268026e9b1c543d95346a38312ba32a00793082dc441130f1132c3bdab5203f5015ea8ce2534bbbe SHA512 c00b0156382aaf18f2ba78ed531778c00dabfe30729681cb79be6adeb9fca15592255f6e1fb606930487c491c5fdb57aaaec955b828c3bc843913dba10e7ccc9
DIST rails-7.0.8.6.tgz 11073387 BLAKE2B 94f86f41013c9929721786aaf668844915f340d490df1028218942192756404683736060b8bf23e04f431496d121245aae02c62f472cd482db3c9a21b0afca09 SHA512 0a302c395e0b00948b2c99096c6c240479bbd12110ab47d05771308676d35c22755ccc7888ebf37d650ac0ed7a21a0f2cfc7f366a051ae12ecae9e7f7f9624cd
+DIST rails-7.0.8.7.tgz 11083317 BLAKE2B 055a4930a1076bbdab294393ea1423d043e0679bef0be262189c6e0a7825000eb32bbf8d30982a456f289d3748818d254b4482ae117798663f424bd719d452f8 SHA512 4a480278eea63962aba6a6e5d9c0c2f18c6af4e98a0de1bcb7a87c90ebece16bada9cebef1a88f141ebafac9741ef16c818b9fa04625ba7bb345726258a0bcd7
DIST rails-7.1.4.2.tgz 10930504 BLAKE2B 711cc97232e3ed54c76641fe2e50c4c0b2f97f5152be38dbdf1eb8a48b63cfb363612bf1f55fa42ed8f2fcccc3a4ecd59f5651d7afef883f54b7d19896ce0de0 SHA512 87f8be5be37a68943bdb53eec34a1f34d43bb39a12c82990b8e123c7bb9824be854e4dfc2f431f5c021beefc813a282132dd950cbf1a74118c3d79ad72a4a074
DIST rails-7.1.5.tgz 10933914 BLAKE2B 4af6c007b3ae0b28dff6bd603ae06e516079f95e8d9613c76e3d2c415fd8e88dec89cfa3c3ecf23079ae9fdcdfcbc1de18edaf2e576e5726dc0410e6568aa46e SHA512 b25039975e52f9a6b5b5f5554f25adf29dca9d006274ff8cb05513acdae89b53aafa9b722d7332e4a7a2c50feb5b51a423453535d80ab564c03e672ec85f3185
DIST rails-7.2.1.2.tgz 11062632 BLAKE2B bea7bce77556b4ee8b58a7b77df5f333379af9c6d0226bf3f5033bc416e55bf0926dd72e0509ccf3eb173ffdbb2aa2fb4b4ee762b3a57d7a5de2200d4b08e6a0 SHA512 8ec9b6ab4f0898e99b9aa9bb9d741510216e3ebff695d451e5691f0d32e8cb18d40c1a7310e16cc4bb1f55f1dd88ca7242a6165190311d11b13e6e2046da63cc
diff --git a/dev-ruby/actionpack/actionpack-7.0.8.7.ebuild b/dev-ruby/actionpack/actionpack-7.0.8.7.ebuild
new file mode 100644
index 000000000000..bf3a73b339b6
--- /dev/null
+++ b/dev-ruby/actionpack/actionpack-7.0.8.7.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32"
+
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="actionpack.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Eases web-request routing, handling, and response"
+HOMEPAGE="https://github.com/rails/rails"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="test"
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ ~dev-ruby/activesupport-${PV}
+ ~dev-ruby/actionview-${PV}
+ dev-ruby/rack:2.2
+ >=dev-ruby/rack-test-0.6.3:*
+ >=dev-ruby/rails-html-sanitizer-1.2.0:1
+ dev-ruby/rails-dom-testing:2
+"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/mocha:0.14
+ dev-ruby/bundler
+ >=dev-ruby/capybara-3.26
+ ~dev-ruby/activemodel-${PV}
+ ~dev-ruby/railties-${PV}
+ >=dev-ruby/rack-cache-1.2:1.2
+ dev-ruby/selenium-webdriver:4
+ www-servers/puma
+ <dev-ruby/minitest-5.16:*
+ )"
+
+all_ruby_prepare() {
+ eapply "${FILESDIR}/actionpack-7.0.4-rack-test-2.patch"
+
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|execjs\|jquery-rails\|'mysql'\|journey\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|sprockets-rails\|redcarpet\|bcrypt\|uglifier\|sprockets\|stackprof\)/ s:^:#:" \
+ -e '/:job/,/end/ s:^:#:' \
+ -e '/group :doc/,/^end/ s:^:#:' \
+ -i ../Gemfile || die
+ rm ../Gemfile.lock || die
+
+ sed -e '3igem "rack", "<3"; gem "minitest", "<5.16"; gem "railties", "~> 7.0.0"; gem "activemodel", "~> 7.0.0"; require "ostruct"' \
+ -i test/abstract_unit.rb || die
+
+ # Use different timezone notation, this changed at some point due to an external dependency changing.
+ sed -e 's/-0000/GMT/' \
+ -i test/dispatch/response_test.rb test/dispatch/cookies_test.rb test/dispatch/session/cookie_store_test.rb || die
+
+ # Avoid tests that fail with a fixed cgi.rb version
+ sed -e '/test_session_store_with_all_domains/askip "Fails with fixed cgi.rb"' \
+ -i test/dispatch/session/cookie_store_test.rb || die
+}