summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-geosciences/josm-bin/Manifest1
-rw-r--r--sci-geosciences/josm-bin/josm-bin-18646.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/sci-geosciences/josm-bin/Manifest b/sci-geosciences/josm-bin/Manifest
index d311207a843b..f90ed9361e02 100644
--- a/sci-geosciences/josm-bin/Manifest
+++ b/sci-geosciences/josm-bin/Manifest
@@ -1,2 +1,3 @@
DIST josm-snapshot-18583.jar 16269996 BLAKE2B 1f661090db02278a05f457093ac6ff8aff060c00ead6347e283892e114ea7bf5c0a96279dd645cf97cbb45a3bf8f8919b5523cc847f52b703b19c4bfa909f463 SHA512 04cd705e745357cc6169a2d12bf7ca9b91615201976326d52dc468921ea959f281d30ff2be8eeb2fbde9e780ca588e6240538036d2cdf66b0316def28dbbf684
DIST josm-snapshot-18622.jar 16311954 BLAKE2B 01d033cb4105f192ef14176dca79667ef2df95a55507df47dd5d163025d7460246fcc5524133e08e9ee77ee3073dce819072470d3898620d7ed9c5eedd405a34 SHA512 7220c007b87b5128bf9a4ace9a61d2fff4a22834248c85c4b3ab96db7d364f4adc63aa2167419f2418f4c3fb1f96bd3cd6ef05727bc1c4cd46280dc161b4fbe2
+DIST josm-snapshot-18646.jar 16326607 BLAKE2B 8735298e268f2b516f235e7368a44e638455dffc9ab5d8c07672bb2053227bb15473cd71ce1f8b08e3e3dc43ed4c240aab8a9f2b4632cf6d59a30a49a70302a6 SHA512 34fa30e7fdea179efd63c7e68617dec8c3bd3060f5cef57e93bd3cc856495a1b6f7254e84880867467fc1ff09102bbaa1e4e108d0cd8a174e327d261c68ad992
diff --git a/sci-geosciences/josm-bin/josm-bin-18646.ebuild b/sci-geosciences/josm-bin/josm-bin-18646.ebuild
new file mode 100644
index 000000000000..1aba0e7ffd7b
--- /dev/null
+++ b/sci-geosciences/josm-bin/josm-bin-18646.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop java-utils-2 xdg
+
+DESCRIPTION="Java-based editor for the OpenStreetMap project"
+HOMEPAGE="https://josm.openstreetmap.de/"
+# PV should be stable here https://josm.openstreetmap.de/wiki/StartupPage
+SRC_URI="https://josm.openstreetmap.de/download/josm-snapshot-${PV}.jar"
+S="${WORKDIR}"
+
+LICENSE="Apache-2.0 GPL-2+ GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=virtual/jre-1.8"
+BDEPEND="app-arch/unzip"
+
+src_install() {
+ java-pkg_newjar "${DISTDIR}/${A}" ${PN}.jar
+ java-pkg_dolauncher ${PN} --jar ${PN}.jar
+
+ local icon_size
+ for icon_size in 16 32 48; do
+ newicon -s ${icon_size} -t hicolor \
+ images/logo_${icon_size}x${icon_size}x32.png ${PN}.png
+ newicon -s ${icon_size} -t locolor \
+ images/logo_${icon_size}x${icon_size}x8.png ${PN}.png
+ done
+ make_desktop_entry ${PN} "Java OpenStreetMap Editor" ${PN} "Utility;Science;Geoscience"
+}