summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-text/dvisvgm/Manifest1
-rw-r--r--app-text/dvisvgm/dvisvgm-3.0.1.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/app-text/dvisvgm/Manifest b/app-text/dvisvgm/Manifest
index fc6aa6c95976..56560a914cc2 100644
--- a/app-text/dvisvgm/Manifest
+++ b/app-text/dvisvgm/Manifest
@@ -1,3 +1,4 @@
DIST dvisvgm-2.12.tar.gz 3164951 BLAKE2B 249f1ee43444ac95ed512eac803ab073e1ec04a58266fc569a272014510ab373890fdc7be2207d2037742f4192e266eb214078c0bb448de953ffdf5c29deabba SHA512 3f0ca530f24a8866839d71093dc6fd84f2a0f984d06cdd189425aeeb7c7e7e3c9e283d1fe2e7e9ec79845f36c8bd4d973224a321b8ad39da229a3b4fd59b7008
DIST dvisvgm-2.13.tar.gz 3174723 BLAKE2B bee6efd0fd32b1b0c116820df955a3b76cfd795acb75063f35bf2b6b15b6bacc8ddc60d9622d8554c80f7c2ab44c85c78a120d4e18fd7a0c902eabb70b6060fc SHA512 264643f9d9dcfa7e1d20df31c3514108ed45c88e0bd0f1ce88c37af22ae57447d624537720e902c5e5e799906d567999c9449fea411f755e75e4c4158e37de30
DIST dvisvgm-2.14.tar.gz 3192670 BLAKE2B 16b290db680c57babba06d97250b26925223984af807695a5b24b2e134a0d41e0b7292efd47e6781e75c4790c3e6482d3447e8a5ad7e25b9b36526ba033d15d4 SHA512 874d2d3deed2b1c1cd3e459a53d43533e7fc19613ad2ade09fdf303cedfecd8091d944933c30a7107aad2e8901cc23f1debd4e36031a90b1ad8ba2f56d2a3ba6
+DIST dvisvgm-3.0.1.tar.gz 2897716 BLAKE2B 52574002b285191cbeb878f94440451beb10291fe5fadacffa59ed6da181c525053ffddd3cd3570d7357941825df4449c311e86bd25b530de505cbeae865e180 SHA512 1ddee12735883c814cdd3c647e902f8372dbe82693b9a599fb752509a184174e376d028c0fee5e11d23115ae94f34e04fb44fe1f8f20f4d599dc92229a2dd94d
diff --git a/app-text/dvisvgm/dvisvgm-3.0.1.ebuild b/app-text/dvisvgm/dvisvgm-3.0.1.ebuild
new file mode 100644
index 000000000000..f057d03f29d8
--- /dev/null
+++ b/app-text/dvisvgm/dvisvgm-3.0.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Converts DVI files to SVG"
+HOMEPAGE="https://dvisvgm.de/"
+SRC_URI="https://github.com/mgieseki/dvisvgm/releases/download/${PV}/${P}.tar.gz"
+
+# dvisvgm: GPL-3
+# Boost (tiny part, one header): Boost-1.0
+# md5: || ( public-domain BSD-1 )
+# clipper: Boost-1.0
+# variant: Boost-1.0
+LICENSE="GPL-3 Boost-1.0 || ( public-domain BSD-1 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos"
+IUSE="test"
+
+# Tests don't work from ${WORKDIR}: kpathsea tries to search in relative
+# directories from where the binary is executed.
+# We cannot really use absolute paths in the kpathsea configuration since that
+# would make it harder for prefix installs.
+RESTRICT="test"
+
+RDEPEND="
+ >=app-arch/brotli-1.0.5:=
+ app-text/ghostscript-gpl:=
+ dev-libs/kpathsea:=
+ dev-libs/openssl:=
+ >=dev-libs/xxhash-0.8.1
+ >=media-gfx/potrace-1.10-r1
+ media-libs/freetype:2
+ >=media-libs/woff2-1.0.2
+ sys-libs/zlib
+ virtual/tex-base
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( >=dev-cpp/gtest-1.11 )
+"
+BDEPEND="
+ app-text/asciidoc
+ app-text/xmlto
+ dev-libs/libxslt
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local myargs=(
+ --disable-bundled-libs
+ --without-ttfautohint
+ )
+
+ econf "${myargs[@]}"
+}