summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-lang/typescript/Manifest1
-rw-r--r--dev-lang/typescript/typescript-5.4.4.ebuild39
2 files changed, 0 insertions, 40 deletions
diff --git a/dev-lang/typescript/Manifest b/dev-lang/typescript/Manifest
index e755f76b59d63..c5666049d8906 100644
--- a/dev-lang/typescript/Manifest
+++ b/dev-lang/typescript/Manifest
@@ -1,2 +1 @@
-DIST typescript-5.4.4.tgz 5825725 BLAKE2B 98ebd2f2c3472b7944009f672d647d34540b3cb331fb02d41069df572dc10a0f19c08aee7a12c0536e6d3895502e4a8c11b8ff0c1dcb2d58e0398795f2ce50fe SHA512 74613656ff1ca55bf0dbcbfc1c23eac9bd3c1336c1511c43a6e849bd3aeeb128547c69e11c169f0ec2dd4b5121871c8be8125013ed9c4f77433c0bfe310ea82f
DIST typescript-5.4.5.tgz 5825770 BLAKE2B aea24c0924b2a0b0d01face2ce6be4e7fac85c2205cb0ecde492c5301f83d55fd8cd501326bd47f90cd78abf48c7aaf0381b13fc8242f3d2f9235e6051860b2b SHA512 bdc23852946083cd68211505c11d164881cab75d6727b48056560d22ef90a6a7b25cffa0a50272fd9e3e174686c5213832ac23c97bd6fd3ce090b031d80187c1
diff --git a/dev-lang/typescript/typescript-5.4.4.ebuild b/dev-lang/typescript/typescript-5.4.4.ebuild
deleted file mode 100644
index 761177a3441e5..0000000000000
--- a/dev-lang/typescript/typescript-5.4.4.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 2021-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DESCRIPTION="Superset of JavaScript with optional static typing, classes and interfaces"
-HOMEPAGE="https://www.typescriptlang.org/
- https://github.com/microsoft/TypeScript/"
-SRC_URI="https://registry.npmjs.org/${PN}/-/${P}.tgz"
-S="${WORKDIR}"/package
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 ~ppc64"
-
-RDEPEND="net-libs/nodejs"
-BDEPEND=">=net-libs/nodejs-16[npm]"
-
-src_compile() {
- # Skip, nothing to compile here.
- :
-}
-
-src_install() {
- local myopts=(
- --audit false
- --color false
- --foreground-scripts
- --global
- --offline
- --omit dev
- --prefix "${ED}"/usr
- --progress false
- --verbose
- )
- npm ${myopts[@]} install "${DISTDIR}"/${P}.tgz || die "npm install failed"
-
- dodoc *.md *.txt
-}