summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-debug/d-spy/Manifest1
-rw-r--r--dev-debug/d-spy/d-spy-47.0.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-debug/d-spy/Manifest b/dev-debug/d-spy/Manifest
index ecd9544cef2a..5f1ac75cc157 100644
--- a/dev-debug/d-spy/Manifest
+++ b/dev-debug/d-spy/Manifest
@@ -1,2 +1,3 @@
DIST d-spy-1.10.0.tar.xz 213044 BLAKE2B acb4d99e6f9be8ed86685c9deeb705727ac2b9522e701daa38e7baa84d37a585effda9c871d2cce814fff4dc240c585b6679d95a56b457434d0ce9e721ce3e29 SHA512 89f28ac2cc1799f7ad053da0c3995627c567ec224dc2267aac2fe6a2305d8580712c2ae3b4a86f86547f4bd7ac0462d2c6768bee3049cb449c4b6b00ce216cd6
DIST d-spy-1.8.0.tar.xz 232944 BLAKE2B cb6f90e9b3d779aa5a76bc93f16e9ae677af029b72451bbb983ffeb06b99a92aa2402ef8b6f6a6c6b4ad4f6ba49a924db37d7e9fc9cb98157a6475a0ec234267 SHA512 49c0ff250a91110014f98453ed6958cf4b5191cc0c8d31c5e63b1408864eaf0906ab3860b0479400a04a8614ee36fe5b9527b179e6346bdb5616cb188d2648f0
+DIST d-spy-47.0.tar.xz 219464 BLAKE2B 4bdb51df9ecb051408ce265a41ccdd3d74afbebb57e09d12a50cd525084b2446a09dd668b4440e5bfae64ca1044b6c331ccc8163100fa026bb1b697bfa5074ed SHA512 da5275691ab29ced7a125bf9411a8bae4388ea6f940c8e4f5a0764e18e9d1909abfe4d5c13e4cbd3405d106929bbbf6ba15f45c509d3396906311f5d453b2df2
diff --git a/dev-debug/d-spy/d-spy-47.0.ebuild b/dev-debug/d-spy/d-spy-47.0.ebuild
new file mode 100644
index 000000000000..d1d45beb5510
--- /dev/null
+++ b/dev-debug/d-spy/d-spy-47.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org meson xdg
+
+DESCRIPTION="D-Spy is a simple tool to explore D-Bus connections"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/d-spy"
+
+LICENSE="GPL-3+ LGPL-3+"
+SLOT="1"
+KEYWORDS="~amd64 ~arm64"
+
+DEPEND="
+ >=dev-libs/glib-2.76:2
+ >=gui-libs/gtk-4.12:4
+ >=gui-libs/libadwaita-1.4:1
+"
+RDEPEND="
+ ${DEPEND}
+ >=sys-apps/dbus-1
+"
+BDEPEND="
+ dev-libs/appstream-glib
+ dev-util/desktop-file-utils
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dbuilder=false
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}