summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-emulation/vagrant/Manifest1
-rw-r--r--app-emulation/vagrant/vagrant-2.2.7.ebuild90
-rw-r--r--dev-python/flake8/Manifest1
-rw-r--r--dev-python/flake8/flake8-2.5.4.ebuild52
-rw-r--r--dev-python/pep8/Manifest1
-rw-r--r--dev-python/pep8/pep8-1.5.6.ebuild35
-rw-r--r--dev-python/pyflakes/Manifest1
-rw-r--r--dev-python/pyflakes/pyflakes-0.8.1.ebuild26
-rw-r--r--mail-filter/opendkim/files/opendkim-2.10.3-lua-pkgconfig.patch174
-rw-r--r--mail-filter/opendkim/opendkim-2.10.3-r18.ebuild228
-rw-r--r--media-sound/xmms2/files/xmms2-0.8_p20161122-gcc-10.patch11
-rw-r--r--media-sound/xmms2/xmms2-0.8_p20161122-r5.ebuild3
12 files changed, 507 insertions, 116 deletions
diff --git a/app-emulation/vagrant/Manifest b/app-emulation/vagrant/Manifest
index b063bb21fc8e..1f6359608f65 100644
--- a/app-emulation/vagrant/Manifest
+++ b/app-emulation/vagrant/Manifest
@@ -1 +1,2 @@
DIST vagrant-2.2.6.tar.gz 1285530 BLAKE2B 802537b56429366ab0dab08d5490f2a5c1ec3810e9c04573ccd11f27078fc375f092ed70b27a7846813cbde5fdce0aa90399eba07e19a9d6ae7e11cb47204efe SHA512 6d8b5b1d4e5cc482404cf4c59e1b7cf9502a9819569b5098e44874733cee706f26adb4ac7994abe7e3307ca69d3003e2604dc859ce460c53d766d78b8d9fe22a
+DIST vagrant-2.2.7.tar.gz 2173893 BLAKE2B bf905cb25a905e4fb79ce9c1fb59ad5520b5176d5681dfdc22855ca0a7520535346d2aebffe47162a1f8ca008083c94426e9de92b6d92de4373c654784605c7e SHA512 3455b74c8a867ab37ca9873187a98cdb80feb22a400c4e9f2266897da815815aaefbe0c166172b1c1dbd66aa49ccb1201dcbf904fd883ad34218d694e20d7f87
diff --git a/app-emulation/vagrant/vagrant-2.2.7.ebuild b/app-emulation/vagrant/vagrant-2.2.7.ebuild
new file mode 100644
index 000000000000..d81979d0d04a
--- /dev/null
+++ b/app-emulation/vagrant/vagrant-2.2.7.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+RUBY_FAKEGEM_GEMSPEC="vagrant.gemspec"
+RUBY_FAKEGEM_EXTRAINSTALL="keys plugins templates version.txt"
+RUBY_FAKEGEM_TASK_DOC=""
+
+inherit bash-completion-r1 ruby-fakegem
+
+DESCRIPTION="A tool for building and distributing development environments"
+HOMEPAGE="https://vagrantup.com/"
+SRC_URI="https://github.com/hashicorp/vagrant/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+virtualbox"
+RESTRICT="test"
+
+RDEPEND="${RDEPEND}
+ app-arch/libarchive
+ net-misc/curl
+ virtualbox? ( || ( app-emulation/virtualbox app-emulation/virtualbox-bin ) )"
+
+ruby_add_rdepend "
+ >=dev-ruby/bcrypt_pbkdf-1.0.0
+ >=dev-ruby/childprocess-0.6.0
+ >=dev-ruby/ed25519-1.2.4
+ >=dev-ruby/erubis-2.7.0
+ >=dev-ruby/hashicorp-checkpoint-0.1.5
+ >=dev-ruby/i18n-1.1.1:1
+ >=dev-ruby/listen-3.1.5
+ <dev-ruby/log4r-1.1.11
+ <dev-ruby/mime-types-3:*
+ >=dev-ruby/net-ssh-5.1.0:*
+ >=dev-ruby/net-sftp-2.1
+ >=dev-ruby/net-scp-1.2.0
+ dev-ruby/rest-client:2
+ >=dev-ruby/rubyzip-1.3:1
+ >=dev-ruby/vagrant_cloud-2.0.3
+"
+
+# upstream specifies rake>=12 but it apparently doesn't need something this
+# recent. Because vagrant builds fine with rake 10 and because stabilizing rake
+# is tricky, we specify a lower dependency requirement here. This way, we'll be
+# able to stabilize vagrant sooner.
+ruby_add_bdepend "
+ >=dev-ruby/rake-10.5.0
+"
+
+all_ruby_prepare() {
+ # remove bundler support
+ sed -i '/[Bb]undler/d' Rakefile || die
+ rm Gemfile || die
+
+ # loosen dependencies
+ sed -e '/hashicorp-checkpoint\|i18n\|listen\|net-ssh\|net-scp\|rake\|childprocess/s/~>/>=/' \
+ -e '/ruby_dep/s/<=/>=/' \
+ -i ${PN}.gemspec || die
+
+ # remove windows-specific gems
+ sed -e '/wdm\|winrm/d' \
+ -i ${PN}.gemspec || die
+
+ # remove bsd-specific gems
+ sed -e '/rb-kqueue/d' \
+ -i ${PN}.gemspec || die
+
+ sed -e "s/@VAGRANT_VERSION@/${PV}/g" "${FILESDIR}/${PN}.in" > "${PN}" || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ newbashcomp contrib/bash/completion.sh ${PN}
+
+ # provide executable similar to upstream:
+ # https://github.com/hashicorp/vagrant-installers/blob/master/substrate/modules/vagrant_installer/templates/vagrant.erb
+ dobin "${PN}"
+
+ # directory for plugins.json
+ keepdir /var/lib/vagrant
+
+ insinto /usr/share/vim/vimfiles/syntax/
+ doins contrib/vim/vagrantfile.vim
+}
diff --git a/dev-python/flake8/Manifest b/dev-python/flake8/Manifest
index a23e729810eb..5432131e6a91 100644
--- a/dev-python/flake8/Manifest
+++ b/dev-python/flake8/Manifest
@@ -1,3 +1,2 @@
-DIST flake8-2.5.4.tar.gz 81663 BLAKE2B 89bd5965fe1f6862cadbfc7b614a819a13d4ab147994485542ba519d6151ab11d4b496066c74141020858f468050e7b6dc3d6ce3a89ddf809e9cdc6d130984ef SHA512 31cbec556fc41361ac464d2547275e319ab663c907a4a8644113a2288a9f349bcfbec85197b6dfa13a7db9e82419f01e0f2abc84a347e133c144ea137e0daa28
DIST flake8-3.5.0.tar.gz 140608 BLAKE2B 938ad4406370da27155512355432edd23a824db1d6ee635591628fefad43ee1116256ae7f240496d93941800212ea2479be73fb9ee9bd03c9a54ab70bbce452f SHA512 ac5d1bd9c44ed76c9e5cbd941b24bb552aa76e156b24ccda6cc8440ee90f3a574fdb393665adc75298e4f57111d7ab3115ef21ef9088fb327d0a9703d442450c
DIST flake8-3.7.9.tar.gz 150123 BLAKE2B fd46710c0dcce7d3dcb3d5fc8ff7a83a35315679fa838e68abafd5bdc342c13218706fec0dac3fc9a6d919971f1f846c855f00cbd60c925e979378e431dace0b SHA512 c3c753ad050d8a8f87f7c28c8a1c953ed9bd04f08b09512d9323152b4eebb57d67fbfb0f5317d629174fa12fa234e1a86d6a633dd951fff6a45330b1c4f62850
diff --git a/dev-python/flake8/flake8-2.5.4.ebuild b/dev-python/flake8/flake8-2.5.4.ebuild
deleted file mode 100644
index 23f202f65ff9..000000000000
--- a/dev-python/flake8/flake8-2.5.4.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="A wrapper around PyFlakes, pep8 & mccabe"
-HOMEPAGE="https://bitbucket.org/tarek/flake8 https://pypi.org/project/flake8/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-KEYWORDS="~alpha amd64 arm ~arm64 hppa ia64 ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="test"
-RESTRICT="!test? ( test )"
-LICENSE="MIT"
-SLOT="0"
-
-# requires.txt inc. mccabe however that creates a circular dep
-RDEPEND="
- >=dev-python/pyflakes-0.8.1[${PYTHON_USEDEP}]
- <dev-python/pyflakes-1.1[${PYTHON_USEDEP}]
- >=dev-python/pep8-1.5.7[${PYTHON_USEDEP}]
- !=dev-python/pep8-1.6.1[${PYTHON_USEDEP}]
- !=dev-python/pep8-1.6.2[${PYTHON_USEDEP}]
- "
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( ${PDEPEND}
- dev-python/nose[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7)
- >=dev-python/mccabe-0.2.1[${PYTHON_USEDEP}]
- <dev-python/mccabe-0.5[${PYTHON_USEDEP}]
- )"
-PDEPEND="
- >=dev-python/mccabe-0.2.1[${PYTHON_USEDEP}]
- <dev-python/mccabe-0.5[${PYTHON_USEDEP}]"
-
-python_prepare_all() {
- # This tests requires / assumes this version is already installed.
- sed -e 's:test_register_extensions:_&:' -i flake8/tests/test_engine.py || die
-
- # Gentoo has flake8 support restored in >=pep8-1.6.2-r1.
- sed -e 's:, != 1.6.2::' -i setup.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- esetup.py test
-}
diff --git a/dev-python/pep8/Manifest b/dev-python/pep8/Manifest
index 4359c4c7a517..cc45297fb7b4 100644
--- a/dev-python/pep8/Manifest
+++ b/dev-python/pep8/Manifest
@@ -1,4 +1,3 @@
-DIST pep8-1.5.6.tar.gz 66944 BLAKE2B 5875895eb21c771d21cb1c415dc9f85737ae18ab10cb9ab64c758cc0fb834387b6815751cdebefeef9ea2d9a17f7c67d54d4f435a64a005213f3406d11e0e1a8 SHA512 9de60df0f56eeb28be835b3f11d060150e08c19403552b769abe0794a1aca65e3a17fd8b45f35b34b11593f527c2f4521ab72823aa1475963b1281c044c71ec1
DIST pep8-1.5.7.tar.gz 67302 BLAKE2B 714ecb7f21c457aca1a2465319c3f202d13b5cfe067418eb2e3e6f21b25dffbab891a05f5b145264e484c180b67e1fc8c4ad1cf47f1413ebeaff2bb858f9858e SHA512 ae5cc6cc47d71e90059fec0c89f5e8e7b71b08d185c95b0c8cf0aa9acaee4841d0cfc617fb1ca6d7af7f4721480a1992b6178dc845d80dfe87fe3792d515a3eb
DIST pep8-1.7.0.tar.gz 79704 BLAKE2B f2e3585bdb3732f9be7f77b1cbf065c0938c1847a5caeb493e3cd62e6a5e19713779a087ffdc9c627481fb10e13d3ed53b3bc368182c2442f24ad57d1d2e96d3 SHA512 0077dac97846fe3a5fc654cd3ce8578845cf3b93ee097a3ae6ff2db4ae0797ad5766c69f036d6a5add786eb929a9beb6d657ab693227b8df2ba46ec0f9284b0a
DIST pep8-1.7.1.tar.gz 80334 BLAKE2B 71a038c8fbcbd7c94ff713d1eb8fa248106d283fb520f97fe35819b14382eff6e55683b739acd933cfe22001ed262f76a9b6f3f55661938b3b199ec1f4c35745 SHA512 d20d6a6f91bc865580e3d39c50e26f9c6be81fd8e80a1b9a029d7ea9c906748e46080b841dc5507004089e5ee0d0cb3f70a74bb35131c58113ff5571153af4da
diff --git a/dev-python/pep8/pep8-1.5.6.ebuild b/dev-python/pep8/pep8-1.5.6.ebuild
deleted file mode 100644
index f1d0cb4bf99d..000000000000
--- a/dev-python/pep8/pep8-1.5.6.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="Python style guide checker"
-HOMEPAGE="https://github.com/jcrocholl/pep8 https://pypi.org/project/pep8/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ia64 ppc ppc64 s390 x86 ~amd64-linux ~x86-linux"
-IUSE="doc"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-RDEPEND="${DEPEND}"
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- PYTHONPATH="${S}" "${PYTHON}" pep8.py -v --testsuite=testsuite || die
- PYTHONPATH="${S}" "${PYTHON}" pep8.py --doctest -v || die
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/pyflakes/Manifest b/dev-python/pyflakes/Manifest
index 35c9f7b12859..030d4604c267 100644
--- a/dev-python/pyflakes/Manifest
+++ b/dev-python/pyflakes/Manifest
@@ -1,3 +1,2 @@
-DIST pyflakes-0.8.1.tar.gz 32981 BLAKE2B a4d02202e5cc9e1174d9296834edae7bc2c3d66e0081979438ceaa80dab9dcf41710b23015f8fcabea062d7dbb249ffc7521657d0860fd115cf58b441721b778 SHA512 b9843637891f3e82a8430121395ceb4ec5df48b5ba73b96a307ebcb4a393e8cebee1681e094ee1f71a85b58bd2f32562b78fbd61d3fa85634f3ac448b1244637
DIST pyflakes-1.6.0.tar.gz 48184 BLAKE2B a5762c23521aa68ea92537fbc2903bb7af64faf8d1fafc97e48e003f529f8c16ae8dca444c9122fc5c50618fec7120b2f2b2e6682e1d86e502ab49096cb42bfc SHA512 7e9c2aad6ebed638a1354cef51c7e1f68b25e59f8caf4694997a9afecd7cd8baa629a9363297ac0d961430f007fd22dcae7dae1bcbd7838a3b5d4285063bc7c5
DIST pyflakes-2.1.1.tar.gz 58072 BLAKE2B 68dccddae2a9dc77f2d1f1251c80e2552935281b6b79e55fd2a0805cb30bf5e1c227b60a7e1f55f5f92ac42dfd18a69eb0b76ce06f43ac1c48dde3921817a271 SHA512 7ebf5843b38146305c1063e070480fea8ec3b47fa1be546b1fafaeb242a688a5a001f978e7257fd71d5905b9a338b466ef17c7330725191587e9c40ba632c3f8
diff --git a/dev-python/pyflakes/pyflakes-0.8.1.ebuild b/dev-python/pyflakes/pyflakes-0.8.1.ebuild
deleted file mode 100644
index eeabddc9f4cf..000000000000
--- a/dev-python/pyflakes/pyflakes-0.8.1.ebuild
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="Passive checker for Python programs"
-HOMEPAGE="https://launchpad.net/pyflakes https://pypi.org/project/pyflakes/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm ~arm64 hppa ia64 ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}"
-
-DOCS=(AUTHORS NEWS.txt README.rst)
-
-python_test() {
- esetup.py test --quiet
-}
diff --git a/mail-filter/opendkim/files/opendkim-2.10.3-lua-pkgconfig.patch b/mail-filter/opendkim/files/opendkim-2.10.3-lua-pkgconfig.patch
new file mode 100644
index 000000000000..ee8d5769f76a
--- /dev/null
+++ b/mail-filter/opendkim/files/opendkim-2.10.3-lua-pkgconfig.patch
@@ -0,0 +1,174 @@
+From 1f1c947a983c49677544ab08dea3ea04869a8caf Mon Sep 17 00:00:00 2001
+From: Michael Orlitzky <michael@orlitzky.com>
+Date: Sun, 26 Jan 2020 22:29:16 -0500
+Subject: [PATCH 1/1] configure.ac: check for "lua" with pkg-config in addition
+ to "lua5.1".
+
+The upstream Lua pkg-config file is named lua.pc, so unless some
+distribution renames it, OpenDKIM should be looking for "lua"
+and not "lua5.1" in its PKG_CHECK_MODULES call. In any case, we
+should definitely be checking for "lua", so this commit appends it
+to the list of modules we look for. The "lua5.1" module was left
+alone, because I don't know enough of the history to be sure that
+removing it is the right thing to do.
+
+When the call to PKG_CHECK_MODULES fails, OpenDKIM falls back to
+a manual search that looks in /usr/lib, and this can detect 32-bit
+libraries on a 64-bit system. Therefore it is preferable that the
+PKG_CHECK_MODULES call succeed.
+
+In the process of adding this fallback, I realized that some
+additional actions need to be performed in the success branch of
+the existing (and new) PKG_CHECK_MODULES call. The following
+three lines were added,
+
+ AC_SEARCH_LIBS([dlopen], [dl])
+ AC_SUBST([LUA_MANNOTICE], "")
+ AC_DEFINE([USE_LUA], 1, [support for Lua scripting])
+
+to tell various parts of OpenDKIM that we do indeed have Lua support.
+Afterwards, it became clear that those three lines could be factored
+out of *every* lua check, so that has been done as well.
+
+Closes: https://github.com/trusteddomainproject/OpenDKIM/issues/62
+Gentoo-bug: https://bugs.gentoo.org/704556
+---
+ configure.ac | 45 +++++++++++++++++----------------------------
+ 1 file changed, 17 insertions(+), 28 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index a478bb83..1d0db41a 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -1495,12 +1495,20 @@ lua_found="no"
+
+ if test \( x"$luapath" = x"auto" -o x"$luapath" = x"yes" \) -a x"$PKG_CONFIG" != x""
+ then
+- PKG_CHECK_MODULES([LIBLUA], [lua5.1],
+- [
+- lua_found="yes"
+- LIBLUA_INCDIRS="$LIBLUA_CFLAGS"
+- ],
+- [AC_MSG_WARN([pkg-config for Lua not found, trying manual search...])])
++ PKG_CHECK_MODULES([LIBLUA], [lua5.1], [
++ LIBLUA_INCDIRS="$LIBLUA_CFLAGS"
++ lua_found="yes"
++ ],
++ [
++ AC_MSG_WARN([pkg-config for lua5.1 not found, trying lua...])
++ PKG_CHECK_MODULES([LIBLUA], [lua], [
++ LIBLUA_INCDIRS="$LIBLUA_CFLAGS"
++ lua_found="yes"
++ ],
++ [AC_MSG_WARN([pkg-config for lua not found, trying manual search...])]
++ )
++ ]
++ )
+ fi
+
+ if test \( x"$luapath" = x"yes" -o x"$luapath" = x"auto" \) -a x"$lua_found" = x"no"
+@@ -1515,10 +1523,6 @@ then
+ LIBLUA_INCDIRS="-I$d/include/lua51"
+ LIBLUA_LIBDIRS="-L$d/lib/lua51"
+ LIBLUA_LIBS="-llua -lm"
+- AC_SEARCH_LIBS([dlopen], [dl])
+- AC_DEFINE([USE_LUA], 1,
+- [support for Lua scripting])
+- AC_SUBST([LUA_MANNOTICE], "")
+ lua_found="yes"
+ break
+ elif test -f $d/include/lua52/lua.h
+@@ -1527,10 +1531,6 @@ then
+ LIBLUA_INCDIRS="-I$d/include/lua52"
+ LIBLUA_LIBDIRS="-L$d/lib/lua52"
+ LIBLUA_LIBS="-llua -lm"
+- AC_SEARCH_LIBS([dlopen], [dl])
+- AC_DEFINE([USE_LUA], 1,
+- [support for Lua scripting])
+- AC_SUBST([LUA_MANNOTICE], "")
+ lua_found="yes"
+ break
+ elif test -f $d/include/lua5.1/lua.h
+@@ -1539,10 +1539,6 @@ then
+ LIBLUA_INCDIRS="-I$d/include/lua5.1"
+ LIBLUA_LIBDIRS="-L$d/lib"
+ LIBLUA_LIBS="-llua5.1 -lm"
+- AC_SEARCH_LIBS([dlopen], [dl])
+- AC_DEFINE([USE_LUA], 1,
+- [support for Lua scripting])
+- AC_SUBST([LUA_MANNOTICE], "")
+ lua_found="yes"
+ break
+ elif test -f $d/include/lua5.2/lua.h
+@@ -1551,10 +1547,6 @@ then
+ LIBLUA_INCDIRS="-I$d/include/lua5.2"
+ LIBLUA_LIBDIRS="-L$d/lib"
+ LIBLUA_LIBS="-llua5.2 -lm"
+- AC_SEARCH_LIBS([dlopen], [dl])
+- AC_DEFINE([USE_LUA], 1,
+- [support for Lua scripting])
+- AC_SUBST([LUA_MANNOTICE], "")
+ lua_found="yes"
+ break
+ elif test -f $d/include/lua.h
+@@ -1563,7 +1555,6 @@ then
+ LIBLUA_INCDIRS="-I$d/include"
+ LIBLUA_LIBDIRS="-L$d/lib"
+ LIBLUA_LIBS="-llua -lm"
+- AC_SEARCH_LIBS([dlopen], [dl])
+ lua_found="yes"
+ break
+ fi
+@@ -1588,7 +1579,6 @@ then
+ LIBLUA_INCDIRS="-I$luapath/include/lua51"
+ LIBLUA_LIBDIRS="-L$luapath/lib/lua51"
+ LIBLUA_LIBS="-llua -lm"
+- AC_SEARCH_LIBS([dlopen], [dl])
+ lua_found="yes"
+ elif test -f $luapath/include/lua52/lua.h
+ then
+@@ -1596,7 +1586,6 @@ then
+ LIBLUA_INCDIRS="-I$luapath/include/lua52"
+ LIBLUA_LIBDIRS="-L$luapath/lib/lua52"
+ LIBLUA_LIBS="-llua -lm"
+- AC_SEARCH_LIBS([dlopen], [dl])
+ lua_found="yes"
+ elif test -f $luapath/include/lua5.1/lua.h
+ then
+@@ -1604,7 +1593,6 @@ then
+ LIBLUA_INCDIRS="-I$luapath/include/lua5.1"
+ LIBLUA_LIBDIRS="-L$luapath/lib"
+ LIBLUA_LIBS="-llua5.1 -lm"
+- AC_SEARCH_LIBS([dlopen], [dl])
+ lua_found="yes"
+ elif test -f $luapath/include/lua5.2/lua.h
+ then
+@@ -1612,7 +1600,6 @@ then
+ LIBLUA_INCDIRS="-I$luapath/include/lua5.2"
+ LIBLUA_LIBDIRS="-L$luapath/lib"
+ LIBLUA_LIBS="-llua5.2 -lm"
+- AC_SEARCH_LIBS([dlopen], [dl])
+ lua_found="yes"
+ elif test -f $luapath/include/lua.h
+ then
+@@ -1620,7 +1607,6 @@ then
+ LIBLUA_INCDIRS="-I$luapath/include"
+ LIBLUA_LIBDIRS="-L$luapath/lib"
+ LIBLUA_LIBS="-llua -lm"
+- AC_SEARCH_LIBS([dlopen], [dl])
+ lua_found="yes"
+ else
+ AC_MSG_ERROR(not found at $luapath)
+@@ -1629,6 +1615,9 @@ fi
+
+ if test x"$lua_found" = x"yes"
+ then
++ AC_SUBST([LUA_MANNOTICE], "")
++ AC_DEFINE([USE_LUA], 1, [support for Lua scripting])
++ AC_SEARCH_LIBS([dlopen], [dl])
+ saved_CPPFLAGS="$CPPFLAGS"
+ CPPFLAGS="$outer_CPPFLAGS $LIBLUA_INCDIRS"
+ AC_MSG_CHECKING([Lua version])
+--
+2.24.1
+
diff --git a/mail-filter/opendkim/opendkim-2.10.3-r18.ebuild b/mail-filter/opendkim/opendkim-2.10.3-r18.ebuild
new file mode 100644
index 000000000000..260010392d11
--- /dev/null
+++ b/mail-filter/opendkim/opendkim-2.10.3-r18.ebuild
@@ -0,0 +1,228 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools db-use eutils systemd tmpfiles
+
+DESCRIPTION="A milter providing DKIM signing and verification"
+HOMEPAGE="http://opendkim.org/"
+SRC_URI="https://downloads.sourceforge.net/project/opendkim/${P}.tar.gz"
+
+# The GPL-2 is for the init script, bug 425960.
+LICENSE="BSD GPL-2 Sendmail-Open-Source"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="berkdb ldap libressl lmdb lua memcached opendbx poll sasl selinux +ssl static-libs stats querycache test unbound"
+
+BDEPEND="acct-user/opendkim
+ test? ( dev-lang/lua:* )"
+
+COMMON_DEPEND="|| ( mail-filter/libmilter mail-mta/sendmail )
+ dev-libs/libbsd
+ sys-apps/grep
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )
+ berkdb? ( >=sys-libs/db-3.2:* )
+ opendbx? ( >=dev-db/opendbx-1.4.0 )
+ lua? ( dev-lang/lua:* )
+ ldap? ( net-nds/openldap )
+ lmdb? ( dev-db/lmdb )
+ memcached? ( dev-libs/libmemcached )
+ sasl? ( dev-libs/cyrus-sasl )
+ unbound? ( >=net-dns/unbound-1.4.1:= net-dns/dnssec-root )
+ !unbound? ( net-libs/ldns )"
+
+DEPEND="${COMMON_DEPEND}"
+
+RDEPEND="${COMMON_DEPEND}
+ acct-user/opendkim
+ sys-process/psmisc
+ selinux? ( sec-policy/selinux-dkim )"
+
+REQUIRED_USE="sasl? ( ldap )
+ stats? ( opendbx )
+ querycache? ( berkdb )"
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+ "${FILESDIR}/${P}-openrc.patch"
+ "${FILESDIR}/${P}-openssl-1.1.1.patch.r2"
+ "${FILESDIR}/${P}-lua-pkgconfig.patch"
+)
+
+src_prepare() {
+ default
+ sed -e 's:/var/db/dkim:/var/lib/opendkim:g' \
+ -i opendkim/opendkim.conf.sample opendkim/opendkim.conf.simple.in \
+ || die
+ sed -e 's:dist_doc_DATA:dist_html_DATA:' \
+ -i libopendkim/docs/Makefile.am \
+ || die
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=()
+ if use berkdb ; then
+ myconf+=( --with-db-incdir=$(db_includedir) )
+ fi
+ if use unbound; then
+ myconf+=( --with-unbound )
+ else
+ myconf+=( --with-ldns )
+ fi
+ if use ldap; then
+ myconf+=( $(use_with sasl) )
+ fi
+
+ # We install the our configuration filed under e.g. /etc/opendkim,
+ # so the next line is necessary to point the daemon and all of its
+ # documentation to the right location by default.
+ myconf+=( --sysconfdir="${EPREFIX}/etc/${PN}" )
+
+ econf \
+ $(use_with berkdb db) \
+ $(use_with opendbx odbx) \
+ $(use_with lua) \
+ $(use_enable lua rbl) \
+ $(use_with ldap openldap) \
+ $(use_with lmdb) \
+ $(use_enable poll) \
+ $(use_enable querycache query_cache) \
+ $(use_enable static-libs static) \
+ $(use_enable stats) \
+ $(use_with memcached libmemcached) \
+ "${myconf[@]}" \
+ --enable-filter \
+ --enable-atps \
+ --enable-identity_header \
+ --enable-rate_limit \
+ --enable-resign \
+ --enable-replace_rules \
+ --enable-default_sender \
+ --enable-sender_macro \
+ --enable-vbr \
+ --disable-live-testing \
+ --with-test-socket="${T}/opendkim.sock"
+}
+
+src_compile() {
+ emake runstatedir=/run
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -type f -delete || die
+
+ dosbin stats/opendkim-reportstats
+
+ newinitd "${S}/contrib/OpenRC/opendkim.openrc" "${PN}"
+ systemd_newtmpfilesd "${S}/contrib/systemd/opendkim.tmpfiles" "${PN}.conf"
+ systemd_newunit "contrib/systemd/opendkim.service" "${PN}.service"
+
+ dodir /etc/opendkim
+ keepdir /var/lib/opendkim
+
+ # The OpenDKIM data (particularly, your keys) should be read-only to
+ # the UserID that the daemon runs as.
+ fowners root:opendkim /var/lib/opendkim
+ fperms 750 /var/lib/opendkim
+
+ # Tweak the "simple" example configuration a bit before installing
+ # it unconditionally.
+ local cf="${T}/opendkim.conf"
+ # Some MTAs are known to break DKIM signatures with "simple"
+ # canonicalization [1], so we choose the "relaxed" policy
+ # over OpenDKIM's current default settings.
+ # [1] https://wordtothewise.com/2016/12/dkim-canonicalization-or-why-microsoft-breaks-your-mail/
+ sed -E -e 's:^(Canonicalization)[[:space:]]+.*:\1\trelaxed/relaxed:' \
+ "${S}/opendkim/opendkim.conf.simple" >"${cf}" || die
+ cat >>"${cf}" <<EOT || die
+
+# The UMask is really only used for the PID file (root:root) and the
+# local UNIX socket, if you're using one. It should be 0117 for the
+# socket.
+UMask 0117
+UserID opendkim
+
+# For use with unbound
+#TrustAnchorFile /etc/dnssec/root-anchors.txt
+EOT
+ insinto /etc/opendkim
+ doins "${cf}"
+}
+
+pkg_postinst() {
+ tmpfiles_process "${PN}.conf"
+ if [[ -z ${REPLACING_VERSION} ]]; then
+ elog "If you want to sign your mail messages and need some help"
+ elog "please run:"
+ elog " emerge --config ${CATEGORY}/${PN}"
+ elog "It will help you create your key and give you hints on how"
+ elog "to configure your DNS and MTA."
+
+ elog "If you are using a local (UNIX) socket, then you will"
+ elog "need to make sure that your MTA has read/write access"
+ elog "to the socket file. This is best accomplished by creating"
+ elog "a completely-new group with only your MTA user and the"
+ elog "\"opendkim\" user in it. Step-by-step instructions can be"
+ elog "found on our Wiki, at https://wiki.gentoo.org/wiki/OpenDKIM ."
+ else
+ ewarn "The user account for the OpenDKIM daemon has changed"
+ ewarn "from \"milter\" to \"opendkim\" to prevent unrelated services"
+ ewarn "from being able to read your private keys. You should"
+ ewarn "adjust your existing configuration to use the \"opendkim\""
+ ewarn "user and group, and change the permissions on"
+ ewarn "${ROOT}/var/lib/opendkim to root:opendkim with mode 0750."
+ ewarn "The owner and group of the files within that directory"
+ ewarn "will likely need to be adjusted as well."
+ fi
+}
+
+pkg_config() {
+ local selector keysize pubkey
+
+ read -p "Enter the selector name (default ${HOSTNAME}): " selector
+ [[ -n "${selector}" ]] || selector="${HOSTNAME}"
+ if [[ -z "${selector}" ]]; then
+ eerror "Oddly enough, you don't have a HOSTNAME."
+ return 1
+ fi
+ if [[ -f "${ROOT}/var/lib/opendkim/${selector}.private" ]]; then
+ ewarn "The private key for this selector already exists."
+ else
+ keysize=1024
+ # Generate the private and public keys. Note that opendkim-genkeys
+ # sets umask=077 on its own to keep these safe. However, we want
+ # them to be readable (only!) to the opendkim user, and we manage
+ # that by changing their groups and making everything group-readable.
+ opendkim-genkey -b ${keysize} -D "${ROOT}/var/lib/opendkim/" \
+ -s "${selector}" -d '(your domain)' && \
+ chgrp --no-dereference opendkim \
+ "${ROOT}/var/lib/opendkim/${selector}".{private,txt} || \
+ { eerror "Failed to create private and public keys."; return 1; }
+ chmod g+r "${ROOT}/var/lib/opendkim/${selector}".{private,txt}
+ fi
+
+ # opendkim selector configuration
+ echo
+ einfo "Make sure you have the following settings in your /etc/opendkim/opendkim.conf:"
+ einfo " Keyfile /var/lib/opendkim/${selector}.private"
+ einfo " Selector ${selector}"
+
+ # MTA configuration
+ echo
+ einfo "If you are using Postfix, add following lines to your main.cf:"
+ einfo " smtpd_milters = unix:/run/opendkim/opendkim.sock"
+ einfo " non_smtpd_milters = unix:/run/opendkim/opendkim.sock"
+ einfo " and read http://www.postfix.org/MILTER_README.html"
+
+ # DNS configuration
+ einfo "After you configured your MTA, publish your key by adding this TXT record to your domain:"
+ cat "${ROOT}/var/lib/opendkim/${selector}.txt"
+ einfo "t=y signifies you only test the DKIM on your domain. See following page for the complete list of tags:"
+ einfo " http://www.dkim.org/specs/rfc4871-dkimbase.html#key-text"
+}
diff --git a/media-sound/xmms2/files/xmms2-0.8_p20161122-gcc-10.patch b/media-sound/xmms2/files/xmms2-0.8_p20161122-gcc-10.patch
new file mode 100644
index 000000000000..29a8311d2197
--- /dev/null
+++ b/media-sound/xmms2/files/xmms2-0.8_p20161122-gcc-10.patch
@@ -0,0 +1,11 @@
+--- a/src/lib/s4/tests/s4/t_transactions.c
++++ b/src/lib/s4/tests/s4/t_transactions.c
+@@ -19,7 +19,7 @@
+ #include <glib.h>
+ #include <glib/gstdio.h>
+
+-s4_t *s4;
++extern s4_t *s4;
+ s4_val_t *val;
+
+ SETUP (Transactions) {
diff --git a/media-sound/xmms2/xmms2-0.8_p20161122-r5.ebuild b/media-sound/xmms2/xmms2-0.8_p20161122-r5.ebuild
index 68f9fc6c4c2e..393d601eabd9 100644
--- a/media-sound/xmms2/xmms2-0.8_p20161122-r5.ebuild
+++ b/media-sound/xmms2/xmms2-0.8_p20161122-r5.ebuild
@@ -143,6 +143,9 @@ src_prepare() {
# C++ client dangling reference: https://github.com/xmms2/xmms2-devel/pull/5
eapply "${FILESDIR}/${P}"-cpp-client.patch
+ # gcc-10 stopped putting globals into common section
+ eapply "${FILESDIR}/${P}"-gcc-10.patch
+
eapply_user
}