summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-perl/HTTP-Message/HTTP-Message-6.450.0.ebuild43
-rw-r--r--dev-perl/HTTP-Message/Manifest1
-rw-r--r--dev-perl/Module-Build-Tiny/Manifest1
-rw-r--r--dev-perl/Module-Build-Tiny/Module-Build-Tiny-0.47.0.ebuild41
-rw-r--r--dev-perl/Test-Warnings/Manifest1
-rw-r--r--dev-perl/Test-Warnings/Test-Warnings-0.32.0.ebuild36
-rw-r--r--dev-python/tpm2-pytss/files/tpm2-pytss-2.1.0-test-add-check-for-renamed-cryptography-types.patch45
-rw-r--r--dev-python/tpm2-pytss/tpm2-pytss-2.1.0-r1.ebuild (renamed from dev-python/tpm2-pytss/tpm2-pytss-2.1.0.ebuild)8
-rw-r--r--eclass/toolchain-funcs.eclass4
9 files changed, 176 insertions, 4 deletions
diff --git a/dev-perl/HTTP-Message/HTTP-Message-6.450.0.ebuild b/dev-perl/HTTP-Message/HTTP-Message-6.450.0.ebuild
new file mode 100644
index 000000000000..77d117604bcb
--- /dev/null
+++ b/dev-perl/HTTP-Message/HTTP-Message-6.450.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=OALDERS
+DIST_VERSION=6.45
+inherit perl-module
+
+DESCRIPTION="Base class for Request/Response"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+RDEPEND="
+ !<dev-perl/libwww-perl-6
+ virtual/perl-Carp
+ >=dev-perl/Clone-0.460.0
+ virtual/perl-Compress-Raw-Bzip2
+ >=virtual/perl-Compress-Raw-Zlib-2.62.0
+ >=virtual/perl-Encode-3.10.0
+ >=dev-perl/Encode-Locale-1.0.0
+ >=virtual/perl-Exporter-5.570.0
+ virtual/perl-File-Spec
+ >=dev-perl/HTTP-Date-6.0.0
+ >=virtual/perl-IO-Compress-2.21.0
+ dev-perl/IO-HTML
+ >=dev-perl/LWP-MediaTypes-6.0.0
+ >=virtual/perl-MIME-Base64-2.100.0
+ >=dev-perl/URI-1.100.0
+"
+BDEPEND="
+ ${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ dev-perl/Test-Needs
+ virtual/perl-File-Spec
+ >=virtual/perl-Test-Simple-0.880.0
+ virtual/perl-Time-Local
+ dev-perl/Try-Tiny
+ dev-perl/URI
+ )
+"
diff --git a/dev-perl/HTTP-Message/Manifest b/dev-perl/HTTP-Message/Manifest
index 176af94667b7..ddf55e8dbce9 100644
--- a/dev-perl/HTTP-Message/Manifest
+++ b/dev-perl/HTTP-Message/Manifest
@@ -1,3 +1,4 @@
DIST HTTP-Message-6.32.tar.gz 88711 BLAKE2B 765d6ee3053c91448cd3023d87cf3bee23f107ebb10f2ccb77f064b7704c92a81f3268612e23266bb3e28a7e2810238be4da9475e93304a04dab4752ef57e789 SHA512 359a0d51e65d721d8167dea05d7aa9853d07eb4a4093735cf5f45814117070400cce93d60b08dcf92cfe0fbc98e7455e7facaecbfcaff44cc0e619fb621b3288
DIST HTTP-Message-6.33.tar.gz 89245 BLAKE2B 4a200c634c261ca7c5721bb786277712b15f1dc662543136aa8c8508be149ee520cd192afa0290756e6c1db94f6361348f0357099d3a529ad14dadda777bd5fc SHA512 8c27560796cc28f7db8e5c54a8fec0d21e5bb4d775d1d0d9fa791a7f5b51e523ce4e854facee82211d989f1cacc6f69af53dba23f4558ef0c947add6b35f8314
DIST HTTP-Message-6.44.tar.gz 94897 BLAKE2B cbfc3cdd68ba52572156340a3303a24a6d02078b7cac887e84bf4806546867479d4e1ba15582bb835b04802a897cd31afb097c8a161ca4854abae1c96a0ee0ca SHA512 515f3b91b4ed1b12c63149006651b8d60e3b4d3d842e2b997b2e8c67ce93cbdcb8eb5357f4c5bce20057aea22c1f84b5e02995b02e381c21d918032edb35a994
+DIST HTTP-Message-6.45.tar.gz 95552 BLAKE2B 8b9245a94540686e500fabedced9a63a172e89285292cfe5cfa8a907eda7ad6f35bff3dab1eab25d2b636289c0fa768e3761167c93d14cd12e7d65eeaabeb1cd SHA512 b72ab9068c5f9ddb41f89b2a84887393f2c1bd14b462a1a60c03b4560800cfbf37c76f4bdd7c08f1ce9bf616242c2e39e0ff93859ed61268c48c978322a6d03d
diff --git a/dev-perl/Module-Build-Tiny/Manifest b/dev-perl/Module-Build-Tiny/Manifest
index 7e0769609a4a..0b3ca82f3fab 100644
--- a/dev-perl/Module-Build-Tiny/Manifest
+++ b/dev-perl/Module-Build-Tiny/Manifest
@@ -1,2 +1,3 @@
DIST Module-Build-Tiny-0.039.tar.gz 20663 BLAKE2B 730ba49b5d7090321dc11d44d6e3a3fd42f81baf5f82c3e5044ede7bbe86e83d78dc8a0678671ebda4256365c5d24f118df5c12f0d2f8fad96cd8ab49206837d SHA512 26ca6fe4c1792b26bb2b4711035847f4215ea7c37234fbe24fc07432682fd9d3b6016dbdb2ecb455a7b13f6bea13994826c7f84f21075f0a6e575fa74672903a
DIST Module-Build-Tiny-0.046.tar.gz 22153 BLAKE2B 6f5c9069e07581a09fe3c0c0e18c82df5a14828129187d9d3fba8853dc4763cdce2b0889e89769437bd0adf15b183aff50335861cfdf28da1e492b944dd183db SHA512 21a6aaa9130dfa842df2cd7ff2f8264b89f4d065fa550a74ce41c3c2fb60c276abad9b59362e013efdeb85b0fa4e89aa96ab35b1ec53e499c29ba3c8f286e64b
+DIST Module-Build-Tiny-0.047.tar.gz 22193 BLAKE2B 9b4bddae93c2c2bcfe4d054f5be37ef596cb833003240796930856b27d88b252df8b669455e343ccd77e02d0a3980d4eb4755a1eb72268c03783fedbcce41a14 SHA512 505e8a1a1d7e4f73a820352b476c938769bee1b069eaee0df7a95ea5651f109dfb106faf82bf423ca96b15d0148fd890342ad214b4fa6481d15b8f494fe48a30
diff --git a/dev-perl/Module-Build-Tiny/Module-Build-Tiny-0.47.0.ebuild b/dev-perl/Module-Build-Tiny/Module-Build-Tiny-0.47.0.ebuild
new file mode 100644
index 000000000000..628d152247f3
--- /dev/null
+++ b/dev-perl/Module-Build-Tiny/Module-Build-Tiny-0.47.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=LEONT
+DIST_VERSION=0.047
+inherit perl-module
+
+DESCRIPTION="Tiny replacement for Module::Build"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+RDEPEND="
+ virtual/perl-CPAN-Meta
+ >=virtual/perl-Exporter-5.570.0
+ virtual/perl-ExtUtils-CBuilder
+ >=dev-perl/ExtUtils-Config-0.3.0
+ >=dev-perl/ExtUtils-Helpers-0.20.0
+ virtual/perl-ExtUtils-Install
+ >=dev-perl/ExtUtils-InstallPaths-0.2.0
+ virtual/perl-ExtUtils-ParseXS
+ virtual/perl-File-Path
+ virtual/perl-File-Spec
+ >=virtual/perl-Getopt-Long-2.360.0
+ >=virtual/perl-JSON-PP-2.0.0
+ virtual/perl-podlators
+ virtual/perl-Test-Harness
+"
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ virtual/perl-Data-Dumper
+ virtual/perl-File-Temp
+ virtual/perl-IO
+ >=virtual/perl-Test-Simple-0.88
+ virtual/perl-XSLoader
+ )
+"
+
+mytargets="install"
diff --git a/dev-perl/Test-Warnings/Manifest b/dev-perl/Test-Warnings/Manifest
index e4e7e902f088..c67491370680 100644
--- a/dev-perl/Test-Warnings/Manifest
+++ b/dev-perl/Test-Warnings/Manifest
@@ -1 +1,2 @@
DIST Test-Warnings-0.031.tar.gz 42031 BLAKE2B f195fe11cd0d134b8db8f77f5524b0da065dd33d8a4251df4d197d3310591ca824244b28144e8c95bb6141eafc494380285fec7244416d79c6842652576615d6 SHA512 02ddd342b6aa8771dd6ea3b7385c5eb970173633d49a3535bc46c3f98a66cd6e81895fc5f38cbe23366c8fa0f96121b51a8180b0d4ef0f2d8c658bb559c72c58
+DIST Test-Warnings-0.032.tar.gz 42877 BLAKE2B 86a0c2053c08985d03b15c5593fbeed8a1fa114bb4d50ad314d8b2f2b4d7e5cbb54fc509ffa622f0985a72839913409ac1d1b6582fda3cb6ba5c253f619fb43e SHA512 c4d936fc0670bdabed3454a95185b9f59d847cb84ee6a40e809ad04105ee08802abdb63300e89d8d07fe43c1ab0bda37756c6c070d20ef463776f15dc4ea8d53
diff --git a/dev-perl/Test-Warnings/Test-Warnings-0.32.0.ebuild b/dev-perl/Test-Warnings/Test-Warnings-0.32.0.ebuild
new file mode 100644
index 000000000000..5973846c51a3
--- /dev/null
+++ b/dev-perl/Test-Warnings/Test-Warnings-0.32.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=ETHER
+DIST_VERSION=0.032
+inherit perl-module
+
+DESCRIPTION='Test for warnings and the lack of them'
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="suggested"
+
+RDEPEND="
+ !<dev-perl/File-pushd-1.4.0
+ virtual/perl-Carp
+ virtual/perl-Exporter
+ virtual/perl-Test-Simple
+ virtual/perl-parent
+"
+BDEPEND="
+ ${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.300.0
+ test? (
+ suggested? (
+ >=dev-perl/CPAN-Meta-Check-0.11.0
+ )
+ >=virtual/perl-CPAN-Meta-2.120.900
+ virtual/perl-File-Spec
+ >=virtual/perl-Test-Simple-0.940.0
+ virtual/perl-if
+ virtual/perl-version
+ )
+"
diff --git a/dev-python/tpm2-pytss/files/tpm2-pytss-2.1.0-test-add-check-for-renamed-cryptography-types.patch b/dev-python/tpm2-pytss/files/tpm2-pytss-2.1.0-test-add-check-for-renamed-cryptography-types.patch
new file mode 100644
index 000000000000..c1aeaee4dcd1
--- /dev/null
+++ b/dev-python/tpm2-pytss/files/tpm2-pytss-2.1.0-test-add-check-for-renamed-cryptography-types.patch
@@ -0,0 +1,45 @@
+From e4006e6066c015d9ed55befa9b98247fbdcafd7d Mon Sep 17 00:00:00 2001
+From: Erik Larsson <who+github@cnackers.org>
+Date: Mon, 26 Jun 2023 12:15:41 +0200
+Subject: [PATCH] test: add check for renamed cryptography types
+
+Some types have changed their names in newer cryptography release, so add them to the tests
+
+Signed-off-by: Erik Larsson <who+github@cnackers.org>
+---
+ test/test_crypto.py | 16 ++++++++++++++--
+ 1 file changed, 14 insertions(+), 2 deletions(-)
+
+diff --git a/test/test_crypto.py b/test/test_crypto.py
+index 92cda00..7d7466e 100644
+--- a/test/test_crypto.py
++++ b/test/test_crypto.py
+@@ -596,11 +596,23 @@ class CryptoTest(TSS2_EsapiTest):
+
+ with self.assertRaises(ValueError) as e:
+ TPMT_SENSITIVE.from_pem(der)
+- self.assertEqual(str(e.exception), "unsupported key type: _DSAPrivateKey")
++ self.assertIn(
++ str(e.exception),
++ (
++ "unsupported key type: _DSAPrivateKey",
++ "unsupported key type: DSAPrivateKey",
++ ),
++ )
+
+ with self.assertRaises(ValueError) as e:
+ TPMT_PUBLIC.from_pem(dsa_public_key)
+- self.assertEqual(str(e.exception), "unsupported key type: _DSAPublicKey")
++ self.assertIn(
++ str(e.exception),
++ (
++ "unsupported key type: _DSAPublicKey",
++ "unsupported key type: DSAPublicKey",
++ ),
++ )
+
+ def test_from_pem_with_symmetric(self):
+ sym = TPMT_SYM_DEF_OBJECT(algorithm=TPM2_ALG.AES)
+--
+2.41.0
+
diff --git a/dev-python/tpm2-pytss/tpm2-pytss-2.1.0.ebuild b/dev-python/tpm2-pytss/tpm2-pytss-2.1.0-r1.ebuild
index 087095e3631c..18d96bdbc4e2 100644
--- a/dev-python/tpm2-pytss/tpm2-pytss-2.1.0.ebuild
+++ b/dev-python/tpm2-pytss/tpm2-pytss-2.1.0-r1.ebuild
@@ -2,9 +2,11 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=8
+DISTUTILS_EXT=1
DISTUTILS_USE_PEP517=setuptools
PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..11} )
+
inherit distutils-r1 pypi
DESCRIPTION="Python bindings for TSS"
@@ -33,6 +35,10 @@ DEPEND="${RDEPEND}
BDEPEND="dev-python/setuptools-scm[${PYTHON_USEDEP}]
dev-python/pkgconfig[${PYTHON_USEDEP}]"
+PATCHES=(
+ "${FILESDIR}/${PN}-2.1.0-test-add-check-for-renamed-cryptography-types.patch"
+ )
+
export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
distutils_enable_tests pytest
diff --git a/eclass/toolchain-funcs.eclass b/eclass/toolchain-funcs.eclass
index 556bbac35307..8398ee004a7d 100644
--- a/eclass/toolchain-funcs.eclass
+++ b/eclass/toolchain-funcs.eclass
@@ -576,9 +576,7 @@ _tc-has-openmp() {
# @DESCRIPTION:
# Test for OpenMP support with the current compiler and error out with
# a clear error message, telling the user how to rectify the missing
-# OpenMP support that has been requested by the ebuild. Using this function
-# to test for OpenMP support should be preferred over tc-has-openmp and
-# printing a custom message, as it presents a uniform interface to the user.
+# OpenMP support that has been requested by the ebuild.
#
# You should test for any necessary OpenMP support in pkg_pretend in order to
# warn the user of required toolchain changes. You must still check for OpenMP