summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/ipyparallel/ipyparallel-6.2.3.ebuild3
-rw-r--r--dev-python/ipython/ipython-7.5.0.ebuild30
-rw-r--r--dev-python/ipywidgets/ipywidgets-7.4.2-r1.ebuild34
-rw-r--r--dev-python/jupyter/jupyter-1.0.0-r2.ebuild50
-rw-r--r--dev-python/jupyter_client/jupyter_client-5.2.3-r1.ebuild36
-rw-r--r--dev-python/jupyter_core/jupyter_core-4.4.0-r1.ebuild54
-rw-r--r--dev-python/nbconvert/Manifest1
-rw-r--r--dev-python/nbconvert/nbconvert-5.5.0.ebuild81
-rw-r--r--dev-python/nbformat/nbformat-4.4.0-r1.ebuild57
-rw-r--r--dev-python/nbval/Manifest1
-rw-r--r--dev-python/nbval/nbval-0.9.1.ebuild30
-rw-r--r--dev-python/notebook/Manifest1
-rw-r--r--dev-python/notebook/notebook-5.7.8.ebuild115
-rw-r--r--dev-python/sphinxcontrib-github-alt/Manifest1
-rw-r--r--dev-python/sphinxcontrib-github-alt/files/sphinxcontrib-github-alt-1.1-setup.py.patch19
-rw-r--r--dev-python/sphinxcontrib-github-alt/sphinxcontrib-github-alt-1.1.ebuild35
-rw-r--r--dev-python/widgetsnbextension/Manifest1
-rw-r--r--dev-python/widgetsnbextension/widgetsnbextension-3.4.2.ebuild21
-rw-r--r--profiles/arch/riscv/package.use.mask3
-rw-r--r--profiles/arch/riscv/use.mask3
-rw-r--r--profiles/package.mask6
21 files changed, 550 insertions, 32 deletions
diff --git a/dev-python/ipyparallel/ipyparallel-6.2.3.ebuild b/dev-python/ipyparallel/ipyparallel-6.2.3.ebuild
index 2a43f855e588..b84281765edc 100644
--- a/dev-python/ipyparallel/ipyparallel-6.2.3.ebuild
+++ b/dev-python/ipyparallel/ipyparallel-6.2.3.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+PYTHON_COMPAT=( python3_{5,6,7} )
PYTHON_REQ_USE="threads(+)"
inherit distutils-r1 eutils
@@ -27,7 +27,6 @@ RDEPEND="
dev-python/decorator[${PYTHON_USEDEP}]
dev-python/ipykernel[${PYTHON_USEDEP}]
dev-python/ipython[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '<dev-python/ipython-6[${PYTHON_USEDEP}]' 'python2_7')
dev-python/ipython_genutils[${PYTHON_USEDEP}]
dev-python/jupyter_client[${PYTHON_USEDEP}]
dev-python/python-dateutil[${PYTHON_USEDEP}]
diff --git a/dev-python/ipython/ipython-7.5.0.ebuild b/dev-python/ipython/ipython-7.5.0.ebuild
index 2a20f1205ac3..75c58af6c00d 100644
--- a/dev-python/ipython/ipython-7.5.0.ebuild
+++ b/dev-python/ipython/ipython-7.5.0.ebuild
@@ -18,21 +18,6 @@ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
IUSE="doc examples matplotlib notebook nbconvert qt5 +smp test"
RESTRICT="!test? ( test )"
-# About "-python_targets_python2_7":
-# The ipython stack is in a tricky transition to py3-only. It has many circular
-# dependencies which causes a chicken-and-egg problem because for Portage to
-# properly handle dependency resolution on a system with
-# python_targets_python2_7 all members of the circular dependency must go
-# py3-only at the same time. If they don't, the dependency that requires py2
-# will seek older ipython releases for resolution. This is why, for members
-# of the circular dependency, we force -python_targets_python2_7. This way, the
-# circle stays firmly in py3-only land. This only affects members of the
-# circular dependency. Other dependencies can be on py2 without problem.
-#
-# This situation also require us to explicitly depend on transitive dependencies
-# that are part of the circular dependecy so that we preserve "circle
-# integrity". It's a bit ugly, but temporary.
-
CDEPEND="
dev-python/backcall[${PYTHON_USEDEP}]
dev-python/decorator[${PYTHON_USEDEP}]
@@ -43,17 +28,17 @@ CDEPEND="
<dev-python/prompt_toolkit-2.1[${PYTHON_USEDEP}]
dev-python/pygments[${PYTHON_USEDEP}]
dev-python/traitlets[${PYTHON_USEDEP}]
- matplotlib? ( dev-python/matplotlib[${PYTHON_USEDEP},-python_targets_python2_7] )
+ matplotlib? ( dev-python/matplotlib[${PYTHON_USEDEP}] )
"
RDEPEND="${CDEPEND}
- nbconvert? ( dev-python/nbconvert[${PYTHON_USEDEP},-python_targets_python2_7] )"
+ nbconvert? ( dev-python/nbconvert[${PYTHON_USEDEP}] )"
DEPEND="${CDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
test? (
>=dev-python/ipykernel-5.1.0[${PYTHON_USEDEP}]
- dev-python/nbformat[${PYTHON_USEDEP},-python_targets_python2_7]
+ dev-python/nbformat[${PYTHON_USEDEP}]
dev-python/nose[${PYTHON_USEDEP}]
dev-python/numpy[${PYTHON_USEDEP}]
dev-python/requests[${PYTHON_USEDEP}]
@@ -66,15 +51,14 @@ DEPEND="${CDEPEND}
PDEPEND="
notebook? (
- dev-python/notebook[${PYTHON_USEDEP},-python_targets_python2_7]
- >=dev-python/ipykernel-5.1.0[${PYTHON_USEDEP}]
- dev-python/ipywidgets[${PYTHON_USEDEP},-python_targets_python2_7]
- dev-python/widgetsnbextension[${PYTHON_USEDEP},-python_targets_python2_7]
+ dev-python/notebook[${PYTHON_USEDEP}]
+ dev-python/ipywidgets[${PYTHON_USEDEP}]
+ dev-python/widgetsnbextension[${PYTHON_USEDEP}]
)
qt5? ( dev-python/qtconsole[${PYTHON_USEDEP}] )
smp? (
>=dev-python/ipykernel-5.1.0[${PYTHON_USEDEP}]
- >=dev-python/ipyparallel-6.2.3[${PYTHON_USEDEP},-python_targets_python2_7]
+ >=dev-python/ipyparallel-6.2.3[${PYTHON_USEDEP}]
)"
PATCHES=( "${FILESDIR}"/2.1.0-substitute-files.patch )
diff --git a/dev-python/ipywidgets/ipywidgets-7.4.2-r1.ebuild b/dev-python/ipywidgets/ipywidgets-7.4.2-r1.ebuild
new file mode 100644
index 000000000000..e93864a23ee2
--- /dev/null
+++ b/dev-python/ipywidgets/ipywidgets-7.4.2-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="IPython HTML widgets for Jupyter"
+HOMEPAGE="https://ipywidgets.readthedocs.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/ipykernel-4.5.1[${PYTHON_USEDEP}]
+ >=dev-python/nbformat-4.2.0[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-4.3.1[${PYTHON_USEDEP}]
+ >=dev-python/widgetsnbextension-3.4.2[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ nosetests ipywidgets || die
+}
diff --git a/dev-python/jupyter/jupyter-1.0.0-r2.ebuild b/dev-python/jupyter/jupyter-1.0.0-r2.ebuild
new file mode 100644
index 000000000000..608399551755
--- /dev/null
+++ b/dev-python/jupyter/jupyter-1.0.0-r2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Jupyter metapackage. Install all the Jupyter components in one go"
+HOMEPAGE="https://jupyter.org"
+SRC_URI="
+ mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
+ https://patch-diff.githubusercontent.com/raw/jupyter/jupyter/pull/198.patch -> ${P}-file-colision.patch
+ "
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="
+ dev-python/notebook[${PYTHON_USEDEP}]
+ dev-python/qtconsole[${PYTHON_USEDEP}]
+ dev-python/jupyter_console[${PYTHON_USEDEP}]
+ dev-python/nbconvert[${PYTHON_USEDEP}]
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/ipywidgets[${PYTHON_USEDEP}]"
+DEPEND="doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+PDEPEND=">=dev-python/jupyter_core-4.2.0[${PYTHON_USEDEP}]"
+
+PATCHES=( "${DISTDIR}"/${P}-file-colision.patch )
+
+python_prepare_all() {
+ # Prevent un-needed download during build
+ if use doc; then
+ sed -e "/^ 'sphinx.ext.intersphinx',/d" -i docs/source/conf.py || die
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( "${S}"/docs/build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/jupyter_client/jupyter_client-5.2.3-r1.ebuild b/dev-python/jupyter_client/jupyter_client-5.2.3-r1.ebuild
new file mode 100644
index 000000000000..470782ffa021
--- /dev/null
+++ b/dev-python/jupyter_client/jupyter_client-5.2.3-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Jupyter protocol implementation and client libraries"
+HOMEPAGE="https://jupyter.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/traitlets[${PYTHON_USEDEP}]
+ dev-python/jupyter_core[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-14.4.0[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ )
+ "
+
+python_test() {
+ pytest -vv jupyter_client || die
+}
diff --git a/dev-python/jupyter_core/jupyter_core-4.4.0-r1.ebuild b/dev-python/jupyter_core/jupyter_core-4.4.0-r1.ebuild
new file mode 100644
index 000000000000..994c0dea0944
--- /dev/null
+++ b/dev-python/jupyter_core/jupyter_core-4.4.0-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Core common functionality of Jupyter projects"
+HOMEPAGE="https://jupyter.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/traitlets[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-github-alt[${PYTHON_USEDEP}] )
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ >=dev-python/ipython-4.0.1[${PYTHON_USEDEP}]
+ )
+"
+
+# tests require installation of jupyter_core, bug #649538
+RESTRICT="test"
+
+python_prepare_all() {
+ # Prevent un-needed download during build
+ if use doc; then
+ sed -e "/^ 'sphinx.ext.intersphinx',/d" -i docs/conf.py || die
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ emake -C docs html
+ HTML_DOCS=( docs/_build/html/. )
+ fi
+}
+
+python_test() {
+ distutils_install_for_testing
+ cd "${TEST_DIR}"/lib || die
+ py.test jupyter_core || die
+}
diff --git a/dev-python/nbconvert/Manifest b/dev-python/nbconvert/Manifest
index 2d40ec531924..4f10fd5a283e 100644
--- a/dev-python/nbconvert/Manifest
+++ b/dev-python/nbconvert/Manifest
@@ -1 +1,2 @@
DIST nbconvert-5.2.1.tar.gz 510937 BLAKE2B aade38372775b032287f420ea4d335ad949a80afc0df63859db5a4f520bbaa22fcd17bf4318b05fa042fe94c2f65890aa2ed2365206abe8cdfb357817b056ac7 SHA512 c71c95d6c7bda4b55afad792d108d48c27857e060531dc8ec262673971c258ff9480821bd78ee5cbdbb19f107d5f8d19a49eac88819f20a09b450c26681335fa
+DIST nbconvert-5.5.0.tar.gz 583216 BLAKE2B fce42d68fcfb5439607fcb0fa8475462e929a5ddb9d160985956a85e09c7561e1a966be633b4d59e6afe873fb7f1300997c97bdbf4690290401d14bbe351c47a SHA512 4d10cbd6d6854d7672537cfb2e0a79854be1ed4adf96f805b1a0ec0dde0e149ed465a26ceec8d7c325f7011c30ff646054585b65d1e83540622e25a96cc207bf
diff --git a/dev-python/nbconvert/nbconvert-5.5.0.ebuild b/dev-python/nbconvert/nbconvert-5.5.0.ebuild
new file mode 100644
index 000000000000..542772f0ca2f
--- /dev/null
+++ b/dev-python/nbconvert/nbconvert-5.5.0.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Converting Jupyter Notebooks"
+HOMEPAGE="https://nbconvert.readthedocs.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/bleach[${PYTHON_USEDEP}]
+ >=dev-python/entrypoints-0.2.2[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/jupyter_core[${PYTHON_USEDEP}]
+ >=dev-python/mistune-0.7.4[${PYTHON_USEDEP}]
+ dev-python/nbformat[${PYTHON_USEDEP}]
+ >=dev-python/pandocfilters-1.4.1[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-4.2.1[${PYTHON_USEDEP}]
+ dev-python/testpath[${PYTHON_USEDEP}]
+ www-servers/tornado[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? (
+ ${RDEPEND}
+ dev-python/ipython[${PYTHON_USEDEP}]
+ dev-python/jupyter_client[${PYTHON_USEDEP}]
+ dev-python/nbsphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
+ )
+ test? (
+ ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ >=dev-python/jupyter_client-4.2[${PYTHON_USEDEP}]
+ )
+"
+
+# still failing in many places
+RESTRICT=test
+
+python_prepare_all() {
+ # Prevent un-needed download during build
+ if use doc; then
+ sed -e "/^ 'sphinx.ext.intersphinx',/d" -i docs/source/conf.py || die
+ fi
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ emake -C docs html
+ HTML_DOCS=( docs/build/html/. )
+ fi
+}
+
+python_test() {
+ distutils_install_for_testing
+ cd "${TEST_DIR}"/lib || die
+ pytest -v --pyargs nbconvert || die
+}
+
+pkg_postinst() {
+ if ! has_version app-text/pandoc ; then
+ einfo "Pandoc is required for converting to formats other than Python,"
+ einfo "HTML, and Markdown. If you need this functionality, install"
+ einfo "app-text/pandoc."
+ fi
+}
diff --git a/dev-python/nbformat/nbformat-4.4.0-r1.ebuild b/dev-python/nbformat/nbformat-4.4.0-r1.ebuild
new file mode 100644
index 000000000000..854ea496fff1
--- /dev/null
+++ b/dev-python/nbformat/nbformat-4.4.0-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+PYTHON_REQ_USE='sqlite'
+
+inherit distutils-r1
+
+DESCRIPTION="Reference implementation of the Jupyter Notebook format"
+HOMEPAGE="https://jupyter.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="doc test"
+
+RDEPEND="
+ >=dev-python/jsonschema-2.4.0[${PYTHON_USEDEP}]
+ dev-python/ipython_genutils[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-4.1[${PYTHON_USEDEP}]
+ dev-python/jupyter_core[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/numpydoc[${PYTHON_USEDEP}]
+ )
+ test? (
+ dev-python/testpath[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+ "
+
+python_prepare_all() {
+ # Prevent un-needed download during build
+ if use doc; then
+ sed -e "/^ 'sphinx.ext.intersphinx',/d" -i docs/conf.py || die
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ emake -C docs html
+ HTML_DOCS=( docs/_build/html/. )
+ fi
+}
+
+python_test() {
+ distutils_install_for_testing
+ cd "${TEST_DIR}"/lib || die
+ pytest -vv nbformat || die
+}
diff --git a/dev-python/nbval/Manifest b/dev-python/nbval/Manifest
index f53fdfb3af72..f15ea0546579 100644
--- a/dev-python/nbval/Manifest
+++ b/dev-python/nbval/Manifest
@@ -1 +1,2 @@
DIST nbval-0.7.tar.gz 51805 BLAKE2B 3d1089cd480832847ca8ab5c64b69781216d4fbf2b33f7cb6a26e321062c3def85ab9620d3190451369f70b0051ed371e2df01bd0140859c98db3600cee3e543 SHA512 f146910d7fbd6a1f18b3d9ae006a1b252cc2e038f8a316463530b564e007b4b4e0b2daefbed7ae9ec7e14280f6f004b437c9570fd4d1e959c53165dcdf3cac5e
+DIST nbval-0.9.1.tar.gz 64476 BLAKE2B 299f6cb9a1e28b80b2e27a74f2b6614e83e5b571b1dc27d0f6829693dd0f6c2b59845543c91487615a8621e21ac2cbc2d34e60e62b7a646914283e23649d8bd9 SHA512 8ab0cb4e09907d99f898b148b635f0818660d04417c1c809beb93680862a5ecab14b606ecc3f90eff85e5f01de7dbf10954f1edf3629a1cf8ddac00556d4d6e7
diff --git a/dev-python/nbval/nbval-0.9.1.ebuild b/dev-python/nbval/nbval-0.9.1.ebuild
new file mode 100644
index 000000000000..4b1d3c58cc0a
--- /dev/null
+++ b/dev-python/nbval/nbval-0.9.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="A py.test plugin to validate Jupyter notebooks"
+HOMEPAGE="https://github.com/computationalmodelling/nbval"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/jupyter_client[${PYTHON_USEDEP}]
+ dev-python/nbformat[${PYTHON_USEDEP}]
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/sympy[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ )"
diff --git a/dev-python/notebook/Manifest b/dev-python/notebook/Manifest
index 9cb654aa8f4c..6997588e9cee 100644
--- a/dev-python/notebook/Manifest
+++ b/dev-python/notebook/Manifest
@@ -1,3 +1,4 @@
DIST notebook-5.0.0.tar.gz 11481080 BLAKE2B 3cc483d338ca22c6b4d7199100875e9425f90e1a7059c016cec07500f0558c437db5f7e367a5c4441520deb68fa891be31c07cd93e858c872a1f12d893530479 SHA512 fbee29cc554f36e94b1fe9804187a50581e840cfb5884bcdf2fef82ad9ae3ae0e2082ea0056f815bfa2a1c2f203679169155e61e53253aa2e9004a43ff7fbcae
DIST notebook-5.2.1.tar.gz 12458130 BLAKE2B f10a91fd79064fb09889c4ee30a84a0b34321d3a89f950609df9a90106ed4af75268cc1b087d0229882575d548b7b2b78632aa97452f89fc67910586911fc467 SHA512 defdb08e37dcec9fe799d0b03dc8dc2339f37c9417e4b138ba83b98433dd77f0dea3d83e07368e67f18155af1a67bbabea21ccd061d8a926b6b084fd25960576
DIST notebook-5.7.0.tar.gz 13394162 BLAKE2B b74be075ec97896d8ace2ce9f45d4759aee3dba1a7515a412daa8fda4606198d1487e6760ed01d8a2726ac3bf334f2335f40bf8938e8ae1ca23c9cbb5a52eded SHA512 bc5ff0316b0f89ae2c8b8bc271a8824848e2a3d93420e895557229663c889916aa98e4d1503957abbd38ca61a1b3f9d421946d6c98e36f1153b1833f473330b1
+DIST notebook-5.7.8.tar.gz 13371684 BLAKE2B 077a94ec7085ae7325a972efb58f8d7eee5a541186522402084dfa55e335163fee30e68476265e9825c3623408989b1a0782ff6a5af71af4d8ea5e6e308c3a45 SHA512 1cccb23ce6810df85b3b600c0e2e5d6599be5551ea5243c7b1a9c73ed45c34dea8b16b0fbb3624aefb9eda848bce2fdcea1f3add8df3f00a90c13a9b01ea3f07
diff --git a/dev-python/notebook/notebook-5.7.8.ebuild b/dev-python/notebook/notebook-5.7.8.ebuild
new file mode 100644
index 000000000000..11f00397f28e
--- /dev/null
+++ b/dev-python/notebook/notebook-5.7.8.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Jupyter Interactive Notebook"
+HOMEPAGE="http://jupyter.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc test"
+RDEPEND="
+ >=dev-libs/mathjax-2.4
+ dev-python/jinja[${PYTHON_USEDEP}]
+ >=dev-python/terminado-0.8.1[${PYTHON_USEDEP}]
+ >=www-servers/tornado-4.0[${PYTHON_USEDEP}]
+ dev-python/ipython_genutils[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-4.2.1[${PYTHON_USEDEP}]
+ >=dev-python/jupyter_core-4.4.0[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-17[${PYTHON_USEDEP}]
+ >=dev-python/jupyter_client-5.2[${PYTHON_USEDEP}]
+ dev-python/nbformat[${PYTHON_USEDEP}]
+ >=dev-python/nbconvert-4.2.0[${PYTHON_USEDEP}]
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/send2trash[${PYTHON_USEDEP}]
+ dev-python/prometheus_client[${PYTHON_USEDEP}]"
+
+# sphinx 2+ seems to have a problem with its github plugin. temporarily adding
+# a version constraint.
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/nose-exclude[${PYTHON_USEDEP}]
+ dev-python/nose_warnings_filters[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ )
+ doc? (
+ app-text/pandoc
+ dev-python/ipython[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.3.6[${PYTHON_USEDEP}]
+ <dev-python/sphinx-2[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-github-alt[${PYTHON_USEDEP}]
+ dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
+ dev-python/nbsphinx[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nbval[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+ )
+ "
+
+PATCHES=( "${FILESDIR}/${PN}"-5.7.0-no-mathjax.patch )
+
+# Opens a qtconsole
+restrict="doc"
+
+python_prepare_all() {
+ sed \
+ -e "/import setup/s:$:\nimport setuptools:g" \
+ -i setup.py || die
+
+ # disable bundled mathjax
+ sed -i 's/^.*MathJax.*$//' bower.json || die
+
+ # Prevent un-needed download during build
+ if use doc; then
+ sed \
+ -e "/^ 'sphinx.ext.intersphinx',/d" \
+ -i docs/source/conf.py || die
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ addwrite /dev/dri/card0
+ emake -C docs html
+ HTML_DOCS=( docs/build/html/. )
+ fi
+}
+
+python_test() {
+ nosetests \
+ --verbosity=3 \
+ --exclude-dir notebook/tests/selenium \
+ notebook || die
+
+ # These doc-based tests are broken on gentoo for permission-related errors
+ # (they try to write files in system's ipython folder). Disabled for now.
+ # if use doc; then
+ # pytest --nbval --current-env docs || die
+ # fi
+}
+
+python_install() {
+ distutils-r1_python_install
+
+ ln -sf \
+ "${EPREFIX}/usr/share/mathjax" \
+ "${D}$(python_get_sitedir)/notebook/static/components/MathJax" || die
+}
+
+pkg_preinst() {
+ # remove old mathjax folder if present
+ rm -rf "${EROOT%/}"/usr/lib*/python*/site-packages/notebook/static/components/MathJax || die
+}
diff --git a/dev-python/sphinxcontrib-github-alt/Manifest b/dev-python/sphinxcontrib-github-alt/Manifest
index e920d1f03a05..b291ce0791ca 100644
--- a/dev-python/sphinxcontrib-github-alt/Manifest
+++ b/dev-python/sphinxcontrib-github-alt/Manifest
@@ -1 +1,2 @@
DIST sphinxcontrib-github-alt-1.0.tar.gz 3213 BLAKE2B b2449c0b635769735a23187f422f05c21c52098bd25057f4dfec5412040992417451ba21bd85dcdd71c75fe2d0ac935f745b6595bf5c77bb3facf91d48a39cef SHA512 57f5ab3a5d679634ce0c2ea8c78069f37ed5a5d3c32fe6cf61851ed4a9e8b6b9b6c882f486eb84914153b4121dacc25fd4b11edee111630001ae9bc324f2250e
+DIST sphinxcontrib-github-alt-1.1.tar.gz 3312 BLAKE2B 4665c873bff44a65b0aaac4ea853ac4edc3447850f6c18a8c7b717a84e158c6cf0c16116bbfdff8f3419b8448272a180c57283c324ab5052359da4522937abbf SHA512 b7af74e3762d51663bcc8a33d10bb63ae5fd24e220919719de5ff9421ec2ae854b84bb9f17f379fa174996edc2160580fb49b0030bab4cadbdfbcbf0a0cd509d
diff --git a/dev-python/sphinxcontrib-github-alt/files/sphinxcontrib-github-alt-1.1-setup.py.patch b/dev-python/sphinxcontrib-github-alt/files/sphinxcontrib-github-alt-1.1-setup.py.patch
new file mode 100644
index 000000000000..37269d0373af
--- /dev/null
+++ b/dev-python/sphinxcontrib-github-alt/files/sphinxcontrib-github-alt-1.1-setup.py.patch
@@ -0,0 +1,19 @@
+setup.py for sphinxcontrib_github_alt by Marius Brehler <marbre@linux.sungazer.de>.
+
+Patch by Marius Brehler <marbrbre@linux.sungazer.de>.
+--- /dev/null
++++ b/setup.py
+@@ -0,0 +1,12 @@
++from distutils.core import setup
++
++setup(name='sphinxcontrib_github_alt',
++ version='1.1',
++ author='Jupyter Development Team',
++ author_email='jupyter@googlegroups.com',
++ url='https://github.com/jupyter/sphinxcontrib_github_alt',
++ packages=['sphinxcontrib_github_alt'],
++ classifiers=[
++ 'License :: OSI Approved :: BSD License'
++ ]
++)
+\ No newline at end of file
diff --git a/dev-python/sphinxcontrib-github-alt/sphinxcontrib-github-alt-1.1.ebuild b/dev-python/sphinxcontrib-github-alt/sphinxcontrib-github-alt-1.1.ebuild
new file mode 100644
index 000000000000..e26121edc894
--- /dev/null
+++ b/dev-python/sphinxcontrib-github-alt/sphinxcontrib-github-alt-1.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+inherit distutils-r1
+
+MY_PN="sphinxcontrib_github_alt"
+
+DESCRIPTION="Link to GitHub issues, pull requests, commits and users from Sphinx docs"
+HOMEPAGE="https://github.com/jupyter/sphinxcontrib_github_alt"
+SRC_URI="https://github.com/jupyter/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-python/sphinx[${PYTHON_USEDEP}]"
+
+PATCHES=(
+ "${FILESDIR}/${PN}"-1.1-setup.py.patch
+ "${FILESDIR}/${PN}"-1.0-init.py.patch
+)
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+
+ mv "${WORKDIR}/${MY_PN}-${PV}"/sphinxcontrib_github_alt.py "${WORKDIR}/${MY_PN}-${PV}/${MY_PN}/" || die
+}
diff --git a/dev-python/widgetsnbextension/Manifest b/dev-python/widgetsnbextension/Manifest
index 61ab3c57b850..670ef3d42465 100644
--- a/dev-python/widgetsnbextension/Manifest
+++ b/dev-python/widgetsnbextension/Manifest
@@ -1 +1,2 @@
DIST widgetsnbextension-3.0.0.tar.gz 1253392 BLAKE2B 88d435b06fcbf759f7ea919ee69d3523f86f2a150bb7d411d9f2a41f9e4a6176a7900595ae5bd30232c203b81f3462a1178c001fbbf456f847597b0acbd20f12 SHA512 079a2ce837e37a8d1707b6686e5c23989bb79af298847ae6bd01dd0f6e570f91e86ff53ff4aa3a8cb4f56f895e3839ef96c722bd156599eb01893870aa1fb4dd
+DIST widgetsnbextension-3.4.2.tar.gz 1103610 BLAKE2B 1cbd08dc1b9e4a8350b2d3a6e21ad106cacae8da308b82af5c55a7d520fa0ddb6c82cd7aeff7d7521430bbbbed2aaa276d869a8eaa1122cd5a3b8f69e1376352 SHA512 e50daec0a6fc7df2317a1c90ed7713057b35e4c0aba626cc70a9d886aaf0c6ec3f820344d1e1e79b7895de41b6721dc209278395cdce61291bd03ada51c14613
diff --git a/dev-python/widgetsnbextension/widgetsnbextension-3.4.2.ebuild b/dev-python/widgetsnbextension/widgetsnbextension-3.4.2.ebuild
new file mode 100644
index 000000000000..b8dcc914bf85
--- /dev/null
+++ b/dev-python/widgetsnbextension/widgetsnbextension-3.4.2.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="IPython HTML widgets for Jupyter"
+HOMEPAGE="http://ipython.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="dev-python/notebook[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
diff --git a/profiles/arch/riscv/package.use.mask b/profiles/arch/riscv/package.use.mask
index 94de3c74f63a..d56b9f0b5bbc 100644
--- a/profiles/arch/riscv/package.use.mask
+++ b/profiles/arch/riscv/package.use.mask
@@ -18,8 +18,9 @@ dev-libs/libxslt python
net-libs/gnutls guile test-full
net-libs/ldns python
net-misc/openssh kerberos
-sys-devel/make guile
sys-apps/portage epydoc
sys-auth/pambase consolekit pam_ssh pam_krb5 passwdqc mktemp
+sys-devel/make guile
+sys-fs/squashfs-tools lz4 lzma lzo zstd
sys-process/audit python
sys-process/procps test
diff --git a/profiles/arch/riscv/use.mask b/profiles/arch/riscv/use.mask
index 7d9adf530e67..c07738023533 100644
--- a/profiles/arch/riscv/use.mask
+++ b/profiles/arch/riscv/use.mask
@@ -14,9 +14,12 @@ fuse
gtk
gtk2
gtk3
+introspection
+java
libedit
libressl
qt5
slang
sqlite
+systemtap
X
diff --git a/profiles/package.mask b/profiles/package.mask
index 0c9fcbfd370a..08a355f46424 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -812,12 +812,6 @@ sys-devel/automake:1.8
# Incompatible changes in API in Enchant 2. Bug #629838.
>=app-text/enchant-2
-# Sébastien Fabbro <bicatali@gentoo.org> (19 Aug 2017)
-# ipython-6 is python-3 only and causes circular dependencies
-# Unset python_targets_python2_7 for ipykernel and ipyparallel if needed.
->=dev-python/ipython-6
->=dev-python/ipykernel-5
-
# Kent Fredric <kentnl@gentoo.org> (21 Jul 2017)
# Masked due to serious regression that introduces widespread data
# corruption when storing data in blobs. Masked, because any code