summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/google-api-core/google-api-core-1.30.0.ebuild1
-rw-r--r--eclass/python-utils-r1.eclass8
2 files changed, 7 insertions, 2 deletions
diff --git a/dev-python/google-api-core/google-api-core-1.30.0.ebuild b/dev-python/google-api-core/google-api-core-1.30.0.ebuild
index 1b0c182a7a3c..183edfac0b1a 100644
--- a/dev-python/google-api-core/google-api-core-1.30.0.ebuild
+++ b/dev-python/google-api-core/google-api-core-1.30.0.ebuild
@@ -31,6 +31,7 @@ RDEPEND="
BDEPEND="
test? (
dev-python/grpcio[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
dev-python/rsa[${PYTHON_USEDEP}]
dev-python/pytest-asyncio[${PYTHON_USEDEP}]
)
diff --git a/eclass/python-utils-r1.eclass b/eclass/python-utils-r1.eclass
index d43311762f9f..7488802332f6 100644
--- a/eclass/python-utils-r1.eclass
+++ b/eclass/python-utils-r1.eclass
@@ -597,14 +597,18 @@ python_optimize() {
instpath=/${instpath##/}
case "${EPYTHON}" in
+ python2.7|python3.[34])
+ "${PYTHON}" -m compileall -q -f -d "${instpath}" "${d}"
+ "${PYTHON}" -OO -m compileall -q -f -d "${instpath}" "${d}"
+ ;;
python*|pypy3)
- # both levels of optimization are separate since py3.5
+ # both levels of optimization are separate since 3.5
"${PYTHON}" -m compileall -q -f -d "${instpath}" "${d}"
"${PYTHON}" -O -m compileall -q -f -d "${instpath}" "${d}"
"${PYTHON}" -OO -m compileall -q -f -d "${instpath}" "${d}"
;;
*)
- die "Unknown impl for python_optimize: ${EPYTHON}"
+ "${PYTHON}" -m compileall -q -f -d "${instpath}" "${d}"
;;
esac
done