summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2018-03-05 11:30:48 -0800
committerMatt Turner <mattst88@gentoo.org>2018-03-05 11:46:19 -0800
commit3a534e26823b382dcfffa63e521e3ec72c71db16 (patch)
tree15ca62988d2ac6e2b9463172227fb6a0eeb71fbb /x11-proto/xcb-proto
parentnet-misc/srf-ip-conn-srv: remove stray pid-file, bug #649164 (diff)
downloadgentoo-3a534e26823b382dcfffa63e521e3ec72c71db16.tar.gz
gentoo-3a534e26823b382dcfffa63e521e3ec72c71db16.tar.bz2
gentoo-3a534e26823b382dcfffa63e521e3ec72c71db16.zip
x11-proto/xcb-proto: Version bump to 1.13
Diffstat (limited to 'x11-proto/xcb-proto')
-rw-r--r--x11-proto/xcb-proto/Manifest1
-rw-r--r--x11-proto/xcb-proto/xcb-proto-1.13.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/x11-proto/xcb-proto/Manifest b/x11-proto/xcb-proto/Manifest
index f954f66206f7..e4b1cc4e7beb 100644
--- a/x11-proto/xcb-proto/Manifest
+++ b/x11-proto/xcb-proto/Manifest
@@ -1 +1,2 @@
DIST xcb-proto-1.12.tar.bz2 153890 BLAKE2B cdb4b245e838ca56bfdcaa9a0618ce45e5d4da8ee10f7ae3389ff297325c3d81ba446a6385737cc9b053ecb06a0c829d99ab27dceecfec49ac1591c25c832c46 SHA512 1f427eaf223971b25b56c9f641350e03f5ebeb17a1fc212ce2a0c892de7aba7e53d5e3958b073a122bb344c387c0ff394cf96f542ff046f33de4e1cd27fb9e5c
+DIST xcb-proto-1.13.tar.bz2 151981 BLAKE2B 04d90838f8a892103e6d7aa807f1b0b6794f1538c6c986ad3cba67cff3a963ff680e45c2137c5d6330736a3aa1a387d61fc247f23487de9dada2f4013590b4a1 SHA512 002aa2aa0ad503977e03419c6f136f1e3aa8c787916830ce6d6be8f81ca99edc1d8fc5f71ce8c592b490cc767bf6567695f0bafe55fe3f743076bcddbaac07f7
diff --git a/x11-proto/xcb-proto/xcb-proto-1.13.ebuild b/x11-proto/xcb-proto/xcb-proto-1.13.ebuild
new file mode 100644
index 000000000000..81add3e7b94f
--- /dev/null
+++ b/x11-proto/xcb-proto/xcb-proto-1.13.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+XORG_MULTILIB=yes
+
+inherit python-r1 xorg-2
+
+DESCRIPTION="X C-language Bindings protocol headers"
+HOMEPAGE="https://xcb.freedesktop.org/"
+EGIT_REPO_URI="https://anongit.freedesktop.org/git/xcb/proto.git"
+[[ ${PV} != 9999* ]] && \
+ SRC_URI="https://xcb.freedesktop.org/dist/${P}.tar.bz2"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+ dev-libs/libxml2"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+src_configure() {
+ python_setup
+ xorg-2_src_configure
+}
+
+multilib_src_configure() {
+ autotools-utils_src_configure
+
+ if multilib_is_native_abi; then
+ python_foreach_impl autotools-utils_src_configure
+ fi
+}
+
+multilib_src_compile() {
+ default
+
+ if multilib_is_native_abi; then
+ python_foreach_impl autotools-utils_src_compile -C xcbgen \
+ top_builddir="${BUILD_DIR}"
+ fi
+}
+
+src_install() {
+ xorg-2_src_install
+
+ # pkg-config file hardcodes python sitedir, bug 486512
+ sed -i -e '/pythondir/s:=.*$:=/dev/null:' \
+ "${ED}"/usr/lib*/pkgconfig/xcb-proto.pc || die
+}
+
+multilib_src_install() {
+ default
+
+ if multilib_is_native_abi; then
+ python_foreach_impl autotools-utils_src_install -C xcbgen \
+ top_builddir="${BUILD_DIR}"
+ fi
+}