summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2023-10-08 00:19:45 +0200
committerDavid Seifert <soap@gentoo.org>2023-10-08 00:19:45 +0200
commite1089f202a01b0c1ceaffbd92db59739ed516e3a (patch)
tree1ac1356a269e287bd3eaddc736bbf071e6838aae /x11-misc
parentx11-misc/idesk-extras: update EAPI 6 -> 8 (diff)
downloadgentoo-e1089f202a01b0c1ceaffbd92db59739ed516e3a.tar.gz
gentoo-e1089f202a01b0c1ceaffbd92db59739ed516e3a.tar.bz2
gentoo-e1089f202a01b0c1ceaffbd92db59739ed516e3a.zip
x11-misc/matchbox-keyboard: update EAPI 6 -> 8
Closes: https://bugs.gentoo.org/898250 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/matchbox-keyboard/matchbox-keyboard-0.1-r2.ebuild (renamed from x11-misc/matchbox-keyboard/matchbox-keyboard-0.1-r1.ebuild)24
1 files changed, 15 insertions, 9 deletions
diff --git a/x11-misc/matchbox-keyboard/matchbox-keyboard-0.1-r1.ebuild b/x11-misc/matchbox-keyboard/matchbox-keyboard-0.1-r2.ebuild
index 4ceed10c88e9..8017cd6c4e34 100644
--- a/x11-misc/matchbox-keyboard/matchbox-keyboard-0.1-r1.ebuild
+++ b/x11-misc/matchbox-keyboard/matchbox-keyboard-0.1-r2.ebuild
@@ -1,28 +1,34 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI=8
-inherit versionator
+inherit autotools
DESCRIPTION="Matchbox-keyboard is an on screen 'virtual' or 'software' keyboard"
HOMEPAGE="http://matchbox-project.org/"
-SRC_URI="http://matchbox-project.org/sources/${PN}/$(get_version_component_range 1-2)/${P}.tar.bz2"
+SRC_URI="http://matchbox-project.org/sources/${PN}/$(ver_cut 1-2)/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~arm ~hppa ppc x86"
IUSE="debug cairo"
-DEPEND="x11-libs/libfakekey
+DEPEND="
+ x11-libs/libfakekey
cairo? ( x11-libs/cairo[X] )
!cairo? ( x11-libs/libXft )"
RDEPEND="${DEPEND}"
-PATCHES=(
- "${FILESDIR}"/${PN}-0.1-r1-modernize_desktop.patch
-)
+PATCHES=( "${FILESDIR}"/${PN}-0.1-r1-modernize_desktop.patch )
+
+src_prepare() {
+ default
+ eautoreconf # bug 898250
+}
src_configure() {
- econf $(use_enable debug) $(use_enable cairo)
+ econf \
+ $(use_enable debug) \
+ $(use_enable cairo)
}