summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2015-08-14 14:06:30 +0200
committerJeroen Roovers <jer@gentoo.org>2015-08-14 14:06:30 +0200
commit1e4b4e1cc0ed913e5892de84d28849e03e7a1ba1 (patch)
treefdb72587f442214bdfddd590e2c0eb67cc09c37b /x11-misc
parentVersion bump. (diff)
downloadgentoo-1e4b4e1cc0ed913e5892de84d28849e03e7a1ba1.tar.gz
gentoo-1e4b4e1cc0ed913e5892de84d28849e03e7a1ba1.tar.bz2
gentoo-1e4b4e1cc0ed913e5892de84d28849e03e7a1ba1.zip
Version bump.
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/xfe/Manifest1
-rw-r--r--x11-misc/xfe/files/xfe-1.32.2-missing_Xlib_h.patch33
-rw-r--r--x11-misc/xfe/xfe-1.40.1.ebuild73
3 files changed, 74 insertions, 33 deletions
diff --git a/x11-misc/xfe/Manifest b/x11-misc/xfe/Manifest
index 014e05c1fdd3..3c4e472dd0d2 100644
--- a/x11-misc/xfe/Manifest
+++ b/x11-misc/xfe/Manifest
@@ -1 +1,2 @@
+DIST xfe-1.40.1.tar.gz 2627754 SHA256 ec3d9495bb329c6199f6265dbfb514ffd3bdb8801e36ccc4e8fac6cea15bcc71 SHA512 d4d701dc84b342ca6f728073ff746d7308cc1cf1254956e41831cfa933649c7ac2ed32a55e6dc92047636e99f14d2609f5307aab5af07c700e597dd1cf4bf4cb WHIRLPOOL 00469cfe07604986b0a24fbcbb79c2174af6fc91ccaa7c08a47c31e6450ae637d3e1db002485d730f4ee241156c155754dcebd5a0d629941f101921c2825f533
DIST xfe-1.40.tar.gz 2574477 SHA256 2b476f15beff1a1ce85dd4ce6559bb7ceca78b866c63fb4986456862a36862a8 SHA512 22cf9fd60dcd4b594d7ff39ea78d10a8c71ee2433025acf32b7e69457a5e86852b54e448ebc1e3f63f39bf720767064c74c46eaf2b999c14ae76417d33272892 WHIRLPOOL 5c3ce54db8ac3c7e99f590100a493e3611ea2cad90b498d0b673d1366a85ed0280c8aa664f60f9de633192964a5cead4efee65e6eee69f65fdd0928061e07e0e
diff --git a/x11-misc/xfe/files/xfe-1.32.2-missing_Xlib_h.patch b/x11-misc/xfe/files/xfe-1.32.2-missing_Xlib_h.patch
deleted file mode 100644
index eb08d0ca069f..000000000000
--- a/x11-misc/xfe/files/xfe-1.32.2-missing_Xlib_h.patch
+++ /dev/null
@@ -1,33 +0,0 @@
---- a/src/ViewWindow.cpp
-+++ a/src/ViewWindow.cpp
-@@ -12,6 +12,8 @@
- #include <string.h>
- #include <unistd.h>
-
-+#include <X11/Xlib.h>
-+
- #include <fx.h>
- #include <fxkeys.h>
- #include <FXPNGIcon.h>
---- a/src/WriteWindow.cpp
-+++ a/src/WriteWindow.cpp
-@@ -12,6 +12,8 @@
- #include <unistd.h>
- #include <signal.h>
-
-+#include <X11/Xlib.h>
-+
- #include <fx.h>
- #include <fxkeys.h>
- #include <FXPNGIcon.h>
---- a/src/XFileExplorer.cpp
-+++ a/src/XFileExplorer.cpp
-@@ -8,6 +8,8 @@
- #include <sys/wait.h>
- #include <unistd.h>
-
-+#include <X11/Xlib.h>
-+
- #include <fx.h>
- #include <fxkeys.h>
- #include <FXPNGIcon.h>
diff --git a/x11-misc/xfe/xfe-1.40.1.ebuild b/x11-misc/xfe/xfe-1.40.1.ebuild
new file mode 100644
index 000000000000..9173647d23c2
--- /dev/null
+++ b/x11-misc/xfe/xfe-1.40.1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PLOCALES="
+ bs ca cs da de el es_AR es_CO es fr hu it ja nl no pl pt_BR pt_PT ru sv tr
+ zh_CN zh_TW
+"
+inherit autotools l10n
+
+DESCRIPTION="MS-Explorer-like minimalist file manager for X"
+HOMEPAGE="http://roland65.free.fr/xfe"
+SRC_URI="mirror://sourceforge/${PN}/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug nls startup-notification"
+
+RDEPEND="
+ media-libs/libpng:0
+ x11-libs/fox:1.6[truetype,png]
+ x11-libs/libX11
+ x11-libs/libXft
+ startup-notification? ( x11-libs/startup-notification )
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ nls? (
+ dev-util/intltool
+ sys-devel/gettext
+ )
+"
+
+DOCS=( AUTHORS BUGS ChangeLog README TODO )
+
+src_prepare() {
+ cat >po/POTFILES.skip <<-EOF
+ src/icons.cpp
+ xfe.desktop.in.in
+ xfi.desktop.in.in
+ xfp.desktop.in.in
+ xfv.desktop.in.in
+ xfw.desktop.in.in
+ EOF
+
+ # malformed LINGUAS file
+ # recent intltool expects newline for every linguas
+ sed -i \
+ -e '/^#/!s:\s\s*:\n:g' \
+ po/LINGUAS || die
+
+ # remove not selected locales
+ rm_locale() { sed -i -e "/${1}/d" po/LINGUAS || die ;}
+ l10n_for_each_disabled_locale_do rm_locale
+
+ sed -i \
+ -e 's|AM_CONFIG_HEADER|AC_CONFIG_HEADERS|g' \
+ configure.ac || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable nls) \
+ $(use_enable startup-notification sn) \
+ --enable-minimalflags
+}