summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/sselp
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/sselp')
-rw-r--r--x11-misc/sselp/Manifest1
-rw-r--r--x11-misc/sselp/metadata.xml10
-rw-r--r--x11-misc/sselp/sselp-0.2.ebuild33
-rw-r--r--x11-misc/sselp/sselp-9999.ebuild32
4 files changed, 76 insertions, 0 deletions
diff --git a/x11-misc/sselp/Manifest b/x11-misc/sselp/Manifest
new file mode 100644
index 000000000000..2daa540cd1e9
--- /dev/null
+++ b/x11-misc/sselp/Manifest
@@ -0,0 +1 @@
+DIST sselp-0.2.tar.gz 2562 SHA256 cd0f95ec0eb571a6dd3c48ba3aa931080eb33bc81805bd72832cc04c01b8b822 SHA512 f53163bd6bf257ef912d23dd813690a6a8700344bcc3caad73556917f12e76364b6ebc9bd11224fe8f4013d83518459440f113a313fc9721de2a124277270044 WHIRLPOOL f9ab90f765633106397cf62cb38da780b1fa25379e1722772e46d2eed0614bbfcf778f60e1c5e1a97049033898e41e35e1fecd48195ad510aeedf2031e7bdaf5
diff --git a/x11-misc/sselp/metadata.xml b/x11-misc/sselp/metadata.xml
new file mode 100644
index 000000000000..d6e0a0f7eded
--- /dev/null
+++ b/x11-misc/sselp/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>desktop-misc</herd>
+<maintainer>
+<email>jer@gentoo.org</email>
+<name>Jeroen Roovers</name>
+</maintainer>
+</pkgmetadata>
+
diff --git a/x11-misc/sselp/sselp-0.2.ebuild b/x11-misc/sselp/sselp-0.2.ebuild
new file mode 100644
index 000000000000..1ab1534560c7
--- /dev/null
+++ b/x11-misc/sselp/sselp-0.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs
+
+DESCRIPTION="Simple X selection printer"
+HOMEPAGE="http://tools.suckless.org/sselp"
+SRC_URI="http://dl.suckless.org/tools/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 hppa ~ppc ~ppc64 x86"
+IUSE=""
+
+DEPEND="x11-libs/libX11"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i \
+ -e "s|^CFLAGS = -std=c99 -pedantic -Wall -Os|CFLAGS += -std=c99 -pedantic -Wall|" \
+ -e "s|^LDFLAGS = -s|LDFLAGS +=|" \
+ -e "s|^CC = cc|CC = $(tc-getCC)|" \
+ config.mk || die "sed failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" install || die "emake install failed"
+ dodoc README
+}
diff --git a/x11-misc/sselp/sselp-9999.ebuild b/x11-misc/sselp/sselp-9999.ebuild
new file mode 100644
index 000000000000..a42f9be5d304
--- /dev/null
+++ b/x11-misc/sselp/sselp-9999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit git-2 toolchain-funcs
+
+DESCRIPTION="Simple X selection printer"
+HOMEPAGE="http://tools.suckless.org/sselp"
+SRC_URI=""
+EGIT_REPO_URI="git://git.suckless.org/sselp"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+DEPEND="x11-libs/libX11"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i \
+ -e "s|^CFLAGS = -std=c99 -pedantic -Wall -Os|CFLAGS += -std=c99 -pedantic -Wall|" \
+ -e "s|^LDFLAGS = -s|LDFLAGS +=|" \
+ -e "s|^CC = cc|CC = $(tc-getCC)|" \
+ config.mk || die "sed failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" install
+ dodoc README
+}