summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2023-02-20 21:51:35 +0100
committerDavid Seifert <soap@gentoo.org>2023-02-20 21:51:35 +0100
commit677e18223af9cc75dc8997c66cc53eb7d75bfb38 (patch)
tree1f60463158be63d6ed3b582ea7d55af9114b0e30 /x11-libs
parentx11-libs/gtkmathview: update EAPI 6 -> 8 (diff)
downloadgentoo-677e18223af9cc75dc8997c66cc53eb7d75bfb38.tar.gz
gentoo-677e18223af9cc75dc8997c66cc53eb7d75bfb38.tar.bz2
gentoo-677e18223af9cc75dc8997c66cc53eb7d75bfb38.zip
x11-libs/librfm: update EAPI 6 -> 8
Closes: https://bugs.gentoo.org/887423 Closes: https://bugs.gentoo.org/892129 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/librfm/files/librfm-5.3.16.3-C99-decls.patch42
-rw-r--r--x11-libs/librfm/files/librfm-5.3.16.3-autotools.patch10
-rw-r--r--x11-libs/librfm/librfm-5.3.16.3-r2.ebuild (renamed from x11-libs/librfm/librfm-5.3.16.3-r1.ebuild)24
3 files changed, 65 insertions, 11 deletions
diff --git a/x11-libs/librfm/files/librfm-5.3.16.3-C99-decls.patch b/x11-libs/librfm/files/librfm-5.3.16.3-C99-decls.patch
new file mode 100644
index 000000000000..784647ca92f1
--- /dev/null
+++ b/x11-libs/librfm/files/librfm-5.3.16.3-C99-decls.patch
@@ -0,0 +1,42 @@
+--- a/modules/settings-module.i
++++ b/modules/settings-module.i
+@@ -36,7 +36,7 @@
+ #define SHRED_OPTIONS rfm_void(RFM_MODULE_DIR, "callbacks","get_shred_options")
+ */
+
+-static GtkWidget *rfm_check_button_new(){
++static GtkWidget *rfm_check_button_new(void){
+ return gtk_check_button_new ();
+ }
+ static void
+@@ -374,7 +374,7 @@
+ }
+
+
+-static gchar **get_program_options(i){
++static gchar **get_program_options(gint i){
+ if (i >= RFM_OPTIONS) return NULL;
+ environ_t *environ_v = rfm_get_environ();
+ return environ_v[i].env_options;
+--- a/primary/primary-icons.i
++++ b/primary/primary-icons.i
+@@ -181,7 +181,7 @@
+
+
+ static void
+-init_lite_hash () {
++init_lite_hash (void) {
+ // g_once init
+ static gsize initialized = 0;
+ if (g_once_init_enter (&initialized)){
+--- a/primary/primary.c
++++ b/primary/primary.c
+@@ -1405,7 +1405,7 @@
+ }
+
+ static
+-gint get_paste_length(){
++gint get_paste_length(void){
+ gint fd = shm_open (PASTE_SHM_NAME, O_RDONLY, S_IRUSR | S_IWUSR);
+ if(fd < 0){
+ return 0;
diff --git a/x11-libs/librfm/files/librfm-5.3.16.3-autotools.patch b/x11-libs/librfm/files/librfm-5.3.16.3-autotools.patch
new file mode 100644
index 000000000000..4913468741d1
--- /dev/null
+++ b/x11-libs/librfm/files/librfm-5.3.16.3-autotools.patch
@@ -0,0 +1,10 @@
+--- a/m4/rfm-conditionals.m4
++++ b/m4/rfm-conditionals.m4
+@@ -174,7 +174,6 @@
+ else
+ AC_SUBST(WITH_DEBUG) WITH_DEBUG=no
+ AC_MSG_NOTICE([No debug for you.])
+- CFLAGS="-O2"
+ fi
+ ])
+
diff --git a/x11-libs/librfm/librfm-5.3.16.3-r1.ebuild b/x11-libs/librfm/librfm-5.3.16.3-r2.ebuild
index cdb51d846231..55991898b946 100644
--- a/x11-libs/librfm/librfm-5.3.16.3-r1.ebuild
+++ b/x11-libs/librfm/librfm-5.3.16.3-r2.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
+
inherit autotools
MY_P="${PN}5-${PV}"
@@ -9,11 +10,11 @@ MY_P="${PN}5-${PV}"
DESCRIPTION="The basic library used by some rfm applications, such as Rodent filemanager"
HOMEPAGE="http://xffm.org/libxffm.html"
SRC_URI="mirror://sourceforge/xffm/${PN}/${MY_P}.tar.bz2"
+S="${WORKDIR}/${MY_P}"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE=""
RDEPEND="
>=dev-libs/glib-2.22.5:2
@@ -24,18 +25,19 @@ RDEPEND="
>=gnome-base/librsvg-2.26:2
>=x11-libs/cairo-1.12.6[X]
>=x11-libs/gtk+-3.12:3[X]
- >=x11-libs/pango-1.28.0[X]
- !<x11-misc/rodent-5
-"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
-"
+ >=x11-libs/pango-1.28.0[X]"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/intltool
+ virtual/pkgconfig"
-S="${WORKDIR}/${MY_P}"
+PATCHES=(
+ "${FILESDIR}"/${P}-autotools.patch
+ "${FILESDIR}"/${P}-C99-decls.patch
+)
src_prepare() {
default
- sed -i -e "s|-O2|${CFLAGS}|" m4/rfm-conditionals.m4 || die
eautoreconf
}