summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-12-10 23:02:54 +0100
committerMichał Górny <mgorny@gentoo.org>2019-12-11 00:22:38 +0100
commit064af661d0c9a31cecdf348632bc5603333a9149 (patch)
tree2202373a7cafcb8a761d32747d4f62263aed64d5 /www-servers
parentdev-python/passlib: keyworded 1.7.1-r2 for hppa, bug #700918 (diff)
downloadgentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.gz
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.bz2
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.zip
*/*: [QA] Fix trivial cases of MissingTestRestrict
The result was achieved via the following pipeline: pkgcheck scan -c RestrictTestCheck -R FormatReporter \ --format '{category}/{package}/{package}-{version}.ebuild' | xargs -n32 grep -L RESTRICT | xargs -n32 sed -i -e '/^IUSE=.*test/aRESTRICT="!test? ( test )"' The resulting metadata was compared before and after the change. Few Go ebuilds had to be fixed manually due to implicit RESTRICT=strip added by the eclass. Two ebuilds have to be fixed because of multiline IUSE. Suggested-by: Robin H. Johnson <robbat2@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/13942 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/gunicorn/gunicorn-19.8.1.ebuild1
-rw-r--r--www-servers/gunicorn/gunicorn-19.9.0.ebuild1
-rw-r--r--www-servers/lighttpd/lighttpd-1.4.53.ebuild1
-rw-r--r--www-servers/lighttpd/lighttpd-1.4.54.ebuild1
-rw-r--r--www-servers/lighttpd/lighttpd-9999.ebuild1
-rw-r--r--www-servers/sniproxy/sniproxy-0.6.0.ebuild1
-rw-r--r--www-servers/tornado/tornado-4.4.2-r1.ebuild1
-rw-r--r--www-servers/tornado/tornado-4.5.1.ebuild1
-rw-r--r--www-servers/tornado/tornado-4.5.3.ebuild1
-rw-r--r--www-servers/tornado/tornado-5.0.2.ebuild1
-rw-r--r--www-servers/tornado/tornado-5.1.ebuild1
-rw-r--r--www-servers/xsp/xsp-2014.12-r2014120900.ebuild3
12 files changed, 13 insertions, 1 deletions
diff --git a/www-servers/gunicorn/gunicorn-19.8.1.ebuild b/www-servers/gunicorn/gunicorn-19.8.1.ebuild
index 31ce2e67890e..07f09c37af79 100644
--- a/www-servers/gunicorn/gunicorn-19.8.1.ebuild
+++ b/www-servers/gunicorn/gunicorn-19.8.1.ebuild
@@ -15,6 +15,7 @@ LICENSE="MIT PSF-2 doc? ( BSD )"
SLOT="0"
KEYWORDS="amd64 ~arm ~arm64 x86"
IUSE="doc test"
+RESTRICT="!test? ( test )"
RDEPEND="dev-python/setproctitle[${PYTHON_USEDEP}]"
DEPEND="
diff --git a/www-servers/gunicorn/gunicorn-19.9.0.ebuild b/www-servers/gunicorn/gunicorn-19.9.0.ebuild
index 258c29118213..c98e3a00bb6f 100644
--- a/www-servers/gunicorn/gunicorn-19.9.0.ebuild
+++ b/www-servers/gunicorn/gunicorn-19.9.0.ebuild
@@ -14,6 +14,7 @@ LICENSE="MIT PSF-2 doc? ( BSD )"
SLOT="0"
KEYWORDS="amd64 ~arm ~arm64 x86"
IUSE="doc test"
+RESTRICT="!test? ( test )"
RDEPEND="dev-python/setproctitle[${PYTHON_USEDEP}]"
DEPEND="
diff --git a/www-servers/lighttpd/lighttpd-1.4.53.ebuild b/www-servers/lighttpd/lighttpd-1.4.53.ebuild
index b1da554c2102..08f98fd76ef9 100644
--- a/www-servers/lighttpd/lighttpd-1.4.53.ebuild
+++ b/www-servers/lighttpd/lighttpd-1.4.53.ebuild
@@ -13,6 +13,7 @@ LICENSE="BSD GPL-2"
SLOT="0"
KEYWORDS="alpha amd64 arm ~arm64 ~hppa ia64 ~mips ppc ppc64 s390 ~sh sparc x86"
IUSE="bzip2 dbi doc fam gdbm geoip ipv6 kerberos ldap libev libressl lua minimal mmap memcached mysql pcre php postgres rrdtool sasl selinux ssl sqlite test webdav xattr zlib"
+RESTRICT="!test? ( test )"
REQUIRED_USE="kerberos? ( ssl !libressl ) webdav? ( sqlite )"
diff --git a/www-servers/lighttpd/lighttpd-1.4.54.ebuild b/www-servers/lighttpd/lighttpd-1.4.54.ebuild
index 361c6c497a5c..a30fd3000ed1 100644
--- a/www-servers/lighttpd/lighttpd-1.4.54.ebuild
+++ b/www-servers/lighttpd/lighttpd-1.4.54.ebuild
@@ -13,6 +13,7 @@ LICENSE="BSD GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
IUSE="bzip2 dbi doc fam gdbm geoip ipv6 kerberos ldap libev libressl lua minimal mmap memcached mysql pcre php postgres rrdtool sasl selinux ssl sqlite test webdav xattr zlib"
+RESTRICT="!test? ( test )"
REQUIRED_USE="kerberos? ( ssl !libressl ) webdav? ( sqlite )"
diff --git a/www-servers/lighttpd/lighttpd-9999.ebuild b/www-servers/lighttpd/lighttpd-9999.ebuild
index 46f8da74bb1b..83a7806e757e 100644
--- a/www-servers/lighttpd/lighttpd-9999.ebuild
+++ b/www-servers/lighttpd/lighttpd-9999.ebuild
@@ -13,6 +13,7 @@ LICENSE="BSD GPL-2"
SLOT="0"
KEYWORDS=""
IUSE="bzip2 doc fam gdbm ipv6 kerberos ldap libev libressl lua minimal mmap memcached mysql pcre php rrdtool selinux ssl test webdav xattr zlib"
+RESTRICT="!test? ( test )"
REQUIRED_USE="kerberos? ( ssl !libressl )"
diff --git a/www-servers/sniproxy/sniproxy-0.6.0.ebuild b/www-servers/sniproxy/sniproxy-0.6.0.ebuild
index 2c4947ff75ad..458f1e8ac793 100644
--- a/www-servers/sniproxy/sniproxy-0.6.0.ebuild
+++ b/www-servers/sniproxy/sniproxy-0.6.0.ebuild
@@ -21,6 +21,7 @@ HOMEPAGE="https://github.com/dlundquist/sniproxy"
LICENSE="BSD-2"
SLOT="0"
IUSE="+dns +largefile rfc3339 test"
+RESTRICT="!test? ( test )"
RDEPEND="
dev-libs/libev
diff --git a/www-servers/tornado/tornado-4.4.2-r1.ebuild b/www-servers/tornado/tornado-4.4.2-r1.ebuild
index 3d603a22ae1d..b03ef4435a9a 100644
--- a/www-servers/tornado/tornado-4.4.2-r1.ebuild
+++ b/www-servers/tornado/tornado-4.4.2-r1.ebuild
@@ -16,6 +16,7 @@ LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ppc ppc64 s390 ~sh sparc x86 ~amd64-linux ~x86-linux"
IUSE="doc examples test"
+RESTRICT="!test? ( test )"
CDEPEND="
dev-python/certifi[${PYTHON_USEDEP}]
diff --git a/www-servers/tornado/tornado-4.5.1.ebuild b/www-servers/tornado/tornado-4.5.1.ebuild
index df6e808e25cc..d4bb99a886e1 100644
--- a/www-servers/tornado/tornado-4.5.1.ebuild
+++ b/www-servers/tornado/tornado-4.5.1.ebuild
@@ -16,6 +16,7 @@ LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
IUSE="doc examples test"
+RESTRICT="!test? ( test )"
CDEPEND="
dev-python/certifi[${PYTHON_USEDEP}]
diff --git a/www-servers/tornado/tornado-4.5.3.ebuild b/www-servers/tornado/tornado-4.5.3.ebuild
index 206e059e0de9..1deec81f52bb 100644
--- a/www-servers/tornado/tornado-4.5.3.ebuild
+++ b/www-servers/tornado/tornado-4.5.3.ebuild
@@ -16,6 +16,7 @@ LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ppc ppc64 s390 ~sh sparc x86 ~amd64-linux ~x86-linux"
IUSE="doc examples test"
+RESTRICT="!test? ( test )"
CDEPEND="
dev-python/certifi[${PYTHON_USEDEP}]
diff --git a/www-servers/tornado/tornado-5.0.2.ebuild b/www-servers/tornado/tornado-5.0.2.ebuild
index 98921c38ee75..689b47f22e8d 100644
--- a/www-servers/tornado/tornado-5.0.2.ebuild
+++ b/www-servers/tornado/tornado-5.0.2.ebuild
@@ -16,6 +16,7 @@ LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
IUSE="doc examples test"
+RESTRICT="!test? ( test )"
CDEPEND="
$(python_gen_cond_dep 'dev-python/futures[${PYTHON_USEDEP}]' 'python2_7')
diff --git a/www-servers/tornado/tornado-5.1.ebuild b/www-servers/tornado/tornado-5.1.ebuild
index cf30654f3573..8d4759b7d535 100644
--- a/www-servers/tornado/tornado-5.1.ebuild
+++ b/www-servers/tornado/tornado-5.1.ebuild
@@ -16,6 +16,7 @@ LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
IUSE="doc examples test"
+RESTRICT="!test? ( test )"
CDEPEND="
$(python_gen_cond_dep 'dev-python/futures[${PYTHON_USEDEP}]' 'python2_7')
diff --git a/www-servers/xsp/xsp-2014.12-r2014120900.ebuild b/www-servers/xsp/xsp-2014.12-r2014120900.ebuild
index 0f2567648c57..682da894b805 100644
--- a/www-servers/xsp/xsp-2014.12-r2014120900.ebuild
+++ b/www-servers/xsp/xsp-2014.12-r2014120900.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
@@ -19,6 +19,7 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="doc test developer"
+RESTRICT="!test? ( test )"
RDEPEND="dev-db/sqlite:3"
DEPEND="${RDEPEND}"