summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-02-21 14:03:08 +0100
committerManuel Rüger <mrueg@gentoo.org>2016-02-21 14:03:08 +0100
commitfd3289df3c0f4602a6eeef3451e5104329aeb0ec (patch)
tree024cc7f8dbc0bdce5726695d1f86f52a84ffd279 /www-apps/jekyll-gist/jekyll-gist-1.4.0.ebuild
parentdev-java/java-config: Add Python 3.5, fix Python deps wrt bug #539802 (diff)
downloadgentoo-fd3289df3c0f4602a6eeef3451e5104329aeb0ec.tar.gz
gentoo-fd3289df3c0f4602a6eeef3451e5104329aeb0ec.tar.bz2
gentoo-fd3289df3c0f4602a6eeef3451e5104329aeb0ec.zip
www-apps/jekyll-gist: Version bump
Package-Manager: portage-2.2.27
Diffstat (limited to 'www-apps/jekyll-gist/jekyll-gist-1.4.0.ebuild')
-rw-r--r--www-apps/jekyll-gist/jekyll-gist-1.4.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/www-apps/jekyll-gist/jekyll-gist-1.4.0.ebuild b/www-apps/jekyll-gist/jekyll-gist-1.4.0.ebuild
new file mode 100644
index 000000000000..d5007c31d3c1
--- /dev/null
+++ b/www-apps/jekyll-gist/jekyll-gist-1.4.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md History.markdown"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Liquid tag for displaying GitHub Gists in Jekyll sites"
+HOMEPAGE="https://github.com/jekyll/jekyll-gist"
+SRC_URI="https://github.com/jekyll/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/octokit-4.2"
+ruby_add_bdepend "test? ( dev-ruby/webmock
+ >=www-apps/jekyll-3 )"
+
+all_ruby_prepare() {
+ rm Rakefile || die
+}