summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWim Muskee <wimmuskee@gmail.com>2018-01-26 07:03:06 +0100
committerRafael G. Martins <rafaelmartins@gentoo.org>2018-05-07 20:01:20 +0200
commita50edaca90a69c294fa9cbee14861d646e5a0095 (patch)
tree80b6e14eb8e184477db1b10d15f89b7f17afc73d /www-apps/cgisysinfo/cgisysinfo-0.4.1.ebuild
parentsci-visualization/gnuplot: De-stabilise hppa (diff)
downloadgentoo-a50edaca90a69c294fa9cbee14861d646e5a0095.tar.gz
gentoo-a50edaca90a69c294fa9cbee14861d646e5a0095.tar.bz2
gentoo-a50edaca90a69c294fa9cbee14861d646e5a0095.zip
www-apps/cgisysinfo: update SRC_URI, HOMEPAGE, REPO_URI
Closes: https://bugs.gentoo.org/626300 Apparently, the Github 0.4.1 version requires an eautoreconf. The Github compiled bin has the same md5sum as the one from the tree.
Diffstat (limited to 'www-apps/cgisysinfo/cgisysinfo-0.4.1.ebuild')
-rw-r--r--www-apps/cgisysinfo/cgisysinfo-0.4.1.ebuild16
1 files changed, 9 insertions, 7 deletions
diff --git a/www-apps/cgisysinfo/cgisysinfo-0.4.1.ebuild b/www-apps/cgisysinfo/cgisysinfo-0.4.1.ebuild
index 392f1647e1c7..0dc2dac982cd 100644
--- a/www-apps/cgisysinfo/cgisysinfo-0.4.1.ebuild
+++ b/www-apps/cgisysinfo/cgisysinfo-0.4.1.ebuild
@@ -3,18 +3,22 @@
EAPI="5"
+inherit autotools
+
if [[ ${PV} = *9999* ]]; then
WANT_AUTOMAKE="1.10"
- inherit autotools mercurial
- EHG_REPO_URI="http://hg.rafaelmartins.eng.br/cgisysinfo/"
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/rafaelmartins/${PN}"
KEYWORDS=""
+ DOCS=( "README.md" "AUTHORS" "NEWS" )
else
- SRC_URI="http://distfiles.rafaelmartins.eng.br/${PN}/${P}.tar.bz2"
+ SRC_URI="https://github.com/rafaelmartins/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
+ DOCS=( "README" "AUTHORS" "NEWS" )
fi
DESCRIPTION="A small cgi utility to show basic system information"
-HOMEPAGE="http://projects.rafaelmartins.eng.br/cgisysinfo"
+HOMEPAGE="https://github.com/rafaelmartins/cgisysinfo"
LICENSE="GPL-2"
SLOT="0"
@@ -23,10 +27,8 @@ IUSE="fastcgi"
DEPEND="fastcgi? ( dev-libs/fcgi )"
RDEPEND="${DEPEND}"
-DOCS="README AUTHORS NEWS"
-
src_prepare() {
- [[ ${PV} = *9999* ]] && eautoreconf
+ eautoreconf
}
src_configure() {