summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-process/at/at-3.1.14.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-process/at/at-3.1.14.ebuild')
-rw-r--r--sys-process/at/at-3.1.14.ebuild82
1 files changed, 82 insertions, 0 deletions
diff --git a/sys-process/at/at-3.1.14.ebuild b/sys-process/at/at-3.1.14.ebuild
new file mode 100644
index 000000000000..1aafee53b70f
--- /dev/null
+++ b/sys-process/at/at-3.1.14.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils flag-o-matic pam user systemd
+
+DESCRIPTION="Queues jobs for later execution"
+HOMEPAGE="http://packages.qa.debian.org/a/at.html"
+SRC_URI="mirror://debian/pool/main/a/at/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm hppa ia64 ~mips ppc ppc64 sparc x86"
+IUSE="pam selinux"
+
+DEPEND="virtual/mta
+ >=sys-devel/autoconf-2.64
+ sys-devel/bison
+ >=sys-devel/flex-2.5.4a
+ pam? ( virtual/pam )"
+RDEPEND="virtual/mta
+ virtual/logger
+ selinux? ( sec-policy/selinux-at )"
+
+pkg_setup() {
+ enewgroup at 25
+ enewuser at 25 -1 /var/spool/at/atjobs at
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-3.1.8-more-deny.patch
+ epatch "${FILESDIR}"/${PN}-3.1.14-Makefile.patch
+ # fix parallel make issues, bug #244884
+ epatch "${FILESDIR}"/${PN}-3.1.10.2-Makefile.in-parallel-make-fix.patch
+ epatch "${FILESDIR}"/${PN}-3.1.13-configure.in-fix-PAM-automagick-dep.patch
+ # Fix parallel make issue (bug #408375)
+ epatch "${FILESDIR}"/${PN}-3.1.13-parallel-make-fix.patch
+ epatch "${FILESDIR}"/${PN}-3.1.13-getloadavg.patch
+
+ eautoconf
+}
+
+src_configure() {
+ use pam || my_conf="--without-pam"
+ econf \
+ --sysconfdir=/etc/at \
+ --with-jobdir=/var/spool/at/atjobs \
+ --with-atspool=/var/spool/at/atspool \
+ --with-etcdir=/etc/at \
+ --with-daemon_username=at \
+ --with-daemon_groupname=at \
+ ${my_conf}
+}
+
+src_install() {
+ emake install IROOT="${D}"
+
+ newinitd "${FILESDIR}"/atd.rc7 atd
+ newconfd "${FILESDIR}"/atd.confd atd
+ newpamd "${FILESDIR}"/at.pamd-3.1.13-r1 atd
+
+ # Preserve existing .SEQ files (bug #386625)
+ local seq_file="${ROOT}/var/spool/at/atjobs/.SEQ"
+ if [ -f "${seq_file}" ] ; then
+ einfo "Preserving existing .SEQ file (bug #386625)."
+ cp -p "${seq_file}" "${D}"/var/spool/at/atjobs/ || die
+ fi
+
+ systemd_dounit "${FILESDIR}/atd.service"
+}
+
+pkg_postinst() {
+ einfo "Forcing correct permissions on /var/spool/at"
+ chown at:at "${ROOT}/var/spool/at/atjobs"
+ chmod 1770 "${ROOT}/var/spool/at/atjobs"
+ chown at:at "${ROOT}/var/spool/at/atjobs/.SEQ"
+ chmod 0600 "${ROOT}/var/spool/at/atjobs/.SEQ"
+ chown at:at "${ROOT}/var/spool/at/atspool"
+ chmod 1770 "${ROOT}/var/spool/at/atspool"
+}