summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2023-06-02 13:15:11 +0200
committerConrad Kostecki <conikost@gentoo.org>2023-06-02 13:16:25 +0200
commit7c77ffaa6bea37cd19a4d5f02877a2b64b5759b1 (patch)
treeacb131b928a6dad458e1c59075b1072f09878baf /sys-power/acpi_call
parentsys-apps/smc-sum: migrate to linux-mod-r1 (diff)
downloadgentoo-7c77ffaa6bea37cd19a4d5f02877a2b64b5759b1.tar.gz
gentoo-7c77ffaa6bea37cd19a4d5f02877a2b64b5759b1.tar.bz2
gentoo-7c77ffaa6bea37cd19a4d5f02877a2b64b5759b1.zip
sys-power/acpi_call: migrate to linux-mod-r1
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'sys-power/acpi_call')
-rw-r--r--sys-power/acpi_call/acpi_call-1.2.2-r1.ebuild (renamed from sys-power/acpi_call/acpi_call-1.2.2.ebuild)15
-rw-r--r--sys-power/acpi_call/acpi_call-9999.ebuild15
2 files changed, 14 insertions, 16 deletions
diff --git a/sys-power/acpi_call/acpi_call-1.2.2.ebuild b/sys-power/acpi_call/acpi_call-1.2.2-r1.ebuild
index 90e2e0158a01..b7fd9601068a 100644
--- a/sys-power/acpi_call/acpi_call-1.2.2.ebuild
+++ b/sys-power/acpi_call/acpi_call-1.2.2-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit linux-info linux-mod
+inherit linux-mod-r1
DESCRIPTION="A linux kernel module that enables calls to ACPI"
HOMEPAGE="https://github.com/nix-community/acpi_call"
@@ -14,18 +14,17 @@ SLOT="0"
KEYWORDS="amd64"
IUSE="examples"
-BUILD_TARGETS="default"
CONFIG_CHECK="ACPI"
-MODULE_NAMES="acpi_call(misc:${S})"
src_compile() {
- BUILD_PARAMS="KDIR=${KV_OUT_DIR} M=${S}"
+ local modargs=( KDIR=${KV_OUT_DIR} )
+ local modlist=( acpi_call=misc )
- linux-mod_src_compile
+ linux-mod-r1_src_compile
}
src_install() {
- linux-mod_src_install
+ linux-mod-r1_src_install
if use examples; then
insinto /usr/share/acpi_call
diff --git a/sys-power/acpi_call/acpi_call-9999.ebuild b/sys-power/acpi_call/acpi_call-9999.ebuild
index ba449334ffc0..c8b96da325e2 100644
--- a/sys-power/acpi_call/acpi_call-9999.ebuild
+++ b/sys-power/acpi_call/acpi_call-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit git-r3 linux-info linux-mod
+inherit git-r3 linux-mod-r1
DESCRIPTION="A linux kernel module that enables calls to ACPI"
HOMEPAGE="https://github.com/nix-community/acpi_call"
@@ -14,18 +14,17 @@ SLOT="0"
KEYWORDS=""
IUSE="examples"
-BUILD_TARGETS="default"
CONFIG_CHECK="ACPI"
-MODULE_NAMES="acpi_call(misc:${S})"
src_compile() {
- BUILD_PARAMS="KDIR=${KV_OUT_DIR} M=${S}"
+ local modargs=( KDIR=${KV_OUT_DIR} )
+ local modlist=( acpi_call=misc )
- linux-mod_src_compile
+ linux-mod-r1_src_compile
}
src_install() {
- linux-mod_src_install
+ linux-mod-r1_src_install
if use examples; then
insinto /usr/share/acpi_call