summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2018-12-21 17:21:18 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2018-12-21 17:21:34 +0100
commit481e2e89a13668daaa3e14e3310faf3e9e87d62e (patch)
tree3e3d3892dc6181a48d125b4955093e26b204373b /sys-libs
parentsys-kernel/gentoo-sources: Linux patch 4.14.90 (diff)
downloadgentoo-481e2e89a13668daaa3e14e3310faf3e9e87d62e.tar.gz
gentoo-481e2e89a13668daaa3e14e3310faf3e9e87d62e.tar.bz2
gentoo-481e2e89a13668daaa3e14e3310faf3e9e87d62e.zip
sys-libs/glibc: locale-gen: precisely replicate 2.27 behaviour
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/Manifest2
-rw-r--r--sys-libs/glibc/glibc-9999.ebuild6
2 files changed, 4 insertions, 4 deletions
diff --git a/sys-libs/glibc/Manifest b/sys-libs/glibc/Manifest
index bbf500d820e8..4483254573bb 100644
--- a/sys-libs/glibc/Manifest
+++ b/sys-libs/glibc/Manifest
@@ -20,4 +20,4 @@ DIST glibc-2.28-patches-3.tar.xz 46172 BLAKE2B b2dc4de76ab4b4e31a6a043a133f89ede
DIST glibc-2.28-patches-5.tar.xz 76472 BLAKE2B bc3457e606ab7be2eca71c949b70f89d08418e6e2d061491dfcac3b8f962ca142f48bf0f789e025a6280f030d7bf74e3421676b08d97fc571d6e0f4e660d2758 SHA512 1639e435728a9970e4eaa79eb0a00502acecf7060d3bf70ef6bb6256ec20c23b4be6ba500a8ab97547e1af9e3df9228f7b70bb65ea1755b61c7884defa6c3535
DIST glibc-2.28-patches-6.tar.xz 89724 BLAKE2B f846534dc912f11ed9b22badfd28ef0402451654390756d2f6332f52ce7c2d3491ed90bbdf2553d7bb38caea6373ad2d3c19e4a1f31f3669948f4e2cbaeb1577 SHA512 f687febde875bb8adb7a61408caea3db99bbbda703eb3486c7d5c09540515e657eda406bf14686498e2c093355c72395502a343201e02cfc97adf6483d8e7455
DIST glibc-2.28.tar.xz 16484344 BLAKE2B 9aa8cbd5a145c2a6fde3a60b3d0a14b12b46ed79333ad1ca3e73464adcfe700277a17a9e7fd0ca36e355a0c5b0b27decfa091da320ba802741ad75cc955bbcc8 SHA512 521f820953ff07c69ece4c2186f59fc061a7f9747932cd70ef2995c2b2deee76eeb6de700d85071cdca5949179aa8ccee75eda7feca1394121ec7b821ad0a3f3
-DIST glibc-9999-patches-9.tar.xz 17384 BLAKE2B d5ddf078a4a9e05a727ba709efdfdb5891e72d19c1a61b11bbde6a555ac38ccc4a1694d46228bbc56ff796e4e16326fb17613d73ccee8b2e6ed51a5bb371a241 SHA512 934bcb0130bd9f3a313b7107528598fb0aac27d719aded265ba111d01eac57e0235e15a4a2d2c7e0376e9d18c803c4b57f9446da4ed3e2b2a62a1587b50dcdbc
+DIST glibc-9999-patches-10.tar.xz 17544 BLAKE2B 1cd4fa14b2168e371c769c06a29f36d6dbd3beccb796788470b63282cb8e5c3c497e4eb3800e4bc86c07d3b82935d71dc96dc3155178d52b68873ea38a271a70 SHA512 bbd376ad87fb71de7a6a4eb28030aa1550f7cca57e521d2a326cab63a66e2dc784b93319190f8bb1b24b335acc604d0523c3ea8335a4424373796ebeb79f273b
diff --git a/sys-libs/glibc/glibc-9999.ebuild b/sys-libs/glibc/glibc-9999.ebuild
index b8e907846306..46dde2c6ce3a 100644
--- a/sys-libs/glibc/glibc-9999.ebuild
+++ b/sys-libs/glibc/glibc-9999.ebuild
@@ -18,7 +18,7 @@ if [[ ${PV} == 9999* ]]; then
EGIT_REPO_URI="https://sourceware.org/git/glibc.git"
inherit git-r3
else
- # KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+ #KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
KEYWORDS=""
SRC_URI="mirror://gnu/glibc/${P}.tar.xz"
fi
@@ -28,7 +28,7 @@ RELEASE_VER=${PV}
GCC_BOOTSTRAP_VER=20180511
# Gentoo patchset
-PATCH_VER=9
+PATCH_VER=10
SRC_URI+=" https://dev.gentoo.org/~dilfridge/distfiles/${P}-patches-${PATCH_VER}.tar.xz"
SRC_URI+=" multilib? ( https://dev.gentoo.org/~dilfridge/distfiles/gcc-multilib-bootstrap-${GCC_BOOTSTRAP_VER}.tar.xz )"
@@ -1101,7 +1101,7 @@ run_locale_gen() {
# if the host locales.gen contains no entries, we'll install everything
local root="$1"
local locale_list="${root}/etc/locale.gen"
- if [[ $(locale-gen --list --config "${locale_list}") == "C.UTF-8" ]] ; then
+ if [[ -z $(locale-gen --list --config "${locale_list}") ]] ; then
ewarn "Generating all locales; edit /etc/locale.gen to save time/space"
locale_list="${root}/usr/share/i18n/SUPPORTED"
fi