summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2022-03-22 12:31:41 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2022-03-22 17:57:59 +0100
commit3588625fe514077e4a0a9a6a8141f00f840eca8e (patch)
tree666a940ab45860205068b0ae77e4dcee408a0b04 /sys-libs
parentapp-doc/pms: Remove old (diff)
downloadgentoo-3588625fe514077e4a0a9a6a8141f00f840eca8e.tar.gz
gentoo-3588625fe514077e4a0a9a6a8141f00f840eca8e.tar.bz2
gentoo-3588625fe514077e4a0a9a6a8141f00f840eca8e.zip
sys-libs/glibc: Improve clang override
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/glibc-2.34-r10.ebuild6
-rw-r--r--sys-libs/glibc/glibc-2.35.ebuild6
-rw-r--r--sys-libs/glibc/glibc-9999.ebuild6
3 files changed, 12 insertions, 6 deletions
diff --git a/sys-libs/glibc/glibc-2.34-r10.ebuild b/sys-libs/glibc/glibc-2.34-r10.ebuild
index 655a41a7f00c..e5b596095245 100644
--- a/sys-libs/glibc/glibc-2.34-r10.ebuild
+++ b/sys-libs/glibc/glibc-2.34-r10.ebuild
@@ -525,9 +525,11 @@ setup_env() {
# a good start into that direction.
# Also, if you're crosscompiling, let's assume you know what you are doing.
# Hopefully.
+ # Last, we need the settings of the *build* environment, not of the
+ # target environment...
- local current_binutils_path=$(binutils-config -B)
- local current_gcc_path=$(gcc-config -B)
+ local current_binutils_path=$(env ROOT="${SYSROOT}" binutils-config -B)
+ local current_gcc_path=$(env ROOT="${SYSROOT}" gcc-config -B)
einfo "Overriding clang configuration, since it won't work here"
export CC="${current_gcc_path}/gcc"
diff --git a/sys-libs/glibc/glibc-2.35.ebuild b/sys-libs/glibc/glibc-2.35.ebuild
index 014bac6b2005..0237132b9373 100644
--- a/sys-libs/glibc/glibc-2.35.ebuild
+++ b/sys-libs/glibc/glibc-2.35.ebuild
@@ -515,9 +515,11 @@ setup_env() {
# a good start into that direction.
# Also, if you're crosscompiling, let's assume you know what you are doing.
# Hopefully.
+ # Last, we need the settings of the *build* environment, not of the
+ # target environment...
- local current_binutils_path=$(binutils-config -B)
- local current_gcc_path=$(gcc-config -B)
+ local current_binutils_path=$(env ROOT="${SYSROOT}" binutils-config -B)
+ local current_gcc_path=$(env ROOT="${SYSROOT}" gcc-config -B)
einfo "Overriding clang configuration, since it won't work here"
export CC="${current_gcc_path}/gcc"
diff --git a/sys-libs/glibc/glibc-9999.ebuild b/sys-libs/glibc/glibc-9999.ebuild
index 2a26162f17d2..f9c41f6d8ccc 100644
--- a/sys-libs/glibc/glibc-9999.ebuild
+++ b/sys-libs/glibc/glibc-9999.ebuild
@@ -515,9 +515,11 @@ setup_env() {
# a good start into that direction.
# Also, if you're crosscompiling, let's assume you know what you are doing.
# Hopefully.
+ # Last, we need the settings of the *build* environment, not of the
+ # target environment...
- local current_binutils_path=$(binutils-config -B)
- local current_gcc_path=$(gcc-config -B)
+ local current_binutils_path=$(env ROOT="${SYSROOT}" binutils-config -B)
+ local current_gcc_path=$(env ROOT="${SYSROOT}" gcc-config -B)
einfo "Overriding clang configuration, since it won't work here"
export CC="${current_gcc_path}/gcc"