summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2021-10-31 22:21:55 -0400
committerMike Frysinger <vapier@gentoo.org>2021-10-31 22:22:53 -0400
commitf994975cb3b2a2ff7f4aa8a69c88e3e0f10b68e5 (patch)
tree51296c31473dcb363bfffef3f8fb830eba0e516d /sys-libs/ncurses
parentdev-perl/Params-Validate: Stabilize 1.300.0 sparc, #810199 (diff)
downloadgentoo-f994975cb3b2a2ff7f4aa8a69c88e3e0f10b68e5.tar.gz
gentoo-f994975cb3b2a2ff7f4aa8a69c88e3e0f10b68e5.tar.bz2
gentoo-f994975cb3b2a2ff7f4aa8a69c88e3e0f10b68e5.zip
sys-libs/ncurses: enable progs when cross-compiling
The native abi detection logic gets confused when cross-compiling, so just always force progs on here and call it a day. Closes: https://bugs.gentoo.org/711590 Signed-off-by: Mike Frysinger <vapier@gentoo.org>
Diffstat (limited to 'sys-libs/ncurses')
-rw-r--r--sys-libs/ncurses/ncurses-6.2-r1.ebuild2
-rw-r--r--sys-libs/ncurses/ncurses-6.2_p20210619.ebuild2
-rw-r--r--sys-libs/ncurses/ncurses-6.3.ebuild2
3 files changed, 3 insertions, 3 deletions
diff --git a/sys-libs/ncurses/ncurses-6.2-r1.ebuild b/sys-libs/ncurses/ncurses-6.2-r1.ebuild
index 718ab0d0f1f5..6353b40857d9 100644
--- a/sys-libs/ncurses/ncurses-6.2-r1.ebuild
+++ b/sys-libs/ncurses/ncurses-6.2-r1.ebuild
@@ -92,7 +92,7 @@ src_configure() {
CXXFLAGS=${BUILD_CXXFLAGS} \
CPPFLAGS=${BUILD_CPPFLAGS} \
LDFLAGS="${BUILD_LDFLAGS} ${lbuildflags}" \
- do_configure cross --without-shared --with-normal
+ do_configure cross --without-shared --with-normal --with-progs
fi
multilib-minimal_src_configure
}
diff --git a/sys-libs/ncurses/ncurses-6.2_p20210619.ebuild b/sys-libs/ncurses/ncurses-6.2_p20210619.ebuild
index 0e5076cc2aca..464f7ca0bcc2 100644
--- a/sys-libs/ncurses/ncurses-6.2_p20210619.ebuild
+++ b/sys-libs/ncurses/ncurses-6.2_p20210619.ebuild
@@ -93,7 +93,7 @@ src_configure() {
CXXFLAGS=${BUILD_CXXFLAGS} \
CPPFLAGS=${BUILD_CPPFLAGS} \
LDFLAGS="${BUILD_LDFLAGS} ${lbuildflags}" \
- do_configure cross --without-shared --with-normal
+ do_configure cross --without-shared --with-normal --with-progs
fi
multilib-minimal_src_configure
}
diff --git a/sys-libs/ncurses/ncurses-6.3.ebuild b/sys-libs/ncurses/ncurses-6.3.ebuild
index 0ec37369cc31..0faa70d2aa52 100644
--- a/sys-libs/ncurses/ncurses-6.3.ebuild
+++ b/sys-libs/ncurses/ncurses-6.3.ebuild
@@ -95,7 +95,7 @@ src_configure() {
CXXFLAGS=${BUILD_CXXFLAGS} \
CPPFLAGS=${BUILD_CPPFLAGS} \
LDFLAGS="${BUILD_LDFLAGS} ${lbuildflags}" \
- do_configure cross --without-shared --with-normal
+ do_configure cross --without-shared --with-normal --with-progs
fi
multilib-minimal_src_configure
}