summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-10-16 19:01:06 +0100
committerSam James <sam@gentoo.org>2022-10-16 19:01:52 +0100
commit9da22a2f622eaa9bddd09ae1eeefc879e3de58c1 (patch)
tree62c831250ffd259c40c296cf223fdf4b8e5c6fc6 /sys-fs
parentgames-roguelike/nethack: fix build w/ clang16, pass -std=gnu89 (diff)
downloadgentoo-9da22a2f622eaa9bddd09ae1eeefc879e3de58c1.tar.gz
gentoo-9da22a2f622eaa9bddd09ae1eeefc879e3de58c1.tar.bz2
gentoo-9da22a2f622eaa9bddd09ae1eeefc879e3de58c1.zip
sys-fs/hfsutils: add 3.2.6_p15, fix build w/ Clang 16
Closes: https://bugs.gentoo.org/871165 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/hfsutils/Manifest1
-rw-r--r--sys-fs/hfsutils/files/hfsutils-3.2.6_p15-Include-string.h-for-strcmp.patch17
-rw-r--r--sys-fs/hfsutils/files/hfsutils-3.2.6_p15-drop-manual-autoconf.patch78
-rw-r--r--sys-fs/hfsutils/hfsutils-3.2.6_p15.ebuild74
4 files changed, 170 insertions, 0 deletions
diff --git a/sys-fs/hfsutils/Manifest b/sys-fs/hfsutils/Manifest
index a8fde341db17..2bfbbbcea585 100644
--- a/sys-fs/hfsutils/Manifest
+++ b/sys-fs/hfsutils/Manifest
@@ -1,2 +1,3 @@
DIST hfsutils_3.2.6-14.debian.tar.xz 6780 BLAKE2B 00474d328f5ec2614ec429052e6940b9eb10d04f433399f686ccc24d66ca1559e7ca45c4ab3ebe6386e02fc4de5ffd96242a7aa6f58d6032798d5536da912a61 SHA512 33d44f7b9094743031fc9315cf9380e158225ee2cd5af7a5ec7c55a2ae9af42e16f9cad3c667b153a1d3d9484d4ea773d34b88b78bfe9499df52a8b9d77defb2
+DIST hfsutils_3.2.6-15.debian.tar.xz 6364 BLAKE2B 7a588ceb4fefe50531d669f9c70452d6f7105f54cd674740296154203336a0d0977eb17d6aa9122b003029c26a4aa7674919fcdbbf8c527031be71a56d5a2c3f SHA512 67e3e7d33918b58cb02b7b8626caac890cf6c3bda5d81adeae9d0fa55bf7ad8fad18b0ecec5619bdfb9be037e16b5986eb1c6c8cd2044164e31927c5a1b6b1bf
DIST hfsutils_3.2.6.orig.tar.gz 207697 BLAKE2B 96c3d839e3c07e325e4e175a484b3c637d7cdebdc02ec11ee6810096162d155aa75d71a8e133b801b767a78d50115384460c4181359767f49e015524800885e8 SHA512 0db3050e5969c4e4e6c6ddb10cbc221a5837eb1e12f9331e7129511d31a4ec8d38420ed0b948dadc85ed990f3b1085e930eb7f0c37b3883866d963e47cbbb173
diff --git a/sys-fs/hfsutils/files/hfsutils-3.2.6_p15-Include-string.h-for-strcmp.patch b/sys-fs/hfsutils/files/hfsutils-3.2.6_p15-Include-string.h-for-strcmp.patch
new file mode 100644
index 000000000000..4b9db273ec40
--- /dev/null
+++ b/sys-fs/hfsutils/files/hfsutils-3.2.6_p15-Include-string.h-for-strcmp.patch
@@ -0,0 +1,17 @@
+https://bugs.gentoo.org/871165
+
+From 065e349d0a0e1db9fda99f90ff825b7934f191da Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Sun, 16 Oct 2022 18:18:58 +0100
+Subject: [PATCH] Include <string.h> for strcmp
+
+--- a/hpwd.c
++++ b/hpwd.c
+@@ -24,6 +24,7 @@
+ # endif
+
+ # include <stdio.h>
++# include <string.h>
+
+ # include "hfs.h"
+ # include "hcwd.h"
diff --git a/sys-fs/hfsutils/files/hfsutils-3.2.6_p15-drop-manual-autoconf.patch b/sys-fs/hfsutils/files/hfsutils-3.2.6_p15-drop-manual-autoconf.patch
new file mode 100644
index 000000000000..00f5bfb8a438
--- /dev/null
+++ b/sys-fs/hfsutils/files/hfsutils-3.2.6_p15-drop-manual-autoconf.patch
@@ -0,0 +1,78 @@
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -197,23 +197,6 @@ dist ::
+
+ ###############################################################################
+
+-Makefile: config.status
+- ./config.status && touch .stamp/config.h
+-
+-.stamp/config.h: config.status
+- ./config.status && touch .stamp/config.h
+-
+-config.status: .stamp/configure .stamp/config.h.in Makefile.in
+- ./config.status --recheck
+-
+-.stamp/configure: configure.in
+- autoconf && touch .stamp/configure
+-
+-.stamp/config.h.in: configure.in acconfig.h
+- autoheader && touch .stamp/config.h.in
+-
+-###############################################################################
+-
+ $(LIBHFS) ::
+ cd libhfs && $(MAKE)
+
+--- a/libhfs/Makefile.in
++++ b/libhfs/Makefile.in
+@@ -96,23 +96,6 @@ maintainer-clean :: distclean
+
+ ###############################################################################
+
+-Makefile: config.status
+- ./config.status && touch .stamp/config.h
+-
+-.stamp/config.h: config.status
+- ./config.status && touch .stamp/config.h
+-
+-config.status: .stamp/configure .stamp/config.h.in Makefile.in
+- ./config.status --recheck
+-
+-.stamp/configure: configure.in
+- autoconf && touch .stamp/configure
+-
+-.stamp/config.h.in: configure.in acconfig.h
+- autoheader && touch .stamp/config.h.in
+-
+-###############################################################################
+-
+ $(HFSTARGET): $(HFSOBJS)
+ $(AR) $@ $(HFSOBJS)
+ $(RANLIB) $@
+--- a/librsrc/Makefile.in
++++ b/librsrc/Makefile.in
+@@ -92,23 +92,6 @@ maintainer-clean :: distclean
+
+ ###############################################################################
+
+-Makefile: config.status
+- ./config.status && touch .stamp/config.h
+-
+-.stamp/config.h: config.status
+- ./config.status && touch .stamp/config.h
+-
+-config.status: .stamp/configure .stamp/config.h.in Makefile.in
+- ./config.status --recheck
+-
+-.stamp/configure: configure.in
+- autoconf && touch .stamp/configure
+-
+-.stamp/config.h.in: configure.in acconfig.h
+- autoheader && touch .stamp/config.h.in
+-
+-###############################################################################
+-
+ $(RSRCTARGET): $(RSRCOBJS)
+ $(AR) $@ $(RSRCOBJS)
+ $(RANLIB) $@
diff --git a/sys-fs/hfsutils/hfsutils-3.2.6_p15.ebuild b/sys-fs/hfsutils/hfsutils-3.2.6_p15.ebuild
new file mode 100644
index 000000000000..dddff37401ba
--- /dev/null
+++ b/sys-fs/hfsutils/hfsutils-3.2.6_p15.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="HFS FS Access utils"
+HOMEPAGE="https://www.mars.org/home/rob/proj/hfs/"
+SRC_URI="
+ mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV/_p*}.orig.tar.gz
+ mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV/_p/-}.debian.tar.xz
+"
+S="${WORKDIR}"/${P/_p*}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="tcl tk"
+# Tests are enabled only with USE=tcl
+RESTRICT="!tcl? ( test )"
+# use tk requires tcl - bug #150437
+REQUIRED_USE="tk? ( tcl )"
+
+DEPEND="
+ tcl? ( dev-lang/tcl:= )
+ tk? ( dev-lang/tk:= )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${WORKDIR}"/debian/patches
+ "${FILESDIR}"/${P/_p*}-fix-tcl-8.6.patch
+ "${FILESDIR}"/${PN}-3.2.6-test-tcl-8.6.patch
+ "${FILESDIR}"/${PN}-3.2.6_p15-Include-string.h-for-strcmp.patch
+ "${FILESDIR}"/${PN}-3.2.6_p15-drop-manual-autoconf.patch
+)
+
+src_prepare() {
+ default
+
+ sed -i -e 's:configure.in:configure.ac:' {libhfs/,librsrc/,}{configure,Makefile,config.h}.in || die
+
+ eautoreconf
+}
+
+src_configure() {
+ tc-export CC
+
+ econf \
+ $(use_with tcl tcl /usr/$(get_libdir) no) \
+ $(use_with tk tk /usr/$(get_libdir) no)
+}
+
+src_compile() {
+ emake AR="$(tc-getAR) rc" CC="$(tc-getCC)" RANLIB="$(tc-getRANLIB)"
+ emake CC="$(tc-getCC)" -C hfsck
+}
+
+src_test() {
+ # Tests reuse the same image name. Let's serialize.
+ emake -j1 check
+}
+
+src_install() {
+ dodir /usr/bin /usr/lib /usr/share/man/man1
+ emake \
+ prefix="${ED}"/usr \
+ MANDEST="${ED}"/usr/share/man \
+ infodir="${ED}"/usr/share/info \
+ install
+ dobin hfsck/hfsck
+ dodoc BLURB CHANGES README TODO doc/*.txt
+}