summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Anderson <telans@posteo.de>2021-02-16 00:57:02 +1300
committerSam James <sam@gentoo.org>2021-02-16 18:39:31 +0000
commitbf7ba0264955e6608e8acf2cc36694727452c5cb (patch)
treebb8748386e1d257144434b02a469bbf351fa5d06 /sys-fs/compsize
parentwww-servers/nginx-unit: minor style changes (diff)
downloadgentoo-bf7ba0264955e6608e8acf2cc36694727452c5cb.tar.gz
gentoo-bf7ba0264955e6608e8acf2cc36694727452c5cb.tar.bz2
gentoo-bf7ba0264955e6608e8acf2cc36694727452c5cb.zip
sys-fs/compsize: bump to 1.5
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Theo Anderson <telans@posteo.de> Closes: https://github.com/gentoo/gentoo/pull/19474 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-fs/compsize')
-rw-r--r--sys-fs/compsize/Manifest1
-rw-r--r--sys-fs/compsize/compsize-1.5.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/sys-fs/compsize/Manifest b/sys-fs/compsize/Manifest
index ddbbc7d51ef2..8b32b0fbfb0d 100644
--- a/sys-fs/compsize/Manifest
+++ b/sys-fs/compsize/Manifest
@@ -1,2 +1,3 @@
DIST compsize-1.3.tar.gz 14782 BLAKE2B 738ff0e2b936f5974064759914284e495c895d22d95b705e1b8fac4b3189891771b0e5be7e0eeac0883dd92f9cef276400bb7ee79840fd7db14a5269e7f78f11 SHA512 411b92651fdc3d03deccbf38f72936fee95cf80c67d6368efbc0dafacfe9793815a23ef0d02f7feadf31391e415df3d90cd19fb3acc8cce94f37cb3e4eed623d
DIST compsize-1.4.tar.gz 15001 BLAKE2B 7e4d4a1f3ea59b23fec891c084f68ddb74838320a817767e48eb857de9678a1915d304d25b454afafec867ea6a028d99d9182087d3229ddae55d8305fe6b174c SHA512 c07081721f87d8a59e724a62a0a6d6724434292e6bb3ffb71acd7c47e21727db8f02f4df296cb6094c0e80d3cd555018e492616747ce69055d21302a6617ca54
+DIST compsize-1.5.tar.gz 15015 BLAKE2B 1a7fc676ffaeb69fd410a834eab54ef63c5fa11e428bd0567ab5dec5dc27fe1b4901fdd47760c07a7fb26375b81ba997528c0aa83409eb364a3b9f2cb1942cc8 SHA512 25d6f1973e8a0a86bd857dc1e1ba99760451cf388f3bd3ede6a6ef35351ff63f100646d313010aff3de9e70b2c68866a31c4ea31d9c6df9254648cd1bd0272fa
diff --git a/sys-fs/compsize/compsize-1.5.ebuild b/sys-fs/compsize/compsize-1.5.ebuild
new file mode 100644
index 000000000000..f00e46619d53
--- /dev/null
+++ b/sys-fs/compsize/compsize-1.5.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic
+
+DESCRIPTION="Utility to find btrfs compression type/ratio on a file or set of files"
+HOMEPAGE="https://github.com/kilobyte/compsize"
+
+if [[ ${PV} = 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/kilobyte/compsize.git"
+else
+ SRC_URI="https://github.com/kilobyte/compsize/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2+ GPL-2"
+IUSE="debug"
+SLOT="0"
+
+DEPEND="sys-fs/btrfs-progs"
+
+src_prepare() {
+ default
+ # Don't try to install a gzipped manfile during emake install
+ sed -i -e $'s/\.gz//' -e $'s/gzip.*/install \-Dm755 \$\< \$\@/' Makefile || die
+}
+
+src_configure() {
+ use debug && append-cflags -Wall -DDEBUG -g
+ default
+}
+
+src_install() {
+ emake PREFIX="${ED}/usr" install
+ einstalldocs
+}