summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-fs/avfs
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-fs/avfs')
-rw-r--r--sys-fs/avfs/Manifest3
-rw-r--r--sys-fs/avfs/avfs-1.0.1.ebuild61
-rw-r--r--sys-fs/avfs/avfs-1.0.2.ebuild61
-rw-r--r--sys-fs/avfs/avfs-1.0.3.ebuild61
-rw-r--r--sys-fs/avfs/metadata.xml13
5 files changed, 199 insertions, 0 deletions
diff --git a/sys-fs/avfs/Manifest b/sys-fs/avfs/Manifest
new file mode 100644
index 000000000000..75e2318f0bf5
--- /dev/null
+++ b/sys-fs/avfs/Manifest
@@ -0,0 +1,3 @@
+DIST avfs-1.0.1.tar.bz2 678562 SHA256 6c6558c35864660e6d26e67f42caeb2bc8f9ef2ad0c502fd659fb7d94724aaf1 SHA512 3eefb07ed303343c4e5ec873fb519f171e8b19f00efda5e78f4af573fccabbefa59f77a677a34a569343db743bb41368beaf6e399d69f228ad0a77878e41adf0 WHIRLPOOL 68153492899a67b36bb8f982bb319469ee8cdf64e8c1ae642fd2f746736bc5ee93c22b0fa005ffc42d5bed543332875b5d6ed096bfd0a8bf2c2da3cc47cfacbf
+DIST avfs-1.0.2.tar.bz2 723051 SHA256 52693953e8290281d441a898040c5ac2989f11bc1fcb83ca5063c37a125a1c9a SHA512 a248c025388d169e2c6a57f04487c0aefb2c574647aade49c3a27d62621c0ead25b321b87518cdd718cb238387a766ec9e7fef434f30dcc4dd2bf9fbcc3de020 WHIRLPOOL 71f3949f39b130522d98fdf6ae431c8d410fc83d4e91028223c6bf0a247373ac129257c1b85efacbe430320d6e870b373a3e65cbfad31eb123f691f02da5c26d
+DIST avfs-1.0.3.tar.bz2 722861 SHA256 c6dee77b2b71567528f897727e51695587189765fc35f694e4734db0a7d4fec8 SHA512 b20a8bcba0d1d0181a14d5f1204f0532817037e3b5d32931f00f988793cb6cdabec82298686d82aa34885209d22841754e990c9c35b6384e0b441f99fd3d1efd WHIRLPOOL 406b708b5b9516ec97e024f518eb7370031edf8410d8637763bacd05f6d15ceb06217c43a8f28381c0d2f9fbfcd991a27b57cb45521ed71696e70e41352b7de2
diff --git a/sys-fs/avfs/avfs-1.0.1.ebuild b/sys-fs/avfs/avfs-1.0.1.ebuild
new file mode 100644
index 000000000000..5de47122fb6f
--- /dev/null
+++ b/sys-fs/avfs/avfs-1.0.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils
+
+DESCRIPTION="AVFS is a virtual filesystem that allows browsing of compressed files"
+HOMEPAGE="http://sourceforge.net/projects/avf"
+SRC_URI="mirror://sourceforge/avf/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~hppa ppc ppc64 x86"
+IUSE="static-libs +lzma"
+
+RDEPEND=">=sys-fs/fuse-2.4
+ sys-libs/zlib
+ app-arch/bzip2
+ lzma? ( app-arch/xz-utils )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ --enable-fuse \
+ --enable-library \
+ --enable-shared \
+ --with-system-zlib \
+ --with-system-bzlib \
+ $(use_enable static-libs static) \
+ $(use_with lzma xz)
+}
+
+src_install() {
+ default
+
+ # remove cruft
+ rm "${D}"/usr/bin/{davpass,ftppass} || die
+
+ # install docs
+ dodoc doc/{api-overview,background,FORMAT,INSTALL.*,README.avfs-fuse}
+ dosym /usr/lib/avfs/extfs/README /usr/share/doc/${PF}/README.extfs
+
+ docinto scripts
+ dodoc scripts/{avfscoda*,*pass}
+
+ prune_libtool_files
+}
+
+pkg_postinst() {
+ einfo "This version of AVFS includes FUSE support. It is user-based."
+ einfo "To execute:"
+ einfo "1) as user, mkdir ~/.avfs"
+ einfo "2) make sure fuse is either compiled into the kernel OR"
+ einfo " modprobe fuse or add to startup."
+ einfo "3) run mountavfs"
+ einfo "To unload daemon, type umountavfs"
+ einfo
+ einfo "READ the documentation! Enjoy :)"
+}
diff --git a/sys-fs/avfs/avfs-1.0.2.ebuild b/sys-fs/avfs/avfs-1.0.2.ebuild
new file mode 100644
index 000000000000..5af46d3c0a42
--- /dev/null
+++ b/sys-fs/avfs/avfs-1.0.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="AVFS is a virtual filesystem that allows browsing of compressed files"
+HOMEPAGE="http://sourceforge.net/projects/avf"
+SRC_URI="mirror://sourceforge/avf/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+IUSE="static-libs +lzma"
+
+RDEPEND=">=sys-fs/fuse-2.4
+ sys-libs/zlib
+ app-arch/bzip2
+ lzma? ( app-arch/xz-utils )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ --enable-fuse \
+ --enable-library \
+ --enable-shared \
+ --with-system-zlib \
+ --with-system-bzlib \
+ $(use_enable static-libs static) \
+ $(use_with lzma xz)
+}
+
+src_install() {
+ default
+
+ # remove cruft
+ rm "${D}"/usr/bin/{davpass,ftppass} || die
+
+ # install docs
+ dodoc doc/{api-overview,background,FORMAT,INSTALL.*,README.avfs-fuse}
+ dosym /usr/lib/avfs/extfs/README /usr/share/doc/${PF}/README.extfs
+
+ docinto scripts
+ dodoc scripts/{avfscoda*,*pass}
+
+ prune_libtool_files
+}
+
+pkg_postinst() {
+ einfo "This version of AVFS includes FUSE support. It is user-based."
+ einfo "To execute:"
+ einfo "1) as user, mkdir ~/.avfs"
+ einfo "2) make sure fuse is either compiled into the kernel OR"
+ einfo " modprobe fuse or add to startup."
+ einfo "3) run mountavfs"
+ einfo "To unload daemon, type umountavfs"
+ einfo
+ einfo "READ the documentation! Enjoy :)"
+}
diff --git a/sys-fs/avfs/avfs-1.0.3.ebuild b/sys-fs/avfs/avfs-1.0.3.ebuild
new file mode 100644
index 000000000000..da4c5c82e47a
--- /dev/null
+++ b/sys-fs/avfs/avfs-1.0.3.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="AVFS is a virtual filesystem that allows browsing of compressed files"
+HOMEPAGE="http://sourceforge.net/projects/avf"
+SRC_URI="mirror://sourceforge/avf/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+IUSE="static-libs +lzma"
+
+RDEPEND=">=sys-fs/fuse-2.4
+ sys-libs/zlib
+ app-arch/bzip2
+ lzma? ( app-arch/xz-utils )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ --enable-fuse \
+ --enable-library \
+ --enable-shared \
+ --with-system-zlib \
+ --with-system-bzlib \
+ $(use_enable static-libs static) \
+ $(use_with lzma xz)
+}
+
+src_install() {
+ default
+
+ # remove cruft
+ rm "${D}"/usr/bin/{davpass,ftppass} || die
+
+ # install docs
+ dodoc doc/{api-overview,background,FORMAT,INSTALL.*,README.avfs-fuse}
+ dosym /usr/lib/avfs/extfs/README /usr/share/doc/${PF}/README.extfs
+
+ docinto scripts
+ dodoc scripts/{avfscoda*,*pass}
+
+ prune_libtool_files
+}
+
+pkg_postinst() {
+ einfo "This version of AVFS includes FUSE support. It is user-based."
+ einfo "To execute:"
+ einfo "1) as user, mkdir ~/.avfs"
+ einfo "2) make sure fuse is either compiled into the kernel OR"
+ einfo " modprobe fuse or add to startup."
+ einfo "3) run mountavfs"
+ einfo "To unload daemon, type umountavfs"
+ einfo
+ einfo "READ the documentation! Enjoy :)"
+}
diff --git a/sys-fs/avfs/metadata.xml b/sys-fs/avfs/metadata.xml
new file mode 100644
index 000000000000..26d3015a0b2e
--- /dev/null
+++ b/sys-fs/avfs/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>kernel-misc</herd>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>pete4abw@comcast.net</email>
+ <name>Peter Hyman</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">avf</remote-id>
+ </upstream>
+</pkgmetadata>