summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-08-25 03:06:56 +0100
committerSam James <sam@gentoo.org>2022-08-25 03:09:27 +0100
commited18bdc4fcc38d8015b4a17b3537444dcf61b5aa (patch)
tree6a5a481f347775cb58303c42b90ac04ba77770f3 /sys-devel
parentsys-devel/cproc: new package from ::guru, add 0_pre20220805, 9999 (diff)
downloadgentoo-ed18bdc4fcc38d8015b4a17b3537444dcf61b5aa.tar.gz
gentoo-ed18bdc4fcc38d8015b4a17b3537444dcf61b5aa.tar.bz2
gentoo-ed18bdc4fcc38d8015b4a17b3537444dcf61b5aa.zip
sys-devel/qbe: style tweaks, EAPI 8, respect CC
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/qbe/qbe-1.0.ebuild (renamed from sys-devel/qbe/qbe-1.0-r1.ebuild)12
-rw-r--r--sys-devel/qbe/qbe-9999.ebuild8
2 files changed, 14 insertions, 6 deletions
diff --git a/sys-devel/qbe/qbe-1.0-r1.ebuild b/sys-devel/qbe/qbe-1.0.ebuild
index 28dcf876539b..d041b7d0b849 100644
--- a/sys-devel/qbe/qbe-1.0-r1.ebuild
+++ b/sys-devel/qbe/qbe-1.0.ebuild
@@ -1,25 +1,31 @@
# Copyright 2021-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-if [[ "${PV}" == "9999" ]]; then
- inherit git-r3
+inherit toolchain-funcs
+
+if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="git://c9x.me/qbe.git"
+ inherit git-r3
else
SRC_URI="https://c9x.me/compile/release/${P}.tar.xz"
+
# 64-bit RISC-V only
KEYWORDS="~amd64 ~arm64 ~riscv"
fi
DESCRIPTION="Pure-C embeddable compiler backend"
HOMEPAGE="https://c9x.me/compile/"
+
LICENSE="MIT"
SLOT="0"
DOCS=( README doc )
src_compile() {
+ tc-export CC
+
emake CFLAGS="-std=c99 ${CPPFLAGS} ${CFLAGS}"
}
diff --git a/sys-devel/qbe/qbe-9999.ebuild b/sys-devel/qbe/qbe-9999.ebuild
index 28dcf876539b..2b2487f3dbbd 100644
--- a/sys-devel/qbe/qbe-9999.ebuild
+++ b/sys-devel/qbe/qbe-9999.ebuild
@@ -1,19 +1,21 @@
# Copyright 2021-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-if [[ "${PV}" == "9999" ]]; then
- inherit git-r3
+if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="git://c9x.me/qbe.git"
+ inherit git-r3
else
SRC_URI="https://c9x.me/compile/release/${P}.tar.xz"
+
# 64-bit RISC-V only
KEYWORDS="~amd64 ~arm64 ~riscv"
fi
DESCRIPTION="Pure-C embeddable compiler backend"
HOMEPAGE="https://c9x.me/compile/"
+
LICENSE="MIT"
SLOT="0"