summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-09-13 08:05:47 +0200
committerMichał Górny <mgorny@gentoo.org>2022-09-13 08:05:47 +0200
commit1ef6255055b3c9039c4b4a12b4674fca0897c132 (patch)
tree7df9a52b520da12c915a39c0f02875cb7b5b4318 /sys-devel/clang-runtime
parentmail-client/alpine: Stabilize 2.26-r1 x86, #869899 (diff)
downloadgentoo-1ef6255055b3c9039c4b4a12b4674fca0897c132.tar.gz
gentoo-1ef6255055b3c9039c4b4a12b4674fca0897c132.tar.bz2
gentoo-1ef6255055b3c9039c4b4a12b4674fca0897c132.zip
sys-devel/clang-runtime: Add a pkg_pretend() warning about breakage
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel/clang-runtime')
-rw-r--r--sys-devel/clang-runtime/clang-runtime-15.0.0-r1.ebuild (renamed from sys-devel/clang-runtime/clang-runtime-15.0.0.ebuild)16
-rw-r--r--sys-devel/clang-runtime/clang-runtime-15.0.0.9999.ebuild16
-rw-r--r--sys-devel/clang-runtime/clang-runtime-16.0.0.9999.ebuild16
3 files changed, 45 insertions, 3 deletions
diff --git a/sys-devel/clang-runtime/clang-runtime-15.0.0.ebuild b/sys-devel/clang-runtime/clang-runtime-15.0.0-r1.ebuild
index f0ec98510540..0540473519b1 100644
--- a/sys-devel/clang-runtime/clang-runtime-15.0.0.ebuild
+++ b/sys-devel/clang-runtime/clang-runtime-15.0.0-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit multilib-build
+inherit multilib-build toolchain-funcs
DESCRIPTION="Meta-ebuild for clang runtime libraries"
HOMEPAGE="https://clang.llvm.org/"
@@ -24,3 +24,17 @@ RDEPEND="
libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )
"
+
+pkg_pretend() {
+ if tc-is-clang; then
+ ewarn "You seem to be using clang as a system compiler. As of clang-15,"
+ ewarn "upstream has turned a few warnings that commonly occur during"
+ ewarn "configure script runs into errors by default. This causes some"
+ ewarn "configure tests to start failing, sometimes resulting in silent"
+ ewarn "breakage, missing functionality or runtime misbehavior. It is"
+ ewarn "not yet clear whether the change will remain or be reverted."
+ ewarn
+ ewarn "For more information, please see:"
+ ewarn "https://discourse.llvm.org/t/configure-script-breakage-with-the-new-werror-implicit-function-declaration/65213"
+ fi
+}
diff --git a/sys-devel/clang-runtime/clang-runtime-15.0.0.9999.ebuild b/sys-devel/clang-runtime/clang-runtime-15.0.0.9999.ebuild
index e4ff9326ddcb..c45769b02981 100644
--- a/sys-devel/clang-runtime/clang-runtime-15.0.0.9999.ebuild
+++ b/sys-devel/clang-runtime/clang-runtime-15.0.0.9999.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit multilib-build
+inherit multilib-build toolchain-funcs
DESCRIPTION="Meta-ebuild for clang runtime libraries"
HOMEPAGE="https://clang.llvm.org/"
@@ -25,3 +25,17 @@ RDEPEND="
libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )
"
+
+pkg_pretend() {
+ if tc-is-clang; then
+ ewarn "You seem to be using clang as a system compiler. As of clang-15,"
+ ewarn "upstream has turned a few warnings that commonly occur during"
+ ewarn "configure script runs into errors by default. This causes some"
+ ewarn "configure tests to start failing, sometimes resulting in silent"
+ ewarn "breakage, missing functionality or runtime misbehavior. It is"
+ ewarn "not yet clear whether the change will remain or be reverted."
+ ewarn
+ ewarn "For more information, please see:"
+ ewarn "https://discourse.llvm.org/t/configure-script-breakage-with-the-new-werror-implicit-function-declaration/65213"
+ fi
+}
diff --git a/sys-devel/clang-runtime/clang-runtime-16.0.0.9999.ebuild b/sys-devel/clang-runtime/clang-runtime-16.0.0.9999.ebuild
index e4ff9326ddcb..c45769b02981 100644
--- a/sys-devel/clang-runtime/clang-runtime-16.0.0.9999.ebuild
+++ b/sys-devel/clang-runtime/clang-runtime-16.0.0.9999.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit multilib-build
+inherit multilib-build toolchain-funcs
DESCRIPTION="Meta-ebuild for clang runtime libraries"
HOMEPAGE="https://clang.llvm.org/"
@@ -25,3 +25,17 @@ RDEPEND="
libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )
"
+
+pkg_pretend() {
+ if tc-is-clang; then
+ ewarn "You seem to be using clang as a system compiler. As of clang-15,"
+ ewarn "upstream has turned a few warnings that commonly occur during"
+ ewarn "configure script runs into errors by default. This causes some"
+ ewarn "configure tests to start failing, sometimes resulting in silent"
+ ewarn "breakage, missing functionality or runtime misbehavior. It is"
+ ewarn "not yet clear whether the change will remain or be reverted."
+ ewarn
+ ewarn "For more information, please see:"
+ ewarn "https://discourse.llvm.org/t/configure-script-breakage-with-the-new-werror-implicit-function-declaration/65213"
+ fi
+}