summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-09-26 09:56:13 +0200
committerJustin Lecher <jlec@gentoo.org>2015-09-26 09:56:20 +0200
commit8f09d6f5c9a821e7e5bcf3bdc746624997ad32c8 (patch)
tree7202d31278ec414a85cf005967e57107e7426bb1 /sys-apps/spu-tools/spu-tools-2.3.0.136.ebuild
parentapp-text/chasen: QA fixes (diff)
downloadgentoo-8f09d6f5c9a821e7e5bcf3bdc746624997ad32c8.tar.gz
gentoo-8f09d6f5c9a821e7e5bcf3bdc746624997ad32c8.tar.bz2
gentoo-8f09d6f5c9a821e7e5bcf3bdc746624997ad32c8.zip
sys-apps/spu-tools: Version Bump
Bumpt EPAI=5 Respect CC fix build for ncurses[tinfo] fix compilation problems with format-security Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=435086 Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=466790 Package-Manager: portage-2.2.22 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'sys-apps/spu-tools/spu-tools-2.3.0.136.ebuild')
-rw-r--r--sys-apps/spu-tools/spu-tools-2.3.0.136.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sys-apps/spu-tools/spu-tools-2.3.0.136.ebuild b/sys-apps/spu-tools/spu-tools-2.3.0.136.ebuild
new file mode 100644
index 000000000000..403c5158753a
--- /dev/null
+++ b/sys-apps/spu-tools/spu-tools-2.3.0.136.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+MY_P=${P/_p/-}
+
+DESCRIPTION="CELL spu ps and top alike utilities"
+HOMEPAGE="http://sourceforge.net/projects/libspe"
+SRC_URI="mirror://sourceforge/libspe/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~ppc64"
+IUSE=""
+
+RDEPEND="sys-libs/ncurses:0="
+DEPEND="${RDEPEND}
+ sys-apps/help2man"
+
+S="${WORKDIR}/${PN}/src"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-buildsystem.patch \
+ "${FILESDIR}"/${P}-format-security.patch
+ tc-export CC
+ export CFLAGS="${CFLAGS}"
+ export LDFLAGS="${LDFLAGS}"
+ export LIBS="$($(tc-getPKG_CONFIG) --libs ncurses)"
+}