summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-03-15 00:10:13 -0400
committerSam James <sam@gentoo.org>2024-03-15 04:14:17 +0000
commit90dd97dc92817313930b0f799ef8095967001e3f (patch)
treecad3f20fe7efefbad6dcef7ab8bfc142d3596b86 /sys-apps/sg3_utils
parentsys-apps/sg3_utils: drop build time dependency on libtool (diff)
downloadgentoo-90dd97dc92817313930b0f799ef8095967001e3f.tar.gz
gentoo-90dd97dc92817313930b0f799ef8095967001e3f.tar.bz2
gentoo-90dd97dc92817313930b0f799ef8095967001e3f.zip
sys-apps/sg3_utils: make sure elibtoolize is applied
Needed to e.g. pass LTO warning flags through to the linker. Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/sg3_utils')
-rw-r--r--sys-apps/sg3_utils/sg3_utils-1.47-r1.ebuild7
1 files changed, 7 insertions, 0 deletions
diff --git a/sys-apps/sg3_utils/sg3_utils-1.47-r1.ebuild b/sys-apps/sg3_utils/sg3_utils-1.47-r1.ebuild
index 039dbca591cd..000805d29a24 100644
--- a/sys-apps/sg3_utils/sg3_utils-1.47-r1.ebuild
+++ b/sys-apps/sg3_utils/sg3_utils-1.47-r1.ebuild
@@ -3,6 +3,8 @@
EAPI=7
+inherit libtool
+
DESCRIPTION="Apps for querying the sg SCSI interface"
HOMEPAGE="https://sg.danny.cz/sg/"
#SRC_URI="https://github.com/hreinecke/sg3_utils/archive/v${PV}.tar.gz -> ${P}.tar.gz"
@@ -20,6 +22,11 @@ PATCHES=(
"${FILESDIR}"/${PN}-1.47-musl.patch
)
+src_prepare() {
+ default
+ elibtoolize
+}
+
src_configure() {
econf $(use_enable static-libs static)
}