summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-apps/netboot-base
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-apps/netboot-base')
-rw-r--r--sys-apps/netboot-base/Manifest1
-rw-r--r--sys-apps/netboot-base/metadata.xml5
-rw-r--r--sys-apps/netboot-base/netboot-base-20050110.ebuild46
3 files changed, 52 insertions, 0 deletions
diff --git a/sys-apps/netboot-base/Manifest b/sys-apps/netboot-base/Manifest
new file mode 100644
index 000000000000..57aefa6dbc1a
--- /dev/null
+++ b/sys-apps/netboot-base/Manifest
@@ -0,0 +1 @@
+DIST netboot-base-20050110.tar.bz2 4313 RMD160 1dd44d31d8315c25c0b6545a54dbcd270583fb8e SHA1 fed12df406df215f738ffe087463db3c7626f9f5 SHA256 0b756d457c6ac705548b903a30685860f3403f7389f6325f0460b7603d9d9bf8
diff --git a/sys-apps/netboot-base/metadata.xml b/sys-apps/netboot-base/metadata.xml
new file mode 100644
index 000000000000..96a2d586367d
--- /dev/null
+++ b/sys-apps/netboot-base/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>base-system</herd>
+</pkgmetadata>
diff --git a/sys-apps/netboot-base/netboot-base-20050110.ebuild b/sys-apps/netboot-base/netboot-base-20050110.ebuild
new file mode 100644
index 000000000000..5a3e56379e40
--- /dev/null
+++ b/sys-apps/netboot-base/netboot-base-20050110.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs
+
+DESCRIPTION="Baselayout for netboot systems"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI="http://dev.gentoo.org/~vapier/${P}.tar.bz2
+ mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha arm hppa ~mips ppc sh sparc x86"
+IUSE=""
+
+DEPEND=""
+
+S=${WORKDIR}
+
+pkg_setup() {
+ [[ ${ROOT} = "/" ]] && die "refusing to emerge to /"
+}
+
+src_compile() {
+ $(tc-getCC) ${CFLAGS} src/consoletype.c -o sbin/consoletype || die
+ $(tc-getSTRIP) --strip-unneeded sbin/consoletype
+}
+
+src_install() {
+ rm -r src
+ cp -r * "${D}"/ || die
+}
+
+pkg_preinst() {
+ [[ ${ROOT} = "/" ]] && die "refusing to install to /"
+}
+
+pkg_postinst() {
+ cd "${ROOT}"
+ mkdir -p bin dev etc lib mnt proc sbin var
+ mkdir -p var/log
+ mkdir -p mnt/gentoo
+ ln -s . usr
+ ln -s . share
+}