summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2018-08-20 03:12:03 +0300
committerMikle Kolyada <zlogene@gentoo.org>2018-08-20 03:12:03 +0300
commit5e4daad6d5ba3e7c3e02f6e24189b22ecc25ff68 (patch)
tree16e38e2a65d0553d0ab5c942ed86e6b85165beea /sys-apps/less
parentnet-misc/remmina: version bump to 1.2.31.3. (diff)
downloadgentoo-5e4daad6d5ba3e7c3e02f6e24189b22ecc25ff68.tar.gz
gentoo-5e4daad6d5ba3e7c3e02f6e24189b22ecc25ff68.tar.bz2
gentoo-5e4daad6d5ba3e7c3e02f6e24189b22ecc25ff68.zip
sys-apps/less: Version bump (v533)
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'sys-apps/less')
-rw-r--r--sys-apps/less/Manifest1
-rw-r--r--sys-apps/less/less-533.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/sys-apps/less/Manifest b/sys-apps/less/Manifest
index 7d5958666147..7f106765c115 100644
--- a/sys-apps/less/Manifest
+++ b/sys-apps/less/Manifest
@@ -1,3 +1,4 @@
DIST less-529.tar.gz 339651 BLAKE2B 745146fd584c6144b4052d18bae07a2b4c7a719d36c556c69837f2018ef95efeea35acadcb9946bdde0272848d1bd8537c847e89591d980ceb2eda5a4c5963c4 SHA512 902e3ed86161c5a9eb3c08567b6b702371b5c88a85ef0b21beada223eaa47e0abf4d4d166a4a7a195caef67509fa683d07d0b6a40b529d703ee26aa8910c360a
DIST less-530.tar.gz 339723 BLAKE2B 9321548b06330c0b1b5b5a36147f5b9348619ff15d907808744b89581edeb4d8c2118ba455d024a23850902cac4d2c34d1e7b9897e02769584315c0e67ef667e SHA512 8d83a18b5648c4fe85921a563aa2c40bcf495aeb611098c83cd167b1e2f706649846cdf457c8506ae2683ab362ad970a0b261747349673020894bccdb9acbc10
DIST less-531.tar.gz 340466 BLAKE2B 6ac75b623fce478114d18cff429659499fedf4ef1a7bb067465ace91c28a7968efb224a4994a1e376a8cf40b110492f10ecda634628029107b38187044a0cd1e SHA512 180b665f194d7cc40d4bbb37bd64b10be463c0705e81795bef84b20dbba1c61825bb3e3da8bcd79f9176bb3af7b1f4e4c3dfe0829a5a2195a11f5b42294daca1
+DIST less-533.tar.gz 341035 BLAKE2B 19e6250ef79d1356b296dd23f2aba45ddddedc1a4c365154d18cd7fa7b79d7ed8c60d8a56646523b8e713d6eede065f3e5fb33527d97053adb2b38fe1f93325c SHA512 a2fa8286f185de866d7c74d9468d201905dcd1b95dfc37013bff3a98a7c8229d76f31584c2db5fe980999cef3445b7db63d5c244078ae0459830fcee609a8e39
diff --git a/sys-apps/less/less-533.ebuild b/sys-apps/less/less-533.ebuild
new file mode 100644
index 000000000000..6509cbbb85e3
--- /dev/null
+++ b/sys-apps/less/less-533.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Excellent text file viewer"
+HOMEPAGE="http://www.greenwoodsoftware.com/less/"
+SRC_URI="http://www.greenwoodsoftware.com/less/${P}.tar.gz"
+
+LICENSE="|| ( GPL-3 BSD-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="pcre unicode"
+
+DEPEND=">=app-misc/editor-wrapper-3
+ >=sys-libs/ncurses-5.2:0=
+ pcre? ( dev-libs/libpcre )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ export ac_cv_lib_ncursesw_initscr=$(usex unicode)
+ export ac_cv_lib_ncurses_initscr=$(usex !unicode)
+ local myeconfargs=(
+ --with-regex=$(usex pcre pcre posix)
+ --with-editor="${EPREFIX}"/usr/libexec/editor
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ newbin "${FILESDIR}"/lesspipe.sh lesspipe
+ newenvd "${FILESDIR}"/less.envd 70less
+}
+
+pkg_preinst() {
+ if has_version "<${CATEGORY}/${PN}-483-r1" ; then
+ elog "The lesspipe.sh symlink has been dropped. If you are still setting"
+ elog "LESSOPEN to that, you will need to update it to '|lesspipe %s'."
+ elog "Colorization support has been dropped. If you want that, check out"
+ elog "the new app-text/lesspipe package."
+ fi
+}