summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSv. Lockal <lockalsash@gmail.com>2024-07-20 17:41:48 +0000
committerSam James <sam@gentoo.org>2024-09-09 19:15:19 +0100
commita8ebfeb02eb7b1bc84d2108a3a933d998604c141 (patch)
tree5ef94755205c780937dc37a715539c07ca33bc1b /sci-libs
parentsci-libs/rocSPARSE: strip unsupported flags for potentially switched compiler (diff)
downloadgentoo-a8ebfeb02eb7b1bc84d2108a3a933d998604c141.tar.gz
gentoo-a8ebfeb02eb7b1bc84d2108a3a933d998604c141.tar.bz2
gentoo-a8ebfeb02eb7b1bc84d2108a3a933d998604c141.zip
sci-libs/rocThrust: strip unsupported flags for potentially switched compiler
Bug: https://bugs.gentoo.org/936099 Signed-off-by: Sv. Lockal <lockalsash@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/rocThrust/rocThrust-6.1.1.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/sci-libs/rocThrust/rocThrust-6.1.1.ebuild b/sci-libs/rocThrust/rocThrust-6.1.1.ebuild
index 7a04d78cbe0f..c63a53337467 100644
--- a/sci-libs/rocThrust/rocThrust-6.1.1.ebuild
+++ b/sci-libs/rocThrust/rocThrust-6.1.1.ebuild
@@ -32,6 +32,8 @@ BDEPEND=">=dev-build/cmake-3.22"
PATCHES=( "${FILESDIR}/${PN}-4.0-operator_new.patch" )
src_configure() {
+ rocm_use_hipcc
+
local mycmakeargs=(
-DCMAKE_SKIP_RPATH=ON
-DAMDGPU_TARGETS="$(get_amdgpu_flags)"
@@ -40,7 +42,7 @@ src_configure() {
-DBUILD_FILE_REORG_BACKWARD_COMPATIBILITY=OFF
)
- CXX=hipcc cmake_src_configure
+ cmake_src_configure
}
src_test() {