summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-06-28 12:56:35 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-06-28 12:56:45 +0200
commitd429baf76dfbce3ce995e2524013635fada2ddfe (patch)
tree9243f2084e6a2e902ac2a258ec79986eafed64d8 /sci-libs/pcl/pcl-9999.ebuild
parentdev-ros/costmap_2d: add := dep on pcl (diff)
downloadgentoo-d429baf76dfbce3ce995e2524013635fada2ddfe.tar.gz
gentoo-d429baf76dfbce3ce995e2524013635fada2ddfe.tar.bz2
gentoo-d429baf76dfbce3ce995e2524013635fada2ddfe.zip
sci-libs/pcl: bump to 1.8.0 and add subslot
Package-Manager: portage-2.3.0
Diffstat (limited to 'sci-libs/pcl/pcl-9999.ebuild')
-rw-r--r--sci-libs/pcl/pcl-9999.ebuild17
1 files changed, 11 insertions, 6 deletions
diff --git a/sci-libs/pcl/pcl-9999.ebuild b/sci-libs/pcl/pcl-9999.ebuild
index 528691c16cc7..c5c91fc0fb67 100644
--- a/sci-libs/pcl/pcl-9999.ebuild
+++ b/sci-libs/pcl/pcl-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -24,8 +24,8 @@ fi
HOMEPAGE="http://pointclouds.org/"
DESCRIPTION="2D/3D image and point cloud processing"
LICENSE="BSD"
-SLOT="0"
-IUSE="cuda doc opengl openni openni2 pcap png +qhull qt4 usb vtk cpu_flags_x86_sse test tutorials"
+SLOT="0/1.8"
+IUSE="cuda doc opengl openni openni2 pcap png +qhull qt5 usb vtk cpu_flags_x86_sse test tutorials"
RDEPEND="
>=sci-libs/flann-1.7.1
@@ -37,9 +37,14 @@ RDEPEND="
pcap? ( net-libs/libpcap )
png? ( media-libs/libpng:0= )
qhull? ( media-libs/qhull )
- qt4? ( dev-qt/qtgui:4 )
+ qt5? (
+ dev-qt/qtgui:5
+ dev-qt/qtcore:5
+ dev-qt/qtconcurrent:5
+ dev-qt/qtopengl:5
+ )
usb? ( virtual/libusb:1 )
- vtk? ( >=sci-libs/vtk-5.6[imaging,rendering,qt4?] )
+ vtk? ( >=sci-libs/vtk-5.6[imaging,rendering] )
cuda? ( >=dev-util/nvidia-cuda-toolkit-4 )
"
DEPEND="${RDEPEND}
@@ -63,7 +68,7 @@ src_configure() {
"-DWITH_OPENGL=$(usex opengl TRUE FALSE)"
"-DWITH_PNG=$(usex png TRUE FALSE)"
"-DWITH_QHULL=$(usex qhull TRUE FALSE)"
- "-DWITH_QT=$(usex qt4 TRUE FALSE)"
+ "-DWITH_QT=$(usex qt5 TRUE FALSE)"
"-DWITH_VTK=$(usex vtk TRUE FALSE)"
"-DWITH_PCAP=$(usex pcap TRUE FALSE)"
"-DWITH_OPENNI=$(usex openni TRUE FALSE)"