summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-biology/bioperl/bioperl-1.6.9.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-biology/bioperl/bioperl-1.6.9.ebuild')
-rw-r--r--sci-biology/bioperl/bioperl-1.6.9.ebuild68
1 files changed, 68 insertions, 0 deletions
diff --git a/sci-biology/bioperl/bioperl-1.6.9.ebuild b/sci-biology/bioperl/bioperl-1.6.9.ebuild
new file mode 100644
index 000000000000..afaa8236b5a2
--- /dev/null
+++ b/sci-biology/bioperl/bioperl-1.6.9.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+MY_PN=BioPerl
+MODULE_AUTHOR=CJFIELDS
+MODULE_VERSION=1.6.901
+inherit perl-module
+
+SUBPROJECTS="+db +network +run"
+MIN_PV=$PV
+
+DESCRIPTION="Perl tools for bioinformatics - Core modules"
+HOMEPAGE="http://www.bioperl.org/"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="-minimal graphviz sqlite ${SUBPROJECTS}"
+
+REQUIRED_USE="minimal? ( !graphviz )"
+
+CDEPEND="
+ dev-perl/libwww-perl
+ !minimal? (
+ dev-perl/Algorithm-Munkres
+ dev-perl/Array-Compare
+ dev-perl/yaml
+ dev-perl/Bio-ASN1-EntrezGene
+ dev-perl/Clone
+ dev-perl/Convert-Binary-C
+ dev-perl/Data-Stag
+ dev-perl/GD
+ dev-perl/Graph
+ >=dev-perl/HTML-Parser-3.60
+ dev-perl/List-MoreUtils
+ dev-perl/Math-Random
+ dev-perl/PostScript
+ dev-perl/set-scalar
+ dev-perl/SOAP-Lite
+ dev-perl/Sort-Naturally
+ dev-perl/Spreadsheet-ParseExcel
+ >=virtual/perl-Storable-2.05
+ >=dev-perl/SVG-2.26
+ >=dev-perl/SVG-Graph-0.01
+ dev-perl/URI
+ >=dev-perl/XML-DOM-XPath-0.13
+ dev-perl/XML-Parser
+ >=dev-perl/XML-SAX-0.15
+ dev-perl/XML-Simple
+ dev-perl/XML-Twig
+ >=dev-perl/XML-Writer-0.4
+ dev-perl/XML-DOM
+ dev-perl/XML-XPath
+ )
+ graphviz? ( dev-perl/GraphViz )
+ sqlite? ( dev-perl/DBD-SQLite )"
+DEPEND="dev-perl/Module-Build
+ ${CDEPEND}"
+RDEPEND="${CDEPEND}"
+PDEPEND="db? ( >=sci-biology/bioperl-db-${MIN_PV} )
+ network? ( >=sci-biology/bioperl-network-${MIN_PV} )
+ run? ( >=sci-biology/bioperl-run-${MIN_PV} )"
+
+src_install() {
+ mydoc="AUTHORS BUGS FAQ"
+ perl-module_src_install
+}