summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Tsoy <alexander@tsoy.me>2022-09-30 19:16:35 +0300
committerSam James <sam@gentoo.org>2022-10-01 04:14:55 +0100
commitc7dc14033cc6464195f718cad55c157e1dbf2f81 (patch)
tree2db0acab106a64d458f4e3b7c773cc52c9d9f2e9 /net-p2p
parentprofiles/arch/ia64: mask net-misc/chrony[html] (diff)
downloadgentoo-c7dc14033cc6464195f718cad55c157e1dbf2f81.tar.gz
gentoo-c7dc14033cc6464195f718cad55c157e1dbf2f81.tar.bz2
gentoo-c7dc14033cc6464195f718cad55c157e1dbf2f81.zip
net-p2p/amule: fix build with gcc-11 and musl
Also update EAPI 7 -> 8 and apply pathes to the live version. Closes: https://bugs.gentoo.org/836739 Closes: https://bugs.gentoo.org/872263 Signed-off-by: Alexander Tsoy <alexander@tsoy.me> Closes: https://github.com/gentoo/gentoo/pull/27543 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/amule/amule-2.3.3.ebuild3
-rw-r--r--net-p2p/amule/amule-9999.ebuild6
-rw-r--r--net-p2p/amule/files/amule-2.3.3-fix-exception.patch12
3 files changed, 18 insertions, 3 deletions
diff --git a/net-p2p/amule/amule-2.3.3.ebuild b/net-p2p/amule/amule-2.3.3.ebuild
index 1c0c098150de..292872783ad9 100644
--- a/net-p2p/amule/amule-2.3.3.ebuild
+++ b/net-p2p/amule/amule-2.3.3.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
WX_GTK_VER="3.0-gtk3"
inherit wxwidgets xdg-utils
@@ -50,6 +50,7 @@ BDEPEND="
PATCHES=(
"${FILESDIR}/${PN}-2.3.2-disable-version-check.patch"
+ "${FILESDIR}/${PN}-2.3.3-fix-exception.patch"
)
pkg_setup() {
diff --git a/net-p2p/amule/amule-9999.ebuild b/net-p2p/amule/amule-9999.ebuild
index a108c9752909..392ddb148410 100644
--- a/net-p2p/amule/amule-9999.ebuild
+++ b/net-p2p/amule/amule-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
WX_GTK_VER="3.0-gtk3"
inherit wxwidgets xdg-utils
@@ -49,6 +49,8 @@ BDEPEND="
"
PATCHES=(
+ "${FILESDIR}/${PN}-2.3.2-disable-version-check.patch"
+ "${FILESDIR}/${PN}-2.3.3-fix-exception.patch"
)
pkg_setup() {
diff --git a/net-p2p/amule/files/amule-2.3.3-fix-exception.patch b/net-p2p/amule/files/amule-2.3.3-fix-exception.patch
new file mode 100644
index 000000000000..ef38f94cfccf
--- /dev/null
+++ b/net-p2p/amule/files/amule-2.3.3-fix-exception.patch
@@ -0,0 +1,12 @@
+diff --git a/src/libs/common/MuleDebug.cpp b/src/libs/common/MuleDebug.cpp
+index 4b023815c..19c172e61 100644
+--- a/src/libs/common/MuleDebug.cpp
++++ b/src/libs/common/MuleDebug.cpp
+@@ -55,6 +55,7 @@
+ #endif
+
+ #include <vector>
++#include <exception>
+
+
+ /**