summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2024-11-28 12:55:55 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2024-11-28 13:15:43 +0100
commit231cd0caa439b28bfbb16d3e7cc585a8296ed50a (patch)
tree6db59742b7f5a3f24ddad159cfc9187b9bebc310 /net-mail
parentapp-mobilephone/scrcpy: drop 2.6.1 (diff)
downloadgentoo-231cd0caa439b28bfbb16d3e7cc585a8296ed50a.tar.gz
gentoo-231cd0caa439b28bfbb16d3e7cc585a8296ed50a.tar.bz2
gentoo-231cd0caa439b28bfbb16d3e7cc585a8296ed50a.zip
net-mail/fetchmail: add 6.5.1
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/fetchmail/Manifest1
-rw-r--r--net-mail/fetchmail/fetchmail-6.5.1.ebuild86
2 files changed, 87 insertions, 0 deletions
diff --git a/net-mail/fetchmail/Manifest b/net-mail/fetchmail/Manifest
index 40d5bc3b36e1..f78fa0e45a2d 100644
--- a/net-mail/fetchmail/Manifest
+++ b/net-mail/fetchmail/Manifest
@@ -1,2 +1,3 @@
DIST fetchmail-6.4.39.tar.xz 1221596 BLAKE2B 2d03f6668d2882e7dd1d4e83e8643a2a4c81576a143c75ff1b24327873fa6112fa313f9723373a268e04697b76b3b638cbbd7a04c21cba946cd1532b6aaf201d SHA512 979721aead72c9b706f9c64a83cf78a91890f5a2dce235b3b4f0dbdb17e879eaef2fb9a08efb415cb288ebee07c915adc8025a6d2d11f532fb95a9e30f93f7f5
DIST fetchmail-6.5.0.tar.xz 1108148 BLAKE2B 4863ab9cfcdc8678654d9715562daaf9a0e41d42cb727559e3039345f18a10aba08c122ff1f68ee356f1479af64bc534dba76fb9f1be99d449cf28bf823a3565 SHA512 ae69196b572c4a849a98bb66b672a68b6c984657b317d1d7048c9772a0d40bcb0105be05acc2d11383b65c5972a1a80e44dc4b05f2d5a3d2315f31eb493600c8
+DIST fetchmail-6.5.1.tar.xz 1110924 BLAKE2B fc0b5fb8db3d823134beece36e874fd931cc53019f3e9997aefeb10f92005e6cc975daaf5c79e6218b222f5c644706a9c83bccf39af68b30a57624184d9b985e SHA512 f82f5a9ba83c529c2e85cf36e714a1075cdb7dca2c888d9a2bee4f4a52acffda7efc71f23d04c4d3f83767e3aa4ccc50d8d981f8f3be51bca3fb40e5cb5e79cf
diff --git a/net-mail/fetchmail/fetchmail-6.5.1.ebuild b/net-mail/fetchmail/fetchmail-6.5.1.ebuild
new file mode 100644
index 000000000000..833150d00654
--- /dev/null
+++ b/net-mail/fetchmail/fetchmail-6.5.1.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools systemd tmpfiles toolchain-funcs
+
+DESCRIPTION="the legendary remote-mail retrieval and forwarding utility"
+HOMEPAGE="https://www.fetchmail.info/"
+SRC_URI="https://downloads.sourceforge.net/${PN}/${P}.tar.xz"
+S=${WORKDIR}/${P/_/.}
+
+LICENSE="GPL-2 public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-solaris"
+IUSE="ssl nls kerberos tk selinux socks"
+
+RDEPEND="acct-user/fetchmail
+ ssl? ( >=dev-libs/openssl-3.0.9:= )
+ kerberos? ( virtual/krb5 )
+ nls? ( virtual/libintl )
+ !elibc_glibc? ( sys-fs/e2fsprogs )
+ socks? ( net-proxy/dante )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ app-alternatives/lex
+ nls? ( sys-devel/gettext )"
+RDEPEND+=" selinux? ( sec-policy/selinux-fetchmail )"
+
+REQUIRED_USE="kerberos? ( ssl )"
+
+DOCS="FAQ FEATURES NEWS NOTES README README.NTLM README.SSL* TODO"
+HTML_DOCS="*.html"
+PATCHES=(
+ "${FILESDIR}"/${PN}-6.3.26-python-optional.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ export PYTHON=:
+
+ econf \
+ --enable-RPA \
+ --enable-NTLM \
+ --enable-SDPS \
+ $(use_enable nls) \
+ $(use_with ssl ssl "${EPREFIX}/usr") \
+ $(use_with kerberos gssapi) \
+ $(use_with kerberos kerberos5) \
+ --without-hesiod \
+ $(use_with socks)
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}"/fetchmail.initd fetchmail
+ newconfd "${FILESDIR}"/fetchmail.confd fetchmail
+
+ systemd_dounit "${FILESDIR}"/${PN}.service
+ systemd_newunit "${FILESDIR}"/${PN}_at.service "${PN}@.service"
+ dotmpfiles "${FILESDIR}"/${PN}.conf
+
+ docinto contrib
+ local f
+ for f in contrib/* ; do
+ [ -f "${f}" ] && dodoc "${f}"
+ done
+}
+
+pkg_postinst() {
+ tmpfiles_process ${PN}.conf
+
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "Please see /etc/conf.d/fetchmail if you want to adjust"
+ elog "the polling delay used by the fetchmail init script."
+ fi
+}