summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-09-05 15:06:20 -0400
committerMatt Turner <mattst88@gentoo.org>2023-09-05 16:28:32 -0400
commit2ca376e7038b4c5ed3fa147bc58c5659948dac3f (patch)
treea58303cb349159939457b4156f6b53d9dee99444 /net-libs
parentnet-libs/glib-networking: Drop old versions (diff)
downloadgentoo-2ca376e7038b4c5ed3fa147bc58c5659948dac3f.tar.gz
gentoo-2ca376e7038b4c5ed3fa147bc58c5659948dac3f.tar.bz2
gentoo-2ca376e7038b4c5ed3fa147bc58c5659948dac3f.zip
net-libs/gupnp: Drop old versions
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/gupnp/Manifest1
-rw-r--r--net-libs/gupnp/gupnp-1.6.3.ebuild77
2 files changed, 0 insertions, 78 deletions
diff --git a/net-libs/gupnp/Manifest b/net-libs/gupnp/Manifest
index 1957c98ff357..a036109bfbc8 100644
--- a/net-libs/gupnp/Manifest
+++ b/net-libs/gupnp/Manifest
@@ -1,3 +1,2 @@
DIST gupnp-1.4.3.tar.xz 154812 BLAKE2B b41a8805853061399412f5eb7267e9913adb3054ebf8a3bd78f6df4c1607d4a944654f3bc6e154fefa98f1289a80055d0feb0168801d83a1ad59c25f5fcac784 SHA512 1963ce917458168c8bc5d669ee30a4071d83d3768ce1be8cbbd81c767853ca01950623a88628a0b1e403d1cce1f0bbc9df80acf4b75f91bfc0403e0d0e6bcedb
-DIST gupnp-1.6.3.tar.xz 2216496 BLAKE2B 635aafa78f8cb7b9542eab14545864a93d5fe01296444397ddb1d1868d51c9bb8013e17e659dce550581f7ae9cbc31a74fb30563d1961b341c3f672390d08f6a SHA512 423605e15dafb1f3789910289604912212a04595bad174654cce5b7717ab0d307ad7e021fc8f0ce59fb090d285fbcf633de63dc40c5f6cebad6a28553a5d6f17
DIST gupnp-1.6.5.tar.xz 163380 BLAKE2B 92c29db56a0fe9596bb0c523fc31be0783d6cf95b1926868a6e8a5e95ed9e28aa04ddf0f6740681995244c5020cfddb9b8ab8aeaf2baeb622185aa3a76a2986e SHA512 c34def9accb0984e17298156b7d325eebd89cc0f0f9568740b15f20a05ce523c8f97b5cc98cee1245c0bdea0a5b4fe97878b810c3325239d87d7d577cd0742a5
diff --git a/net-libs/gupnp/gupnp-1.6.3.ebuild b/net-libs/gupnp/gupnp-1.6.3.ebuild
deleted file mode 100644
index c9e04a37efcb..000000000000
--- a/net-libs/gupnp/gupnp-1.6.3.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..11} )
-PYTHON_REQ_USE="xml(+)"
-
-inherit gnome.org meson-multilib python-single-r1 vala xdg
-
-DESCRIPTION="An object-oriented framework for creating UPnP devs and control points"
-HOMEPAGE="https://wiki.gnome.org/Projects/GUPnP https://gitlab.gnome.org/GNOME/gupnp"
-
-LICENSE="LGPL-2+ GPL-2+" # gupnp-binding-tool is GPL-2+
-SLOT="1.6/1.6-0" # <API version>-<soname>
-KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ~ia64 ~loong ~ppc ppc64 ~riscv ~sparc x86"
-
-IUSE="connman gtk-doc +introspection networkmanager +vala"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}
- ?? ( connman networkmanager )
- gtk-doc? ( introspection )
-"
-
-# prefix: uuid dependency can be adapted to non-linux platforms
-RDEPEND="${PYTHON_DEPS}
- >=dev-libs/glib-2.70:2[${MULTILIB_USEDEP}]
- >=net-libs/gssdp-1.6.2:1.6=[introspection?,${MULTILIB_USEDEP}]
- >=dev-libs/libxml2-2.9.1-r4[${MULTILIB_USEDEP}]
- >=net-libs/libsoup-2.99.0:3.0[introspection?,${MULTILIB_USEDEP}]
- >=sys-apps/util-linux-2.24.1-r3[${MULTILIB_USEDEP}]
- introspection? ( >=dev-libs/gobject-introspection-1.54:= )
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- dev-util/glib-utils
- gtk-doc? ( >=dev-util/gi-docgen-2021.1 )
- dev-libs/libxslt
- app-text/docbook-xsl-stylesheets
- virtual/pkgconfig
- !connman? ( !networkmanager? ( kernel_linux? ( sys-kernel/linux-headers ) ) )
- vala? ( $(vala_depend)
- >=net-libs/gssdp-1.5.2:1.6[vala]
- net-libs/libsoup:3.0[vala]
- )
-"
-
-src_prepare() {
- default
- use vala && vala_setup
-
- # This makes sense for upstream but not for us downstream, bug #906124.
- sed -i -e '/-Werror=deprecated-declarations/d' meson.build || die
-}
-
-multilib_src_configure() {
- local backend=system
- use kernel_linux && backend=linux
- use connman && backend=connman
- use networkmanager && backend=network-manager
-
- local emesonargs=(
- -Dcontext_manager=${backend}
- $(meson_native_use_bool introspection)
- $(meson_native_use_bool vala vapi)
- $(meson_native_use_bool gtk-doc gtk_doc)
- -Dexamples=false
- )
- meson_src_configure
-}
-
-multilib_src_install_all() {
- python_fix_shebang "${ED}"/usr/bin/gupnp-binding-tool-1.6
- if use gtk-doc ; then
- mkdir "${ED}"/usr/share/gtk-doc || die
- mv "${ED}"/usr/share/{doc,gtk-doc}/gupnp-1.6 || die
- fi
-}