summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-irc/unrealircd
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-irc/unrealircd')
-rw-r--r--net-irc/unrealircd/Manifest1
-rw-r--r--net-irc/unrealircd/files/unrealircd.confd-r132
-rw-r--r--net-irc/unrealircd/files/unrealircd.initd44
-rw-r--r--net-irc/unrealircd/metadata.xml25
-rw-r--r--net-irc/unrealircd/unrealircd-3.2.10.4.ebuild213
5 files changed, 315 insertions, 0 deletions
diff --git a/net-irc/unrealircd/Manifest b/net-irc/unrealircd/Manifest
new file mode 100644
index 000000000000..36f258fbc672
--- /dev/null
+++ b/net-irc/unrealircd/Manifest
@@ -0,0 +1 @@
+DIST Unreal3.2.10.4.tar.gz 3540227 SHA256 5041b67745d0bd2072cf9b74c07853085b8b5b07330263f0986bdc56eda98aa8 SHA512 eeecefe79cadf3efa1b9379d4b675c0b86a2dd91e703f9e4b3998331f56b923d3719c67482f464f9b1699f801e0a83d677ada642ea7037c52a9d5db63abe6a5c WHIRLPOOL e52949bb6b20076d382825a841c8f643f1f64ac265d7f58898a6417c4853b569b8f561d5dccf198b4f006725e4be0636a2edb580023e8db62dadab8397d11975
diff --git a/net-irc/unrealircd/files/unrealircd.confd-r1 b/net-irc/unrealircd/files/unrealircd.confd-r1
new file mode 100644
index 000000000000..59b8f426cd24
--- /dev/null
+++ b/net-irc/unrealircd/files/unrealircd.confd-r1
@@ -0,0 +1,32 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# user to run unrealircd as
+UNREALIRCD_USER="unrealircd"
+
+# Which configuration file to load instead of unrealircd.conf. If you
+# want to run multiple instances of unrealircd, you must edit
+# files::pidfile to match UNREALIRCD_PIDFILE. You should also ensure
+# that files::tunefile is different for each unrealircd instance. See
+# http://unrealircd.org/docs.php#filesblock.
+#
+# To support multiple instances of unrealircd, you may create symlinks
+# in /etc/init.d pointing to /etc/init.d/unrealircd. It is recommended
+# that the scheme unrealircd.${instance_name} be used. For each
+# instance, you may make a copy of this file with the appropriate name
+# to override default options specific to that instance.
+UNREALIRCD_CONF="/etc/unrealircd/${SVCNAME}.conf"
+
+# The path where unrealircd is configured to create its pidfile.
+UNREALIRCD_PIDFILE="/var/run/unrealircd/${SVCNAME#unreal}.pid"
+
+# extra options to pass to unrealircd ...
+# You should not specify the -f option here; use
+# UNREALIRCD_CONF instead.
+#
+# [-h servername]
+# [-p portnumber]
+# [-x loglevel]
+# [-t] (to enable debug output)
+UNREALIRCD_OPTS=""
diff --git a/net-irc/unrealircd/files/unrealircd.initd b/net-irc/unrealircd/files/unrealircd.initd
new file mode 100644
index 000000000000..6d837ec0f2ac
--- /dev/null
+++ b/net-irc/unrealircd/files/unrealircd.initd
@@ -0,0 +1,44 @@
+#!/sbin/runscript
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+extra_started_commands="reload"
+
+# Defaults
+: ${UNREALIRCD_USER:=unrealircd}
+: ${UNREALIRCD_CONF:=/etc/unrealircd/${SVCNAME}.conf}
+: ${UNREALIRCD_PIDFILE:=/var/run/unrealircd/${SVCNAME#unreal}.pid}
+
+depend() {
+ use dns net
+ provide ircd
+}
+
+start() {
+ UNREALIRCD_PIDFILEDIR=${UNREALIRCD_PIDFILE%/*}
+ if ! [ -d "${UNREALIRCD_PIDFILEDIR}" ]; then
+ ebegin "Creating ${UNREALIRCD_PIDFILEDIR} for ${SVCNAME}"
+ mkdir "${UNREALIRCD_PIDFILEDIR}" \
+ && chown :unrealircd "${UNREALIRCD_PIDFILEDIR}" \
+ && chmod 770 "${UNREALIRCD_PIDFILEDIR}"
+ eend $?
+ fi
+
+ ebegin "Starting ${SVCNAME}"
+ start-stop-daemon --start --quiet --exec /usr/bin/unrealircd \
+ --user ${UNREALIRCD_USER} --pidfile "${UNREALIRCD_PIDFILE}" -- -f "${UNREALIRCD_CONF}" ${UNREALIRCD_OPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping ${SVCNAME}"
+ start-stop-daemon --stop --quiet --pidfile "${UNREALIRCD_PIDFILE}"
+ eend $?
+}
+
+reload() {
+ ebegin "Reloading ${SVCNAME}"
+ start-stop-daemon --signal HUP --quiet --pidfile "${UNREALIRCD_PIDFILE}"
+ eend $?
+}
diff --git a/net-irc/unrealircd/metadata.xml b/net-irc/unrealircd/metadata.xml
new file mode 100644
index 000000000000..7a298531b3cb
--- /dev/null
+++ b/net-irc/unrealircd/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-irc</herd>
+ <maintainer>
+ <email>binki@gentoo.org</email>
+ <name>Nathan Phillip Brink</name>
+ </maintainer>
+ <maintainer>
+ <email>jdhore@gentoo.org</email>
+ <name>Jeff Horelick</name>
+ </maintainer>
+ <use>
+ <flag name='class-nofakelag'>Enable an unsupported class::options flag called “nofakelag” allowing you to grant fakelag exemption to normal user (instead of just opers).</flag>
+ <flag name='extban-stacking'>Enable extended channel bans (such as +b ~c: and +b ~n:) to contain other extended bans instead of just hostmasks.</flag>
+ <flag name='prefixaq'>Enable chanadmin and chanowner prefixes</flag>
+ <flag name='showlistmodes'>Support displaying channel modes during compilation</flag>
+ <flag name='operoverride-verify'>Enable requiring opers to invite themselves to +s/+p channels</flag>
+ <flag name='operoverride'>Enable OperOverride extension</flag>
+ <flag name='usermod'>Enable /set* and /chg* commands</flag>
+ <flag name='showlistmodes'>Support displaying channel modes in /list</flag>
+ <flag name='shunnotices'>Enable notifying a user when un-shunned</flag>
+ <flag name='topicisnuhost'>Enable displaying nick!user@host as topic setter</flag>
+ </use>
+</pkgmetadata>
diff --git a/net-irc/unrealircd/unrealircd-3.2.10.4.ebuild b/net-irc/unrealircd/unrealircd-3.2.10.4.ebuild
new file mode 100644
index 000000000000..621ae76ebfe3
--- /dev/null
+++ b/net-irc/unrealircd/unrealircd-3.2.10.4.ebuild
@@ -0,0 +1,213 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils ssl-cert versionator multilib user
+
+MY_P=Unreal${PV/_/-}
+
+DESCRIPTION="An advanced Internet Relay Chat daemon"
+HOMEPAGE="http://www.unrealircd.com/"
+SRC_URI="http://www.unrealircd.com/downloads/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="amd64 ppc x86 ~x86-fbsd ~amd64-linux"
+IUSE="class-nofakelag curl ipv6 +extban-stacking +operoverride operoverride-verify +prefixaq
+ showlistmodes shunnotices ssl topicisnuhost +usermod zlib"
+
+RDEPEND="ssl? ( dev-libs/openssl )
+ zlib? ( sys-libs/zlib )
+ curl? ( net-misc/curl[adns] )
+ dev-libs/tre
+ >=net-dns/c-ares-1.7"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4
+ virtual/pkgconfig"
+
+S=${WORKDIR}/Unreal${PV}
+
+pkg_setup() {
+ enewuser unrealircd
+}
+
+src_prepare() {
+ # QA check against bundled pkgs
+ rm extras/*.gz || die
+
+ sed -i \
+ -e "s:ircd\.pid:${EPREFIX}/var/run/unrealircd/ircd.pid:" \
+ -e "s:ircd\.log:${EPREFIX}/var/log/unrealircd/ircd.log:" \
+ -e "s:debug\.log:${EPREFIX}/var/log/unrealircd/debug.log:" \
+ -e "s:ircd\.tune:${EPREFIX}/var/lib/unrealircd/ircd.tune:" \
+ include/config.h \
+ || die "sed failed"
+
+ if use class-nofakelag; then
+ sed -i -e 's:#undef\( FAKELAG_CONFIGURABLE\):#define\1:' include/config.h || die
+ fi
+}
+
+src_configure() {
+ econf \
+ --with-listen=5 \
+ --with-dpath="${EPREFIX}"/etc/unrealircd \
+ --with-spath="${EPREFIX}"/usr/bin/unrealircd \
+ --with-nick-history=2000 \
+ --with-sendq=3000000 \
+ --with-bufferpool=18 \
+ --with-permissions=0600 \
+ --with-fd-setsize=1024 \
+ --with-system-cares \
+ --with-system-tre \
+ --enable-dynamic-linking \
+ $(use_enable curl libcurl "${EPREFIX}"/usr) \
+ $(use_enable ipv6 inet6) \
+ $(use_enable prefixaq) \
+ $(use_enable ssl ssl "${EPREFIX}"/usr) \
+ $(use_enable zlib ziplinks "${EPREFIX}"/usr) \
+ $(use_with showlistmodes) \
+ $(use_with topicisnuhost) \
+ $(use_with shunnotices) \
+ $(use_with !operoverride no-operoverride) \
+ $(use_with operoverride-verify) \
+ $(use_with !usermod disableusermod) \
+ $(use_with !extban-stacking disable-extendedban-stacking)
+}
+
+src_install() {
+ keepdir /var/{lib,log}/unrealircd
+
+ newbin src/ircd unrealircd
+
+ exeinto /usr/$(get_libdir)/unrealircd/modules
+ doexe src/modules/*.so
+
+ dodir /etc/unrealircd
+ dosym /var/lib/unrealircd /etc/unrealircd/tmp
+
+ insinto /etc/unrealircd
+ doins {badwords.*,help,spamfilter,dccallow}.conf
+ newins doc/example.conf unrealircd.conf
+
+ insinto /etc/unrealircd/aliases
+ doins aliases/*.conf
+
+ local so_suffix=so
+ [[ ${CHOST} == -*mingw* ]] && so_suffix=dll
+ sed -i \
+ -e s:src/modules:"${EPREFIX}"/usr/$(get_libdir)/unrealircd/modules: \
+ -e '/loadmodule.*\.'${so_suffix}'/s;^//;;' \
+ -e s:ircd\\.log:"${EPREFIX}"/var/log/unrealircd/ircd.log: \
+ "${ED}"/etc/unrealircd/unrealircd.conf \
+ || die
+
+ dodoc \
+ Changes Donation Unreal.nfo \
+ ircdcron/{ircd.cron,ircdchk} \
+ || die "dodoc failed"
+ dohtml doc/*.html
+
+ newinitd "${FILESDIR}"/unrealircd.initd unrealircd
+ newconfd "${FILESDIR}"/unrealircd.confd-r1 unrealircd
+
+ # config should be read-only
+ fperms -R 0640 /etc/unrealircd{,/aliases}
+ fperms 0750 /etc/unrealircd{,/aliases}
+ # state is editable but not owned by unrealircd directly
+ fperms 0770 /var/{lib,log}/unrealircd
+ fowners -R root:unrealircd /{etc,var/{lib,log}}/unrealircd
+}
+
+pkg_preinst() {
+ # Must pre-create directories; otherwise their permissions are lost
+ # on installation.
+
+ # Usage: _unrealircd_dir_permissions <user> <group> <mode> <dir>[, <dir>…]
+ #
+ # Ensure that directories are created with the correct permissions
+ # before portage tries to merge them to the filesystem because,
+ # otherwise, those directories are installed world-readable.
+ #
+ # If this is a first-time install, create those directories with
+ # correct permissions before installing. Otherwise, update
+ # permissions—but only if we are replacing an unrealircd ebuild at
+ # least as old as net-irc/unrealircd-3.2.10. Portage handles normal
+ # file permissions correctly, so no need for recursive
+ # chmoding/chowning.
+ _unrealircd_dir_permissions() {
+ local user=${1} group=${2} mode=${3} dir v
+ shift 3
+ while dir=${1} && shift; do
+ if [[ ! -d "${EROOT}${dir}" ]]; then
+ ebegin "Creating ${EROOT}${dir} with correct permissions"
+ install -d -m "${mode}" -o "${user}" -g "${group}" "${EROOT}${dir}" || die
+ eend ${?}
+ elif ! [[ ${REPLACING_VERSIONS} ]] || for v in ${REPLACING_VERSIONS}; do
+ # If 3.2.10 ≤ ${REPLACING_VERSIONS}, then we update
+ # existing permissions.
+ version_is_at_least "${v}" 3.2.10 && break
+ done; then
+ ebegin "Correcting permissions of ${EROOT}${dir} left by ${CATEGORY}/${PN}-${v}"
+ chmod "${mode}" "${EROOT}${dir}" \
+ && chown ${user}:${group} "${EROOT}${dir}" \
+ || die "Unable to correct permissions of ${EROOT}${dir}"
+ eend ${?}
+ fi
+ done
+ }
+
+ # unrealircd only needs to be able to read files in /etc/unrealircd.
+ _unrealircd_dir_permissions root unrealircd 0750 etc/unrealircd{,/aliases}
+
+ # unrealircd needs to be able to create files in /var/lib/unrealircd
+ # and /var/log/unrealircd.
+ _unrealircd_dir_permissions root unrealircd 0770 var/{lib,log}/unrealircd
+}
+
+pkg_postinst() {
+ # Move docert call from scr_install() to install_cert in pkg_postinst for
+ # bug #201682
+ if use ssl ; then
+ if [[ ! -f "${EROOT}"/etc/unrealircd/server.cert.key ]]; then
+ install_cert /etc/unrealircd/server.cert
+ chown unrealircd "${EROOT}"/etc/unrealircd/server.cert.*
+ chmod 0640 "${EROOT}"/etc/unrealircd/server.cert.*
+ ln -snf server.cert.key "${EROOT}"/etc/unrealircd/server.key.pem
+ fi
+ fi
+
+ local unrealircd_conf="${EROOT}"/etc/unrealircd/unrealircd.conf
+ # Fix up the default cloak keys.
+ if grep -qe '"and another one";$' "${unrealircd_conf}" && grep -qe '"aoAr1HnR6gl3sJ7hVz4Zb7x4YwpW";$' "${unrealircd_conf}"; then
+ ebegin "Generating cloak-keys"
+ local keys=(
+ $(unrealircd -k 2>&1 | tail -n 3)
+ )
+ [[ -n ${keys[0]} || -n ${keys[1]} || -n ${keys[2]} ]]
+ eend $?
+
+ ebegin "Substituting cloak-keys into ${unrealircd_conf}"
+ sed -i \
+ -e '/cloak-keys/ {
+n
+s/"aoAr1HnR6gl3sJ7hVz4Zb7x4YwpW";/"'"${keys[0]}"'";/
+n
+s/"and another one";/"'"${keys[1]}"'";/
+n
+s/"and another one";/"'"${keys[2]}"'";/
+}' \
+ "${unrealircd_conf}"
+ eend $?
+ fi
+
+ elog "UnrealIRCd will not run until you've set up /etc/unrealircd/unrealircd.conf"
+ elog
+ elog "You can find example cron scripts here:"
+ elog " /usr/share/doc/${PF}/ircd.cron.gz"
+ elog " /usr/share/doc/${PF}/ircdchk.gz"
+ elog
+ elog "You can also use /etc/init.d/unrealircd to start at boot"
+}