summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-01-08 10:29:39 +0100
committerJeroen Roovers <jer@gentoo.org>2020-01-08 10:30:26 +0100
commit948541e4b4ee308c4d3380b976f18e1de7ec74ba (patch)
treea13ead51a1760bfc0e0de89ba895172d08c2370e /net-analyzer/ipband
parentdev-util/ccache: stable 3.7.6 for ppc64, bug #704890 (diff)
downloadgentoo-948541e4b4ee308c4d3380b976f18e1de7ec74ba.tar.gz
gentoo-948541e4b4ee308c4d3380b976f18e1de7ec74ba.tar.bz2
gentoo-948541e4b4ee308c4d3380b976f18e1de7ec74ba.zip
net-analyzer/ipband: EAPI=7
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-analyzer/ipband')
-rw-r--r--net-analyzer/ipband/ipband-0.8.1-r2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-analyzer/ipband/ipband-0.8.1-r2.ebuild b/net-analyzer/ipband/ipband-0.8.1-r2.ebuild
new file mode 100644
index 000000000000..6d65e278291e
--- /dev/null
+++ b/net-analyzer/ipband/ipband-0.8.1-r2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="A pcap based IP traffic and bandwidth monitor"
+HOMEPAGE="http://ipband.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ >=net-libs/libpcap-0.4
+"
+RDEPEND="
+ ${DEPEND}
+"
+PATCHES=(
+ "${FILESDIR}"/${P}-gentoo.patch
+ "${FILESDIR}"/${P}-postfix.patch
+)
+
+src_configure() {
+ tc-export CC
+ default
+}
+
+src_install() {
+ dobin ipband
+ doman ipband.8
+ dodoc CHANGELOG README
+
+ newinitd "${FILESDIR}"/ipband-init ipband
+
+ insinto /etc/
+ newins ipband.sample.conf ipband.conf
+}