summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIlya Tumaykin <itumaykin@gmail.com>2018-07-23 18:46:05 +0300
committerMichał Górny <mgorny@gentoo.org>2018-07-28 10:53:30 +0200
commite31d80a419120a0af70f62b1ee7cbf6b75a38213 (patch)
tree1ce943f97035531a9a7aa85a7d222e6f5b280830 /media-video/mpv
parentmedia-video/mpv: drop libav support in 9999 (diff)
downloadgentoo-e31d80a419120a0af70f62b1ee7cbf6b75a38213.tar.gz
gentoo-e31d80a419120a0af70f62b1ee7cbf6b75a38213.tar.bz2
gentoo-e31d80a419120a0af70f62b1ee7cbf6b75a38213.zip
media-video/mpv: rebase latest ffmpeg patch on top of 0.29.0
Package-Manager: Portage-2.3.43, Repoman-2.3.10
Diffstat (limited to 'media-video/mpv')
-rw-r--r--media-video/mpv/files/mpv-0.29.0-make-ffmpeg-version-check-non-fatal.patch (renamed from media-video/mpv/files/mpv-9999-make-ffmpeg-version-check-non-fatal.patch)6
-rw-r--r--media-video/mpv/mpv-9999.ebuild2
2 files changed, 4 insertions, 4 deletions
diff --git a/media-video/mpv/files/mpv-9999-make-ffmpeg-version-check-non-fatal.patch b/media-video/mpv/files/mpv-0.29.0-make-ffmpeg-version-check-non-fatal.patch
index 1594617fba9a..1a4975a4e305 100644
--- a/media-video/mpv/files/mpv-9999-make-ffmpeg-version-check-non-fatal.patch
+++ b/media-video/mpv/files/mpv-0.29.0-make-ffmpeg-version-check-non-fatal.patch
@@ -3,10 +3,10 @@ player: make ffmpeg/libav version check non-fatal
We already enforce mpv rebuilds when ffmpeg/libav SONAME changes.
diff --git a/player/main.c b/player/main.c
-index 5a3fe4c1b7..8cfbb09c56 100644
+index f56191a297..4e51aebd66 100644
--- a/player/main.c
+++ b/player/main.c
-@@ -429,13 +429,12 @@ int mp_initialize(struct MPContext *mpctx, char **options)
+@@ -387,13 +387,12 @@ int mp_initialize(struct MPContext *mpctx, char **options)
// Distro maintainers who patch this out should be aware that mpv
// intentionally ignores ABI in some places where it's not possible to
// get by without violating it.
@@ -25,4 +25,4 @@ index 5a3fe4c1b7..8cfbb09c56 100644
+ "Please rebuild mpv in case of any problems.\n");
}
- if (!mpctx->playlist->first && !opts->player_idle_mode)
+ if (!mpctx->playlist->first && !opts->player_idle_mode) {
diff --git a/media-video/mpv/mpv-9999.ebuild b/media-video/mpv/mpv-9999.ebuild
index eae5391d95d1..ba554e7956f9 100644
--- a/media-video/mpv/mpv-9999.ebuild
+++ b/media-video/mpv/mpv-9999.ebuild
@@ -137,7 +137,7 @@ RDEPEND="${COMMON_DEPEND}
"
PATCHES=(
- "${FILESDIR}/${P}-make-ffmpeg-version-check-non-fatal.patch"
+ "${FILESDIR}/${PN}-0.29.0-make-ffmpeg-version-check-non-fatal.patch"
)
src_prepare() {