summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-video/griffith
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-video/griffith')
-rw-r--r--media-video/griffith/Manifest2
-rw-r--r--media-video/griffith/files/0.10-fix_lib_path.patch13
-rw-r--r--media-video/griffith/files/griffith-0.12.1-sqlalchemy-0.7.patch39
-rw-r--r--media-video/griffith/griffith-0.13-r1.ebuild76
-rw-r--r--media-video/griffith/griffith-0.13.ebuild78
-rw-r--r--media-video/griffith/metadata.xml12
6 files changed, 220 insertions, 0 deletions
diff --git a/media-video/griffith/Manifest b/media-video/griffith/Manifest
new file mode 100644
index 000000000000..6e073f282a5d
--- /dev/null
+++ b/media-video/griffith/Manifest
@@ -0,0 +1,2 @@
+DIST griffith-0.13.tar.gz 1565903 SHA256 60576d33aa855ab45d654288d7bf2ead8accecb72fd2acbc373656294ab8f242 SHA512 dc8117b1a89253a87eb303c5229e6cdffde26b52de9ac4a3409dcc3f6dca64105f13a98cace225a932aefb2d620e828eea66bae57f40328b7ee3c06a944f0bed WHIRLPOOL 9f46b25e345f5e3b6823c7a5faff173d6d63921b812f7b6de7c0f7c691f881f4252560baae5f4a8660b2f0e94370dcb28e60264d1c261e0b64f03c8d710bcdf1
+DIST griffith-extra-artwork-0.9.4.tar.gz 124008 SHA256 96bc01a05ad54aad9fabcf411809c46c78b990fc7656ea004cebdfd8ea9894fd SHA512 09e912b4511c5c4a7b501d9a8f98223d20e58574e667cdb759e66f743cce14b45cce8bf0f9502ff2aacfc09e7a7b37966a887205a74a6e028b832703a65a2734 WHIRLPOOL 166dcf1bee1ef07452d00b7c87f487fea5417a0b6d156afd127f8723c6d2c44d2a0e4a5719ab5f85c662b7bbc30f0fadd8ba7873908cdf7ae85167b07a518e6b
diff --git a/media-video/griffith/files/0.10-fix_lib_path.patch b/media-video/griffith/files/0.10-fix_lib_path.patch
new file mode 100644
index 000000000000..952448f0f013
--- /dev/null
+++ b/media-video/griffith/files/0.10-fix_lib_path.patch
@@ -0,0 +1,13 @@
+Index: lib/initialize.py
+===================================================================
+--- lib.orig/initialize.py
++++ lib/initialize.py
+@@ -73,7 +73,7 @@ def locations(self, home_dir):
+ os.environ['LANG'] = lang
+
+ elif os.name == 'posix':
+- locations['share'] = os.path.abspath(os.path.join(locations['lib'], '..'))
++ locations['share'] = os.path.abspath(os.path.join(locations['lib'], '../../share/griffith/'))
+ locations['glade'] = os.path.join(locations['share'], 'glade')
+ locations['i18n'] = os.path.abspath(os.path.join(locations['share'], '..', 'locale'))
+ if not os.path.isdir(locations['i18n']):
diff --git a/media-video/griffith/files/griffith-0.12.1-sqlalchemy-0.7.patch b/media-video/griffith/files/griffith-0.12.1-sqlalchemy-0.7.patch
new file mode 100644
index 000000000000..d3e6a5b6e182
--- /dev/null
+++ b/media-video/griffith/files/griffith-0.12.1-sqlalchemy-0.7.patch
@@ -0,0 +1,39 @@
+Index: griffith-0.12.1/lib/add.py
+===================================================================
+--- griffith-0.12.1.orig/lib/add.py
++++ griffith-0.12.1/lib/add.py
+@@ -26,7 +26,7 @@ import logging
+ import os
+
+ import gtk
+-from sqlalchemy.exceptions import IntegrityError
++from sqlalchemy.exc import IntegrityError
+
+ import quick_filter
+ import db
+Index: griffith-0.12.1/lib/db/tables.py
+===================================================================
+--- griffith-0.12.1.orig/lib/db/tables.py
++++ griffith-0.12.1/lib/db/tables.py
+@@ -64,7 +64,7 @@ movies = Table('movies', metadata,
+ Column('poster_md5', ForeignKey(posters.c.md5sum)),
+ Column('loaned', Boolean, nullable=False, default=False),
+ Column('seen', Boolean, nullable=False, default=False),
+- Column('rating', SmallInteger(2)),
++ Column('rating', SmallInteger),
+ Column('color', SmallInteger),
+ Column('cond', SmallInteger), # MySQL will not accept name "condition"
+ Column('layers', SmallInteger),
+Index: griffith-0.12.1/lib/sql.py
+===================================================================
+--- griffith-0.12.1.orig/lib/sql.py
++++ griffith-0.12.1/lib/sql.py
+@@ -29,7 +29,7 @@ import logging
+ import os.path
+
+ from sqlalchemy import create_engine, or_, and_, not_, exists, asc, desc
+-from sqlalchemy.exceptions import OperationalError
++from sqlalchemy.exc import OperationalError
+ from sqlalchemy.orm import sessionmaker, scoped_session
+ from sqlalchemy.sql.expression import Update, Delete
+
diff --git a/media-video/griffith/griffith-0.13-r1.ebuild b/media-video/griffith/griffith-0.13-r1.ebuild
new file mode 100644
index 000000000000..0b6ea928e6ab
--- /dev/null
+++ b/media-video/griffith/griffith-0.13-r1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE='sqlite'
+
+inherit versionator python-single-r1 multilib
+
+ARTWORK_PV="0.9.4"
+
+DESCRIPTION="Movie collection manager"
+HOMEPAGE="http://www.griffith.cc/"
+SRC_URI="http://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.gz
+ http://dev.gentoo.org/~hwoarang/distfiles/${PN}-extra-artwork-${ARTWORK_PV}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE="doc"
+
+RDEPEND="virtual/python-imaging
+ gnome-base/libglade
+ dev-python/pyxml[${PYTHON_USEDEP}]
+ >=dev-python/pygtk-2.6.1:2[${PYTHON_USEDEP}]
+ dev-python/pygobject:2[${PYTHON_USEDEP}]
+ >=dev-python/sqlalchemy-0.5.2[${PYTHON_USEDEP}]
+ >=dev-python/reportlab-1.19[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ doc? ( app-text/docbook2X )"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ use doc || { sed -i -e '/docs/d' Makefile || die ; }
+ sed -i \
+ -e 's#/pl/#/pl.UTF-8/#' \
+ "${S}"/docs/pl/Makefile || die "sed failed"
+
+ sed -i \
+ -e 's/ISO-8859-1/UTF-8/' \
+ "${S}"/lib/gconsole.py || die "sed failed"
+
+ epatch "${FILESDIR}/0.10-fix_lib_path.patch"
+}
+
+src_compile() {
+ # Nothing to compile and default `emake` spews an error message
+ true
+}
+
+src_install() {
+ use doc || { sed -i -e '/docs/d' Makefile || die ; }
+
+ emake \
+ LIBDIR="${D}/usr/$(get_libdir)/griffith" \
+ DESTDIR="${D}" DOC2MAN=docbook2man.pl install
+ dodoc AUTHORS ChangeLog README THANKS TODO NEWS TRANSLATORS
+
+ cd "${WORKDIR}/${PN}-extra-artwork-${ARTWORK_PV}/"
+ emake DESTDIR="${D}" install
+ # This carries over from -0.13 but appears to have no effect.
+ python_optimize "${D}"usr/share/${PN}
+}
+
+pkg_postinst() {
+ einfo
+ einfo "${PN} can make use of the following optional dependencies"
+ einfo "dev-python/chardet: CSV file encoding detections"
+ einfo "dev-python/mysql-python: Python interface for MySQL connectivity"
+ einfo ">=dev-python/psycopg-2.4: Python interface for PostgreSQL connectivity"
+ einfo
+}
diff --git a/media-video/griffith/griffith-0.13.ebuild b/media-video/griffith/griffith-0.13.ebuild
new file mode 100644
index 000000000000..f744bd39661d
--- /dev/null
+++ b/media-video/griffith/griffith-0.13.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+PYTHON_DEPEND="2"
+PYTHON_USE_WITH=sqlite
+
+inherit eutils versionator python multilib
+
+ARTWORK_PV="0.9.4"
+
+DESCRIPTION="Movie collection manager"
+HOMEPAGE="http://www.griffith.cc/"
+SRC_URI="http://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.gz
+ http://dev.gentoo.org/~hwoarang/distfiles/${PN}-extra-artwork-${ARTWORK_PV}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86 ~x86-fbsd"
+IUSE="doc"
+
+RDEPEND="virtual/python-imaging
+ gnome-base/libglade
+ dev-python/pyxml
+ >=dev-python/pygtk-2.6.1:2
+ dev-python/pygobject:2
+ >=dev-python/sqlalchemy-0.5.2
+ >=dev-python/reportlab-1.19"
+DEPEND="${RDEPEND}
+ doc? ( app-text/docbook2X )"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ sed -i \
+ -e 's#/pl/#/pl.UTF-8/#' \
+ "${S}"/docs/pl/Makefile || die "sed failed"
+
+ sed -i \
+ -e 's/ISO-8859-1/UTF-8/' \
+ "${S}"/lib/gconsole.py || die "sed failed"
+ epatch "${FILESDIR}/0.10-fix_lib_path.patch"
+}
+
+src_compile() {
+ # Nothing to compile and default `emake` spews an error message
+ true
+}
+
+src_install() {
+ use doc || { sed -i -e '/docs/d' Makefile || die ; }
+
+ emake \
+ LIBDIR="${D}/usr/$(get_libdir)/griffith" \
+ DESTDIR="${D}" DOC2MAN=docbook2man.pl install
+ dodoc AUTHORS ChangeLog README THANKS TODO NEWS TRANSLATORS
+
+ cd "${WORKDIR}/${PN}-extra-artwork-${ARTWORK_PV}/"
+ emake DESTDIR="${D}" install
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/$(get_libdir)/${PN}
+ einfo
+ einfo "${PN} can make use of the following optional dependencies"
+ einfo "dev-python/chardet: CSV file encoding detections"
+ einfo "dev-python/mysql-python: Python interface for MySQL connectivity"
+ einfo ">=dev-python/psycopg-2.4: Python interface for PostgreSQL connectivity"
+ einfo
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/$(get_libdir)/${PN}
+}
diff --git a/media-video/griffith/metadata.xml b/media-video/griffith/metadata.xml
new file mode 100644
index 000000000000..8553c721b731
--- /dev/null
+++ b/media-video/griffith/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>video</herd>
+ <maintainer>
+ <email>hwoarang@gentoo.org</email>
+ <name>Markos Chandras</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="launchpad">griffith</remote-id>
+ </upstream>
+</pkgmetadata>