summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-09-16 10:01:48 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-09-16 10:03:12 +0200
commitbed97129fd228faa30a3e9d51b07062daed6ceb3 (patch)
tree071da27baec62174f5e39a7798bd568a3af43423 /media-sound
parentdev-util/meson: sh/m68k stable wrt bug #656920 (diff)
downloadgentoo-bed97129fd228faa30a3e9d51b07062daed6ceb3.tar.gz
gentoo-bed97129fd228faa30a3e9d51b07062daed6ceb3.tar.bz2
gentoo-bed97129fd228faa30a3e9d51b07062daed6ceb3.zip
media-sound/karlyriceditor: Fix build with ffmpeg-4
Closes: https://bugs.gentoo.org/665710 Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/karlyriceditor/files/karlyriceditor-2.2-ffmpeg-4.patch34
-rw-r--r--media-sound/karlyriceditor/karlyriceditor-2.2-r1.ebuild8
2 files changed, 39 insertions, 3 deletions
diff --git a/media-sound/karlyriceditor/files/karlyriceditor-2.2-ffmpeg-4.patch b/media-sound/karlyriceditor/files/karlyriceditor-2.2-ffmpeg-4.patch
new file mode 100644
index 000000000000..b7ae9d6e90b4
--- /dev/null
+++ b/media-sound/karlyriceditor/files/karlyriceditor-2.2-ffmpeg-4.patch
@@ -0,0 +1,34 @@
+Description: Fix FTBFS with FFmpeg 4.0
+Author: James Cowgill <jcowgill@debian.org>
+Bug-Debian: https://bugs.debian.org/888377
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+--- a/src/ffmpegvideoencoder.cpp
++++ b/src/ffmpegvideoencoder.cpp
+@@ -345,7 +345,7 @@ av_log_set_level(AV_LOG_VERBOSE);
+
+ // Enable interlacing if needed
+ if ( m_videoformat->flags & VIFO_INTERLACED )
+- videoCodecCtx->flags |= CODEC_FLAG_INTERLACED_DCT;
++ videoCodecCtx->flags |= AV_CODEC_FLAG_INTERLACED_DCT;
+
+ // Enable multithreaded encoding: breaks FLV!
+ //videoCodecCtx->thread_count = 4;
+@@ -373,7 +373,7 @@ av_log_set_level(AV_LOG_VERBOSE);
+
+ // If we have a global header for the format, no need to duplicate the codec info in each keyframe
+ if ( outputFormatCtx->oformat->flags & AVFMT_GLOBALHEADER )
+- videoCodecCtx->flags |= CODEC_FLAG_GLOBAL_HEADER;
++ videoCodecCtx->flags |= AV_CODEC_FLAG_GLOBAL_HEADER;
+
+ // Open the codec
+ if ( ( err = avcodec_open2( videoCodecCtx, videoCodec, 0 )) < 0 )
+@@ -463,7 +463,7 @@ av_log_set_level(AV_LOG_VERBOSE);
+ audioCodecCtx->time_base.den = m_profile->sampleRate;
+
+ if ( outputFormatCtx->oformat->flags & AVFMT_GLOBALHEADER )
+- audioCodecCtx->flags |= CODEC_FLAG_GLOBAL_HEADER;
++ audioCodecCtx->flags |= AV_CODEC_FLAG_GLOBAL_HEADER;
+
+ // Since different audio codecs support different sample formats, look up which one is supported by this specific codec
+ if ( isAudioSampleFormatSupported( audioCodec->sample_fmts, AV_SAMPLE_FMT_FLTP ) )
diff --git a/media-sound/karlyriceditor/karlyriceditor-2.2-r1.ebuild b/media-sound/karlyriceditor/karlyriceditor-2.2-r1.ebuild
index 5c711653cc51..a0b4b5ff69a7 100644
--- a/media-sound/karlyriceditor/karlyriceditor-2.2-r1.ebuild
+++ b/media-sound/karlyriceditor/karlyriceditor-2.2-r1.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit eutils qmake-utils
+inherit desktop qmake-utils
DESCRIPTION="Application to edit and synchronize lyrics with karaoke songs in various formats"
-HOMEPAGE="http://www.ulduzsoft.com/linux/karaoke-lyrics-editor/"
+HOMEPAGE="https://www.ulduzsoft.com/linux/karaoke-lyrics-editor/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-3+"
@@ -27,6 +27,8 @@ DEPEND="${RDEPEND}
virtual/pkgconfig
"
+PATCHES=( "${FILESDIR}/${P}-ffmpeg-4.patch" )
+
src_configure() {
eqmake5 "${PN}.pro"
}