summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKai Krakow <kai@kaishome.de>2024-08-06 20:33:26 +0200
committerJimi Huotari <chiitoo@gentoo.org>2025-01-21 15:54:05 +0200
commitd040231094544ae375da3ac67e700e36b3162750 (patch)
tree8efd5cf43efb4d6f2596dd7e104f3ba1ea75fa92 /media-plugins
parentmedia-plugins/obs-source-record: new package, add 9999 (diff)
downloadgentoo-d040231094544ae375da3ac67e700e36b3162750.tar.gz
gentoo-d040231094544ae375da3ac67e700e36b3162750.tar.bz2
gentoo-d040231094544ae375da3ac67e700e36b3162750.zip
media-plugins/obs-source-record: add 0.4.4
Signed-off-by: Kai Krakow <kai@kaishome.de> Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/obs-source-record/Manifest1
-rw-r--r--media-plugins/obs-source-record/obs-source-record-0.4.4.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/media-plugins/obs-source-record/Manifest b/media-plugins/obs-source-record/Manifest
new file mode 100644
index 000000000000..df9d2cdf16f9
--- /dev/null
+++ b/media-plugins/obs-source-record/Manifest
@@ -0,0 +1 @@
+DIST obs-source-record-0.4.4.tar.gz 67538 BLAKE2B b0f01ef05c08e8b7019b8206318992e38661434e0fd751cca6f0b460684a6983141e00478ffd27c32a6a37ea8276d43248c84758a90427b12a427bbe21f5ce9a SHA512 639fe3443065f4b37105da5a3757f2355fef63f8125bcf08c18e085ef4eab842a92b16a632d691eec0ca1a29c29ad0beee0942bae158ab100b25812a1e60d94d
diff --git a/media-plugins/obs-source-record/obs-source-record-0.4.4.ebuild b/media-plugins/obs-source-record/obs-source-record-0.4.4.ebuild
new file mode 100644
index 000000000000..44d0d8b6ebed
--- /dev/null
+++ b/media-plugins/obs-source-record/obs-source-record-0.4.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Plugin for OBS Studio to make sources available to record via a filter"
+HOMEPAGE="https://github.com/exeldro/obs-source-record"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/exeldro/obs-source-record.git"
+else
+ SRC_URI="https://github.com/exeldro/obs-source-record/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND="
+ >=media-video/obs-studio-30.2.0
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DLIB_OUT_DIR=/lib64/obs-plugins
+ -DLINUX_PORTABLE=OFF
+ )
+
+ cmake_src_configure
+}