summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoerg Bornkessel <hd_brummy@gentoo.org>2020-02-04 19:56:02 +0100
committerJoerg Bornkessel <hd_brummy@gentoo.org>2020-02-04 20:27:37 +0100
commit625d2c380b39c4d86603612acf7bcfb453835f19 (patch)
treebbbf6127d82ff0f9b23eb772d4c1805e80214a8b /media-plugins
parentmedia-plugins/vdr-browse: pmasked removal (diff)
downloadgentoo-625d2c380b39c4d86603612acf7bcfb453835f19.tar.gz
gentoo-625d2c380b39c4d86603612acf7bcfb453835f19.tar.bz2
gentoo-625d2c380b39c4d86603612acf7bcfb453835f19.zip
media-plugins/vdr-osdpip: pmasked removal
bug 704034 Closes: https://bugs.gentoo.org/704034 Signed-off-by: Joerg Bornkessel <hd_brummy@gentoo.org>
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/vdr-osdpip/Manifest1
-rw-r--r--media-plugins/vdr-osdpip/files/vdr-osdpip-0.1.1-ffmpeg-1.patch26
-rw-r--r--media-plugins/vdr-osdpip/files/vdr-osdpip-0.1.2-ffmpeg3.patch55
-rw-r--r--media-plugins/vdr-osdpip/files/vdr-osdpip-libav-9.patch40
-rw-r--r--media-plugins/vdr-osdpip/metadata.xml8
-rw-r--r--media-plugins/vdr-osdpip/vdr-osdpip-0.1.2-r1.ebuild33
6 files changed, 0 insertions, 163 deletions
diff --git a/media-plugins/vdr-osdpip/Manifest b/media-plugins/vdr-osdpip/Manifest
deleted file mode 100644
index 4e2aba462f02..000000000000
--- a/media-plugins/vdr-osdpip/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST vdr-osdpip-0.1.2.tgz 50756 BLAKE2B b43d46c0b2d858e7849d440ffd6faf899a65b1b91eda38b76a8d2a5fec1f717cabda94f3d24253cd8b195cdd2e65793dd74d3775c30b767753bef67771ad8abc SHA512 bc3345497e260d3249e1864a05181939b52a3fea115264af21d0efae10aa4406e9d4e5d348fce967a4fdb1adf2a3c7877b5b2d6840854f55f665800ac080a0eb
diff --git a/media-plugins/vdr-osdpip/files/vdr-osdpip-0.1.1-ffmpeg-1.patch b/media-plugins/vdr-osdpip/files/vdr-osdpip-0.1.1-ffmpeg-1.patch
deleted file mode 100644
index b0304ad5adc0..000000000000
--- a/media-plugins/vdr-osdpip/files/vdr-osdpip-0.1.1-ffmpeg-1.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-Index: osdpip-0.1.1/decoder.h
-===================================================================
---- osdpip-0.1.1.orig/decoder.h
-+++ osdpip-0.1.1/decoder.h
-@@ -34,7 +34,7 @@ extern "C"
- #include <libavcodec/avcodec.h>
- #ifdef USE_SWSCALE
- #include <libswscale/swscale.h>
-- #include <libavcodec/opt.h>
-+ #include <libavutil/opt.h>
- #endif
- #else
- #include <ffmpeg/avcodec.h>
-Index: osdpip-0.1.1/osdpip.c
-===================================================================
---- osdpip-0.1.1.orig/osdpip.c
-+++ osdpip-0.1.1/osdpip.c
-@@ -73,8 +73,6 @@ bool cPluginOsdpip::ProcessArgs(int argc
-
- bool cPluginOsdpip::Initialize(void)
- {
-- // must be called before using avcodec lib
-- avcodec_init();
- // register all the codecs (you can also register only the codec
- // you wish to have smaller code)
- avcodec_register_all();
diff --git a/media-plugins/vdr-osdpip/files/vdr-osdpip-0.1.2-ffmpeg3.patch b/media-plugins/vdr-osdpip/files/vdr-osdpip-0.1.2-ffmpeg3.patch
deleted file mode 100644
index e22428e49f71..000000000000
--- a/media-plugins/vdr-osdpip/files/vdr-osdpip-0.1.2-ffmpeg3.patch
+++ /dev/null
@@ -1,55 +0,0 @@
-https://svnweb.freebsd.org/ports/head/multimedia/vdr-plugin-osdpip/files/patch-ffmpeg3?view=markup
-https://bugs.gentoo.org/show_bug.cgi?id=575100
-
---- decoder.c.orig 2016-06-11 10:45:23.850303000 +0200
-+++ decoder.c 2016-06-11 10:50:57.243181000 +0200
-@@ -28,7 +28,7 @@
-
- int cDecoder::Open()
- {
-- m_Codec = avcodec_find_decoder(CODEC_ID_MPEG2VIDEO);
-+ m_Codec = avcodec_find_decoder(AV_CODEC_ID_MPEG2VIDEO);
- if (!m_Codec)
- {
- printf("codec not found\n");
-@@ -40,8 +40,8 @@
- printf("could not open codec\n");
- return -1;
- }
-- m_PicDecoded = avcodec_alloc_frame();
-- m_PicResample = avcodec_alloc_frame();
-+ m_PicDecoded = av_frame_alloc();
-+ m_PicResample = av_frame_alloc();
- m_BufferResample = new unsigned char[400 * 300 * 4]; // size for RGBA32
- #ifndef USE_SWSCALE
- m_PicConvert = avcodec_alloc_frame();
-@@ -99,7 +99,7 @@
- AVPicture pic_crop;
- struct SwsContext * context;
-
-- av_picture_crop(&pic_crop, (AVPicture *) m_PicDecoded, PIX_FMT_YUV420P, OsdPipSetup.CropTop, OsdPipSetup.CropLeft);
-+ av_picture_crop(&pic_crop, (AVPicture *) m_PicDecoded, AV_PIX_FMT_YUV420P, OsdPipSetup.CropTop, OsdPipSetup.CropLeft);
- #ifdef FF_API_SWS_GETCONTEXT
- if (!(context = sws_alloc_context())) {
- printf("Error initializing scale context.\n");
-@@ -126,9 +126,9 @@
- #else
- context = sws_getContext(m_Context->width - (OsdPipSetup.CropLeft + OsdPipSetup.CropRight),
- m_Context->height - (OsdPipSetup.CropTop + OsdPipSetup.CropBottom),
-- PIX_FMT_YUV420P,
-+ AV_PIX_FMT_YUV420P,
- #ifdef USE_NEW_FFMPEG_HEADERS
-- m_Width, m_Height, ConvertToRGB ? PIX_FMT_RGB32 : PIX_FMT_YUV420P,
-+ m_Width, m_Height, ConvertToRGB ? AV_PIX_FMT_RGB32 : AV_PIX_FMT_YUV420P,
- #else
- m_Width, m_Height, ConvertToRGB ? PIX_FMT_RGBA32 : PIX_FMT_YUV420P,
- #endif
-@@ -140,7 +140,7 @@
- #endif
- avpicture_fill((AVPicture *) m_PicResample, m_BufferResample,
- #ifdef USE_NEW_FFMPEG_HEADERS
-- ConvertToRGB ? PIX_FMT_RGB32 : PIX_FMT_YUV420P,
-+ ConvertToRGB ? AV_PIX_FMT_RGB32 : AV_PIX_FMT_YUV420P,
- #else
- ConvertToRGB ? PIX_FMT_RGBA32 : PIX_FMT_YUV420P,
- #endif
diff --git a/media-plugins/vdr-osdpip/files/vdr-osdpip-libav-9.patch b/media-plugins/vdr-osdpip/files/vdr-osdpip-libav-9.patch
deleted file mode 100644
index d1f531b325ce..000000000000
--- a/media-plugins/vdr-osdpip/files/vdr-osdpip-libav-9.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-diff -urN osdpip-0.1.2.old/decoder.c osdpip-0.1.2/decoder.c
---- osdpip-0.1.2.old/decoder.c 2013-06-17 21:01:31.795476861 +0200
-+++ osdpip-0.1.2/decoder.c 2013-06-17 21:01:57.153475959 +0200
-@@ -34,8 +34,8 @@
- printf("codec not found\n");
- return -1;
- }
-- m_Context = avcodec_alloc_context();
-- if (avcodec_open(m_Context, m_Codec) < 0)
-+ m_Context = avcodec_alloc_context3(m_Codec);
-+ if (avcodec_open2(m_Context, m_Codec, NULL) < 0)
- {
- printf("could not open codec\n");
- return -1;
-@@ -106,17 +106,17 @@
- return -1;
- }
-
-- av_set_int(context, "srcw", m_Context->width - (OsdPipSetup.CropLeft + OsdPipSetup.CropRight));
-- av_set_int(context, "srch", m_Context->height - (OsdPipSetup.CropTop + OsdPipSetup.CropBottom));
-- av_set_int(context, "src_format", PIX_FMT_YUV420P);
-- av_set_int(context, "dstw", m_Width);
-- av_set_int(context, "dsth", m_Height);
-+ av_opt_set_int(context, "srcw", m_Context->width - (OsdPipSetup.CropLeft + OsdPipSetup.CropRight), 0);
-+ av_opt_set_int(context, "srch", m_Context->height - (OsdPipSetup.CropTop + OsdPipSetup.CropBottom), 0);
-+ av_opt_set_int(context, "src_format", PIX_FMT_YUV420P, 0);
-+ av_opt_set_int(context, "dstw", m_Width, 0);
-+ av_opt_set_int(context, "dsth", m_Height, 0);
- #ifdef USE_NEW_FFMPEG_HEADERS
-- av_set_int(context, "dst_format", ConvertToRGB ? PIX_FMT_RGB32 : PIX_FMT_YUV420P);
-+ av_opt_set_int(context, "dst_format", ConvertToRGB ? PIX_FMT_RGB32 : PIX_FMT_YUV420P, 0);
- #else
-- av_set_int(context, "dst_format", ConvertToRGB ? PIX_FMT_RGBA32 : PIX_FMT_YUV420P);
-+ av_opt_set_int(context, "dst_format", ConvertToRGB ? PIX_FMT_RGBA32 : PIX_FMT_YUV420P, 0);
- #endif
-- av_set_int(context, "sws_flags", SWS_LANCZOS);
-+ av_opt_set_int(context, "sws_flags", SWS_LANCZOS, 0);
-
- if (sws_init_context(context, NULL, NULL) < 0) {
- printf("Error initializing conversion context.\n");
diff --git a/media-plugins/vdr-osdpip/metadata.xml b/media-plugins/vdr-osdpip/metadata.xml
deleted file mode 100644
index 27f419c289c3..000000000000
--- a/media-plugins/vdr-osdpip/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="project">
-<email>vdr@gentoo.org</email>
-<name>Gentoo VDR Project</name>
-</maintainer>
-</pkgmetadata>
diff --git a/media-plugins/vdr-osdpip/vdr-osdpip-0.1.2-r1.ebuild b/media-plugins/vdr-osdpip/vdr-osdpip-0.1.2-r1.ebuild
deleted file mode 100644
index ed230cc4089a..000000000000
--- a/media-plugins/vdr-osdpip/vdr-osdpip-0.1.2-r1.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-VERSION="961" # every bump, new version
-
-inherit vdr-plugin-2 flag-o-matic
-
-DESCRIPTION="VDR plugin: Show another channel in the OSD"
-HOMEPAGE="https://projects.vdr-developer.org/projects/plg-osdpip"
-SRC_URI="mirror://vdr-developerorg/${VERSION}/${P}.tgz"
-
-KEYWORDS="amd64 x86"
-SLOT="0"
-LICENSE="GPL-2"
-IUSE=""
-
-DEPEND=">=media-video/vdr-1.7.27
- >=media-libs/libmpeg2-0.5.1
- >=virtual/ffmpeg-0.6.90"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- vdr-plugin-2_src_prepare
-
- # UINT64_C is needed by ffmpeg headers
- append-cxxflags -D__STDC_CONSTANT_MACROS
-
- epatch "${FILESDIR}/${PN}-0.1.1-ffmpeg-1.patch"
- epatch "${FILESDIR}/${PN}-libav-9.patch"
- epatch "${FILESDIR}/${PN}-0.1.2-ffmpeg3.patch"
-}