summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKai Krakow <kai@kaishome.de>2024-07-20 14:56:52 +0200
committerJimi Huotari <chiitoo@gentoo.org>2025-01-21 15:54:06 +0200
commit2fdcc7e195152ae180ff7be9524ba2f7f1ef5347 (patch)
treef6a085c940ad1e4db09d2bb2db8bc5d936201a7f /media-plugins
parentmedia-plugins/obs-vkcapture: new package, add 9999 (diff)
downloadgentoo-2fdcc7e195152ae180ff7be9524ba2f7f1ef5347.tar.gz
gentoo-2fdcc7e195152ae180ff7be9524ba2f7f1ef5347.tar.bz2
gentoo-2fdcc7e195152ae180ff7be9524ba2f7f1ef5347.zip
media-plugins/obs-vkcapture: add 1.5.1
Closes: https://github.com/gentoo/gentoo/pull/37633 Signed-off-by: Kai Krakow <kai@kaishome.de> Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/obs-vkcapture/Manifest1
-rw-r--r--media-plugins/obs-vkcapture/obs-vkcapture-1.5.1.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/media-plugins/obs-vkcapture/Manifest b/media-plugins/obs-vkcapture/Manifest
new file mode 100644
index 000000000000..e050c9a8f41c
--- /dev/null
+++ b/media-plugins/obs-vkcapture/Manifest
@@ -0,0 +1 @@
+DIST obs-vkcapture-1.5.1.tar.gz 60844 BLAKE2B d1e2951ecd0d375940ce8547619507e07be79033f94342babf4a66e51e620c6b0fcc96dd269a6d6a8556d62eda5721502986769c83bd6e38b150c4b77fe411b1 SHA512 9477fd738cdf80e09aad46e58ee5e325aa4f5ae72fbe1cb22918d4910fd997ba2a012ce7ca3b24b1b3734983b94e9b7df391f3deca569a79c90c5d115a1a5eed
diff --git a/media-plugins/obs-vkcapture/obs-vkcapture-1.5.1.ebuild b/media-plugins/obs-vkcapture/obs-vkcapture-1.5.1.ebuild
new file mode 100644
index 000000000000..a5c3c4c2d93d
--- /dev/null
+++ b/media-plugins/obs-vkcapture/obs-vkcapture-1.5.1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib
+
+DESCRIPTION="OBS Linux Vulkan/OpenGL game capture"
+HOMEPAGE="https://github.com/nowrep/obs-vkcapture"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/nowrep/obs-vkcapture.git"
+else
+ SRC_URI="https://github.com/nowrep/obs-vkcapture/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="X wayland"
+
+REQUIRED_USE="|| ( X wayland )"
+
+COMMON_DEPENDS="
+ >=media-video/obs-studio-30.2.0
+ >=media-libs/libglvnd-1.7.0[X=,${MULTILIB_USEDEP}]
+ X? (
+ x11-libs/libxcb:=[${MULTILIB_USEDEP}]
+ )
+ wayland? (
+ >=dev-libs/wayland-1.22.0
+ )
+"
+DEPEND="${COMMON_DEPENDS}
+ >=media-libs/vulkan-loader-1.3[X=,layers,wayland=,${MULTILIB_USEDEP}]
+ dev-util/vulkan-headers
+ wayland? (
+ >=dev-util/wayland-scanner-1.22.0
+ )
+ X? (
+ x11-libs/libX11
+ )
+"
+RDEPEND="${COMMON_DEPENDS}"
+
+QA_SONAME="
+ /usr/lib/libVkLayer_obs_vkcapture.so
+ /usr/lib64/libVkLayer_obs_vkcapture.so
+"
+
+pkg_postinst() {
+ if [[ $(</sys/module/nvidia_drm/parameters/modeset) != Y ]] 2>/dev/null; then
+ elog "This plugin needs nvidia-drm with modeset configured properly"
+ elog "to capture windows. To enable, edit /etc/modprobe.d/nvidia.conf"
+ elog "and uncomment the nvidia-drm options to enable modeset."
+ elog
+ fi
+
+ elog "This plugin can only capture the game window if you add one of the"
+ elog "following launcher options to the game (Steam as an example):"
+ elog " - OBS_VKCAPTURE=1 %command% (recommended, Vulkan)"
+ elog " - obs-gamecapture %command% (generic, OpenGL and Vulkan)"
+ elog
+ elog "HINT: This may currently not work on wayland with"
+ elog "x11-drivers/nvidia-drivers[kernel-open]"
+}
+
+multilib_src_configure() {
+ if ! multilib_is_native_abi; then
+ local mycmakeargs+=(
+ -DBUILD_PLUGIN=OFF
+ )
+ fi
+ cmake_src_configure
+}