summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/sdl2-image
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/sdl2-image')
-rw-r--r--media-libs/sdl2-image/Manifest1
-rw-r--r--media-libs/sdl2-image/metadata.xml8
-rw-r--r--media-libs/sdl2-image/sdl2-image-2.0.0-r1.ebuild60
3 files changed, 69 insertions, 0 deletions
diff --git a/media-libs/sdl2-image/Manifest b/media-libs/sdl2-image/Manifest
new file mode 100644
index 000000000000..b880e2f1c948
--- /dev/null
+++ b/media-libs/sdl2-image/Manifest
@@ -0,0 +1 @@
+DIST SDL2_image-2.0.0.tar.gz 8398016 SHA256 b29815c73b17633baca9f07113e8ac476ae66412dec0d29a5045825c27a47234 SHA512 300ff078c4c9a74ccc143692630e9c97e25a223bf80661cd5e7d684a25c6ad7760b20778d492d6cc41521dcd2a00e4a76947cf6dffc679fdbd54f430b3906ea6 WHIRLPOOL d2b89f0bcb25eeda168a6a4622777f3d9bd6343dc1f87f50aec69afb85fef71dc28e56ed29e30d906ff999f291cf3ec887d20f471bd870eb734f273fd68b4303
diff --git a/media-libs/sdl2-image/metadata.xml b/media-libs/sdl2-image/metadata.xml
new file mode 100644
index 000000000000..2ee19786249e
--- /dev/null
+++ b/media-libs/sdl2-image/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <use>
+ <flag name='webp'>support loading WEBP images</flag>
+ </use>
+</pkgmetadata>
diff --git a/media-libs/sdl2-image/sdl2-image-2.0.0-r1.ebuild b/media-libs/sdl2-image/sdl2-image-2.0.0-r1.ebuild
new file mode 100644
index 000000000000..973dce66ba17
--- /dev/null
+++ b/media-libs/sdl2-image/sdl2-image-2.0.0-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils multilib-minimal
+
+MY_P=SDL2_image-${PV}
+DESCRIPTION="Image file loading library"
+HOMEPAGE="http://www.libsdl.org/projects/SDL_image/"
+SRC_URI="http://www.libsdl.org/projects/SDL_image/release/${MY_P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="gif jpeg png static-libs tiff webp"
+
+RDEPEND="
+ >=media-libs/libsdl2-2.0.1-r1[${MULTILIB_USEDEP}]
+ >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]
+ png? ( >=media-libs/libpng-1.6.10:0[${MULTILIB_USEDEP}] )
+ jpeg? ( >=virtual/jpeg-0-r2:0[${MULTILIB_USEDEP}] )
+ tiff? ( >=media-libs/tiff-3.9.7-r1:0[${MULTILIB_USEDEP}] )
+ webp? ( >=media-libs/libwebp-0.3.0[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable static-libs static) \
+ --disable-sdltest \
+ --enable-bmp \
+ $(use_enable gif) \
+ $(use_enable jpeg jpg) \
+ --disable-jpg-shared \
+ --enable-lbm \
+ --enable-pcx \
+ $(use_enable png) \
+ --disable-png-shared \
+ --enable-pnm \
+ --enable-tga \
+ $(use_enable tiff tif) \
+ --disable-tif-shared \
+ --enable-xcf \
+ --enable-xpm \
+ --enable-xv \
+ $(use_enable webp) \
+ --disable-webp-shared
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+ multilib_is_native_abi && newbin .libs/showimage showimage2
+}
+
+multilib_src_install_all() {
+ dodoc {CHANGES,README}.txt
+ use static-libs || prune_libtool_files
+}